none
Resolved: SSRS 2008 Sparkline will not display in 2010 PPS dashboard page RRS feed

  • Question

  • The sparkline graphic displays fine when the SSRS report is previewed or rendered, but when the report is referenced in Dashboard Designer, it displays a boxed "X" rather than an image. When the report is deployed as part of a dashboard, the image does not display (in IE8). Right-clicking and selecting Show Picture does not help. The image property is as follows:

    http://foo.com/_vti_bin/ReportServer?http%3a%2f%2ffoo.com%2freports%2fTest.rdl&rs%3ASessionID=beicqp55nntqeh45p2gur245&rs%3AFormat=HTML4.0&rs%3AImageID=IMGCON_1_0

    Applications are spread across several boxes (2008 SSAS data, SharePoint 2010 web front end, 2010 PPS on an application server, and SSRS 2008 on a fourth box. All other features work fine and there are no indications that the problem lies in cross-box talk.

    I modeled the problem as simply as possible to reproduce:
      - SSRS report, no parameters, no shared datasets, with very simple MDX pull, puts data into a sparkline control.
      - Report previews fine, and renders perfectly when deployed.
      - Create PerformancePoint report in Dashboard Designer (type = SSRS report).
      - Report preview in DD will not render the sparkline, which shows as a boxed "X".
      - Add report to new dashboard page and deploy. Image will not render in a browser, but displays as a boxed "X".

    Any ideas? Thank you!

    ********************************************

    October 26th Update:

    I discovered that disabling the "Show toolbar" option in the Editor panel (Report design) in Dashboard Designer is what causes this problem. Enable the toolbar, and the sparkline displays fine. MSFT has entered this as a bug.

    Friday, October 22, 2010 5:09 PM

Answers

  • Hello,

     

    This issue has been confirmed by Microsoft that it is NOT a bug.  It is found to be a confirguration setting. 

     

    It has been found that when SSRS is configured for Trusted Account authentication mode in Sharepoint (Central Admin->General Application Settings->Reporting Services Integration, you need to specify the URL of the report server proxy rather than the direct URL of the report server when you create the report in Dashboard Designer. If you have configured SSRS for Windows authentication, this isn't necessary.

     

    When building the SSRS report in dashboard designer, set the Report Server URL value to http://servername/_vti_bin/reportserver rather than http://servername/reportserver.

    Thank you,

    Heidi Tr - MSFT


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, December 21, 2010 5:13 PM
    Moderator

All replies

  • I am adding the call out on October 26th Update so I can mark as an answer for those to find it easily:

    I discovered that disabling the "Show toolbar" option in the Editor panel (Report design) in Dashboard Designer is what causes this problem. Enable the toolbar, and the sparkline displays fine. MSFT has entered this as a bug.

    Thanks
    Heidi Tr - MSFT

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, October 26, 2010 5:27 PM
    Moderator
  • Hello,

     

    This issue has been confirmed by Microsoft that it is NOT a bug.  It is found to be a confirguration setting. 

     

    It has been found that when SSRS is configured for Trusted Account authentication mode in Sharepoint (Central Admin->General Application Settings->Reporting Services Integration, you need to specify the URL of the report server proxy rather than the direct URL of the report server when you create the report in Dashboard Designer. If you have configured SSRS for Windows authentication, this isn't necessary.

     

    When building the SSRS report in dashboard designer, set the Report Server URL value to http://servername/_vti_bin/reportserver rather than http://servername/reportserver.

    Thank you,

    Heidi Tr - MSFT


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, December 21, 2010 5:13 PM
    Moderator
  • We have a same problem (showing 'X' instead of sparkling indicator in the report) and I tried the above method. So I change the Report sever URL to  http://servername/_vti_bin/reportserver rather than http://servername/reportserver in dashboard designer 2010.

    But it gives the follwoing error:

    Unable to find report specified by url. Please verify both server url and Report url is correct

    Do I need to change this report server proxy URL somewhere as well?

    we are stuck on this from the last one month.

     

     

    Friday, July 29, 2011 6:14 PM
  • I have also tried this method, and get the exact same error as Deepak Kumeri has reported.
    Some additional information:
    My Report Server URL is set to the following: http://serverONE1:80/_vti_bin/ReportServer_ABCD
    My Report URL is set to the following: http://serverTWO/bidev/Reports/reportCategoryFolderName/reportname.rdl
    Is the issue possibly because my Report is not stored on the same server as the Report Server?
    Any help would be greatly appreciated. 



    • Edited by LizSyd Tuesday, October 4, 2011 7:09 AM
    Tuesday, October 4, 2011 7:08 AM