locked
Management Server Health Service State not updating RRS feed

  • Question

  • Hi all,

    I've been noticing in my Dev environment this morning that when I import an update to a sealed management pack, this change is not reflected in the console.  The changes in the MP do seem to be making it successfully to the database.

    I'm aware of the 'Clear Health Cache' process (i.e. stop services, delete the Health Service State folder, restart services on primary and secondary management servers), and this process does provide temporary relief until I need to update another management pack.

    Thankfully, I'm not yet seeing this issue on my Production server, but for a Development server, where I am applying relatively frequent management pack updates, having to remember to flush the cache is seriously annoying, especially considering that the Dev environment seemed to be operating fine without regular cache flushing until recently (this Dev enviroment was rebuilt from scratch no more than 30 days ago).

    Adding to my annoyance is the apparent lack of entries in the Ops Manager log to indicate that SCSM is even aware of an issue.

    Rant over - has anyone else experienced my pain?

    Thursday, November 24, 2016 3:20 AM

Answers

  • Hi Adrian,

    Check if the SQL Broker is enabled. A disabled SQL broker could cause this behaviour.

    -          Check status by running this command:
    SELECT is_broker_enabled FROM sys.databases WHERE name = 'ServiceManager‘

    -          If disabled (0) enable it by running these commands:
    ALTER DATABASE ServiceManager SET SINGLE_USER WITH ROLLBACK IMMEDIATE

    ALTER DATABASE ServiceManager SET ENABLE_BROKER

    ALTER DATABASE ServiceManager SET MULTI_USER

    Regards
    //Anders


    Anders Asp | Lumagate | www.lumagate.com | Sweden | My blog: www.scsm.se


    • Edited by AndersAsp Thursday, November 24, 2016 6:07 AM
    • Marked as answer by Adrian Salone Thursday, November 24, 2016 8:05 AM
    Thursday, November 24, 2016 6:06 AM

All replies

  • Hi Adrian,

    Check if the SQL Broker is enabled. A disabled SQL broker could cause this behaviour.

    -          Check status by running this command:
    SELECT is_broker_enabled FROM sys.databases WHERE name = 'ServiceManager‘

    -          If disabled (0) enable it by running these commands:
    ALTER DATABASE ServiceManager SET SINGLE_USER WITH ROLLBACK IMMEDIATE

    ALTER DATABASE ServiceManager SET ENABLE_BROKER

    ALTER DATABASE ServiceManager SET MULTI_USER

    Regards
    //Anders


    Anders Asp | Lumagate | www.lumagate.com | Sweden | My blog: www.scsm.se


    • Edited by AndersAsp Thursday, November 24, 2016 6:07 AM
    • Marked as answer by Adrian Salone Thursday, November 24, 2016 8:05 AM
    Thursday, November 24, 2016 6:06 AM
  • Ah yes, the ol' SQL Broker.  It wasn't enabled (could have sworn I'd enabled that previously...oh well).

    Thanks Anders, you're a legend as always.


    Thursday, November 24, 2016 8:03 AM