none
secondary DPM Unable to Configure Protection on Primary DPM RRS feed

  • Question

  • Hi all,

    I hope the details below are not too confusing but I want to include sufficient detail to allow for a meaningful investigation. 

    I have the following setup.

    Server-2, Server-3 are backed up by DPM1 (server-1a),  DPM1 is backed up by DPM2 (server-1b).

    All 4 systems are running Windows Server 2003 Standard x64 Edition  Build 3790.srv03_sp2_gdr.101019-0340: service Pack 2).  DPM1 and 2 are running DPM2007.

    Server-3 has a BCM 2007 database that was being successfully backed up to DPM1 and then also through to DPM2.   BPM 2007 was updated to BPM 2010 and the backups on DPM2 have stopped for BPM.

    The error is only showing up on DPM2.  DPM1 is backing up the new BCM 2010 SQL database correctly.

    To get DPM1 to correctly backup the new BCM data I modified the old protection group - deleted the old BCM backup and created a new Protection group with the BCM 2010 data.

    Now DPM2 will not backup the BCM data on DPM1.

    On DPM2 I have tried to delete and add the new BCM backup on DPM1 but I keep getting an error.  The Event Viewer for DPM shows:

    DPM could not start a recovery, consistency check, or initial replica creation job for  C:\Program Files\Microsoft DPM\DPM\Volumes\Replica\server-3.local\SqlServerWriter\Business_Contacts on Server-1a.local for following reason:
     (ID: 3170)
    DPM cannot continue to protect the data on Server-1a.local because there is not enough disk space available on one or more of its volumes. (ID: 57)

     

    There is lots of hard drive space.  When I try and modify the Disk allocation I get the following error:

    DPM cannot access the path C:\Program Files\Microsoft DPM\DPM\Volumes\DiffArea\server-3.local\SqlServerWriter\Business_Contacts\ because part of the path has been deleted or renamed.
    Check the path and enter it again.
    ID: 36
    Details: Internal error code: 0x80990A93

     

    I stop the protection on the problem one and try and add it again.  I get the following message:

    DPM cannot browse GIS-Server-1a.GIStrategies.local because the agent is not responding.
    If you just installed an agent on Server-1a.local, the computer might be restarting. Wait a few minutes after Windows starts for the agent to become available. Otherwise, troubleshoot the problem as follows:
    1) Check recent records from the DPMRA source in the Application Event Log on Server-1a.local to find out why the agent failed to respond.
    2) Make sure that the DPM server is remotely accessible from Server-1a.local.
    3) If a firewall is enabled on the DPM server, make sure that it is not blocking requests from Server-1a.local.
    4) Restart the DPM Protection Agent service on Server-1a.local. If the service fails to start, re-install the protection agent.
    ID: 33
    Details: Internal error code: 0x8099090E

     

    When I go to server-1a to see if there is a DPMRA service none exist.

    In the event log on server-1a I can see the following:  EventID 7031

    The DPMRA service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 60000 milliseconds: Restart the service.

     

    I surfed the web looking for solutions for this and I came across some saying to update the latest SQL updates, and os updates.  I have done that and no improvement.  I tried an optional SQL update that stopped all DPM backups so I uinstalled that to get DPM working again for at least server-1a.

    Anyone have any suggestions.  I'm stumped.


    • Edited by tkman28 Monday, November 28, 2011 10:37 PM
    Monday, November 28, 2011 10:32 PM

All replies

  • Hi Tkman28,

    Are you still having this issue?


    Thanks, Wilson Souza - MSFT This posting is provided "AS IS" with no warranties, and confers no rights
    Thursday, December 22, 2011 7:29 AM
  • Yes this is an ongoing problem.

    Luckily it is our backup to our backup or it would be considered critical.

    I have introduced an non DPM alternative work around for our backup to our backup until this is resolved.


    DPM error question on Microsoft TechNet.

    Wednesday, April 4, 2012 11:24 PM