locked
Can't Install the ATA Gateway: "Failed to connect to the ATA Console. RRS feed

  • Question

  • Hello Experts,

    please i need your urgent support.

    i am facing the below issue when try to install the gateway so please i need your support and direction to solve it.

     




    Monday, April 11, 2016 1:22 PM

Answers

  • issue fixed by installing a fresh Operating system.
    Sunday, April 24, 2016 3:00 PM

All replies

  • Hi,

    did you reinstalled the ATA GW or Center?

    Please check the local certificate store (machine certificates) and check if there some other ATA certificates are present. If yes delete them first - open IE and login to your Center - download the new ATA GW setup - try a new installation.

    If this also fails, there is a log file: C:\Users\<YouUser>\AppData\Local\Temp\Microsoft Advanced Threat Analytics Gateway_*timestamp*.log

    Regards

    Monday, April 11, 2016 1:55 PM
  • I asked this exact question a few weeks ago, here are the things I tried, including my resolution:

    https://social.technet.microsoft.com/Forums/security/en-US/08ccb0c6-a726-401a-a7d0-ae3ba0513a4c/gateway-install-problems-logs-indicate-500-error-on-center?forum=mata

    Monday, April 11, 2016 5:40 PM
  • Hi EliWallic,

    thank you for your support.

    already i tried many times to un-install & re-install both center and GW also Disabled the firewall.

    i Tried again removed certificates and stated again but still the Same above error !

    please direct me what can i do to fix it.

    Log Details:

    [018C:0F18][2016-04-12T12:32:43]i000: ActionType=Install IsAfterRestart=False
    [018C:0F18][2016-04-12T12:35:30]i000: System.AggregateException: One or more errors occurred. ---> System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
       at System.Net.Sockets.Socket.EndReceive(IAsyncResult asyncResult)
       at System.Net.Sockets.NetworkStream.EndRead(IAsyncResult asyncResult)
       --- End of inner exception stack trace ---
       at System.Net.TlsStream.EndWrite(IAsyncResult asyncResult)
       at System.Net.PooledStream.EndWrite(IAsyncResult asyncResult)
       at System.Net.ConnectStream.WriteHeadersCallback(IAsyncResult ar)
       --- End of inner exception stack trace ---
       at System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult, TransportContext& context)
       at System.Net.Http.HttpClientHandler.GetRequestStreamCallback(IAsyncResult ar)
       --- End of inner exception stack trace ---
       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at Microsoft.Tri.Common.Data.Common.ManagementClient.<PostAsync>d__1`1.MoveNext()
       --- End of inner exception stack trace ---
       at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
       at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification)
       at System.Threading.Tasks.Task`1.get_Result()
       at Microsoft.Tri.Common.Data.Common.ManagementClient.RegisterGateway(String managementServerUrl, String managementCertificateThumbprint, String managementAccountName, String managementAccountPassword, NetbiosName gatewayNetbiosName, X509Certificate2 gatewayCertificate)
    ---> (Inner Exception #0) System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
       at System.Net.Sockets.Socket.EndReceive(IAsyncResult asyncResult)
       at System.Net.Sockets.NetworkStream.EndRead(IAsyncResult asyncResult)
       --- End of inner exception stack trace ---
       at System.Net.TlsStream.EndWrite(IAsyncResult asyncResult)
       at System.Net.PooledStream.EndWrite(IAsyncResult asyncResult)
       at System.Net.ConnectStream.WriteHeadersCallback(IAsyncResult ar)
       --- End of inner exception stack trace ---
       at System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult, TransportContext& context)
       at System.Net.Http.HttpClientHandler.GetRequestStreamCallback(IAsyncResult ar)
       --- End of inner exception stack trace ---
       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at Microsoft.Tri.Common.Data.Common.ManagementClient.<PostAsync>d__1`1.MoveNext()<---

     

    Tuesday, April 12, 2016 9:52 AM
  • Hi Bryan Loveless,

    i read carefully your Post, and already using the ATA Self-Signed Certificate and for the service read only user Password length (8 Characters).

    i tried again but still the Same error !


    Tuesday, April 12, 2016 9:55 AM
  • System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host

    Did you check you firewall or network configurations?

    I had the same issue, because of an domain difference. The Center and GW is within the same Domain?

    You can enter an AD user within your Center-Configuration: domain\user this user is used to access the AD With the user you want to install the GW is also used to register the GW on the Center.

    Important: This user must be a member of the local group "Microsoft Advanced Threat Analytics Administrators" on the Center server

    Tuesday, April 12, 2016 12:06 PM
  • Thank you EliWallic for your support and fast reply.

    both center and Gw in the Same Domain, same VLAN. also i tried domain\user and double checked that user is a member of local group on the center  "Microsoft Advanced Threat Analytics Administrators

    Still the Same !



    Tuesday, April 12, 2016 12:54 PM
  • issue fixed by installing a fresh Operating system.
    Sunday, April 24, 2016 3:00 PM
  • I've had an issue with GatewayInstallationConfiguration.json file (included in Microsoft ATA Gateway Setup.zip).

    Certificate thumbprint was just wrong even after multiple downloads from Center server.

    p.s. I've edited JSON with proper thumbprint and installation completed successfully.

    Regards,

    Marko


    Monday, October 17, 2016 2:53 PM
  • issue fixed by installing a fresh Operating system.

    Sorry mate, can you explain this please?



    Friday, July 14, 2017 4:01 AM