locked
How to restore "Always ignore" selection pressed on Low IL compat / EPM mode question in IE10 on Windows 7 x64? RRS feed

  • Question

  • How to restore "Always ignore" selection pressed on Low IL compat mode / EPM question in IE10 on Windows 7 x64?

    In a previous question I asked where the Whitelist is and how to modify it but now I have clients that seem to gotten stuck after pressing "Always ignore" and then the question to run outside EPM does not come up anymore and also the Whitelist stops working.

    I need to get the "Question" back so the user can select to disable EPM on a per site basis (and to re-enable the Whitelist already set by login script).


    /Aldus


    • Edited by Aldus_Monitor Monday, April 22, 2013 7:51 AM Spelling
    Monday, April 22, 2013 7:51 AM

Answers

  • Facts and solutions (thanks Robert A. for giving the correct pointers):

    * Disabled addons are still loaded by IE11 but they are in fact "disabled" and will not be used.

    * Tracking protection can be shown as a crossed gray circle WITHOUT being shown in the browser adressbar and it does not have any "ALT" text sign to give a tooltip explaining if it is a "ActiveX filtering"=blue or a "Tracking protection"=gray.

    * Enabling the "Adobe PDF Reader" addon now works with latest IE11 and compability upgrades in Win7 x64. It correctly brings up a message (at the bottom of the browser) to let you choose to disable EPM (= "Run control" button) if you disable Tracking Protection.

    * When this question was originally posted there was another prompt with "Always ignore" but that prompt has been replaced with "Run control"/"Don't run". I do not know if you can revert the "Run control" or if it will permanently allowed.

    Regards


    /Aldus



    • Marked as answer by Aldus_Monitor Monday, April 7, 2014 7:41 AM
    • Edited by Aldus_Monitor Monday, April 7, 2014 7:48 AM Historical note
    Monday, April 7, 2014 7:41 AM

All replies

  • HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Safety\ActiveXFilterExceptions

    Rob^_^

    Monday, April 22, 2013 9:11 PM
  • Hi!

    Thank you for your answer. However it seams to relate to ActiveXFiltering which is something else than EPM = Enhanced Protected Mode.

    My question is about how to restore the display of this text:
    http://i.stack.imgur.com/UtWG4.png
    if you mistakenly pressed "Always ignore"
    Another picture:
    http://ie.microsoft.com/testdrive/ieblog/2012/Mar/14_EnhancedProtectedMode_3.png
    (this one does not have "Always ignore" button, maybe a beta version?)

    Regards


    /Aldus

    Tuesday, April 23, 2013 10:09 AM
  • Additional information:

    If you have a plugin and disable it (i.e. Adobe Reader or Adobe PDF Link helper) then you still get the dreaded "Stop Sign Circle" (crossed-circle) instead of a Open/SaveAs dialog for that filetype or a EPM warning.

    Seams like EPM detects that something would trigger a Plugin and displays the stop-sign-circle but then the "... Disable ... Always ignore" message does not come up and you still can not download.


    /Aldus

    Thursday, April 25, 2013 12:53 PM
  • If you have a plugin and disable it (i.e. Adobe Reader or Adobe PDF Link helper) then you still get the dreaded "Stop Sign Circle" (crossed-circle) instead of a Open/SaveAs dialog for that filetype or a EPM warning.

    In Manage Add-ons what is the Architecture for those?  I suspect if it shows both and not just 32-bit you would not be testing what you want.

    FWIW I have one for Microsoft Update Catalog which is only 32-bit and it shows that it has been allowed only on Microsoft.com.   Let's use the Disable all sites button and see what happens if I try to visit the MUC now...  Oh.  I get a prompt but not the one you want.  I suppose the next test would involve actually uninstalling it instead.  I'll let someone else be the guinea pig for that one.   ; )

     
    Good luck

     
    Robert Aldwinckle
    ---

    Thursday, April 25, 2013 5:49 PM
    Answerer
  • Hi,

    some sites use javascript for activeX support detection... if activeX filtering is enabled (for that site) it looks like the control is not enabled or not installed.

    the common design pattern is to use fallbacks for object tags I/o js feature detection without first feature testing for ActiveX filtering.

    see hbo.com


    Rob^_^

    Friday, April 26, 2013 12:19 AM
  • Hi again!

    Maybe I should say what I would like:
    * I would like to allow following extension/plugin: Java
    * I would like everyone to be able to read PDF by only clicking on link.
    * If site requires Java I would like to be able to click Disable on the EPM prompt to run that page in 32-bit (or to script in an exception in TabProcConfig)
    * Sites that host Adobe PDF documents should not be run outside of EPM but rather just open the PDF externally in Acrobat Reader (without "Save as target")

    Problems right now:
    * Some sites with Java does not show the EPM warning and thus not allowing to "Disable EPM" for that site (Java is 64-bit but not EPM aware)
    * Sites with PDF-files give the stop-circle picture if the Adobe PDF is disabled (2 extensions and both are 32-bit).
    (test with this link: http://www.adobe.com/enterprise/accessibility/pdfs/acro6_pg_ue.pdf )
    * Sites with PDF-files give the EPM warning if the Adobe PDF is enabled, but I do not want to run those sites outside of EPM.

    Might be a bug with disabled Adobe Helper:
    http://connect.microsoft.com/IE/feedback/details/781477/ie10-on-win7x64-enhanced-protected-mode-and-adobe-reader


    /Aldus

    Friday, April 26, 2013 6:25 AM
  • Oh! I forgot:
    Start>Adobe Reader>Edit>Preferences>Internet>uncheck "Use webbrowser to open PDF documents."
    * In Adobe Reader 10.x.x it does not help changing it
    * In Adobe Reader 11.x.x that setting does not exist anymore


    /Aldus

    Friday, April 26, 2013 6:29 AM
    • Edited by feifei82 Wednesday, May 29, 2013 3:38 PM
    Wednesday, May 29, 2013 2:58 PM
  • Now I have found out something more: When clicking a link inside a webpage that goes to a PDF you will normally be offered the "Ignore/Disable" choice. But when pasting a link directly to a PDF (try this one: http://www.adobe.com/enterprise/accessibility/pdfs/acro6_pg_ue.pdf ) then you will only get the blocking sign (which might be an ActiveXFilter BUT that option is not enabled for me but EPM is) but no prompt to disable EPM.

    My guess is that EPM implicitly activates ActiveXFiltering but there is a bug to the "Ignore/Disable" message from the EPM. And since ActiveXFiltering is not manually activated there is no way to temporary disable that either. So essentially you are stuck with just disabling EPM (or dig into registry hacks).

    So bottom line:
    * There is a bug in the implementation of EPM that makes some sites stop working since the "Ignore/Disable" prompt is not shown.

    P.s.
    Can anyone with connections help verify this problem with MS?


    /Aldus


    • Edited by Aldus_Monitor Wednesday, June 12, 2013 7:37 AM Spelling
    Wednesday, June 12, 2013 7:36 AM
  • In IE 10 go to Tools > Delete browsing history... > make sure "history" checkbox is selected! > press delete button. This action will bring back EPM "Disable" and "Always Ignore" buttons...

    Wednesday, September 4, 2013 11:20 PM
  • This sound interesting! Could this be archived for only one website by manually deleting some registry key (or file in the OS) for that site?


    /Aldus

    Thursday, September 5, 2013 6:50 AM
  • This issue is effecting a large majority of my computers.  I have a ticket open with Adobe too.  Will see if this ever gets resolved.
    Wednesday, December 18, 2013 6:48 PM
  • With the new IE11 the text on the blocking message has changed "Run control" / "Don't run". This seams to be even worse since the effect of pressing the buttons seams to mean "Allways run control on this site" / "Always ignore" just as before. Now you just don't get the information that it will be remembered forever (without a GUI way to revert just that site it seams).

    And this link still does not produce any selection message for me:
    http://www.adobe.com/enterprise/accessibility/pdfs/acro6_pg_ue.pdf
    Just the dreaded "ActiveX filtering sign".

    Microsoft and Adobe need to sort this out.

    /Aldus


    /Aldus

    Thursday, December 19, 2013 7:34 AM
  • Please let us know what answer you get from Adobe.

    /Aldus


    /Aldus

    Thursday, December 19, 2013 7:36 AM
  • And this link still does not produce any selection message for me:
    http://www.adobe.com/enterprise/accessibility/pdfs/acro6_pg_ue.pdf

    On W7sp1?  FWIW on it I have Foxit installed which would be handling that request.  However, on W8.1 I got a prompt which could either open in MS Reader (MUF app) or Save or both.  I'm on W8.1 ATM but will try to remember to see what Foxit does on W7sp1.  In any case, this would give you two cases to compare for their essential differences, e.g. using ProcMon.  You could use this (slightly dated) document for a reference.  Much easier to have it first than discover it the other way around.  <eg>



    Robert Aldwinckle
    ---

    Thursday, December 19, 2013 6:15 PM
    Answerer
  •  what Foxit does on W7sp1

    A different prompt but same functions.  However, I had the Foxit extension disabled, so when I requested Open, nothing more happened.  When I enabled it I got the same initial prompt, then another one about EPM(?)   The extension is only 32-bit but I am running without EPM set?  In any case after those two prompts the .pdf was rendered without further intervention.   YMMV. 

    Slightly strange IMO is that the Foxit extension does not show up in Currently loaded add-ons list, only in All Add-ons list.  However, checking its More Information details shows why I get at least one of those prompts:  I don't have it "approved" for anything.   <eg>



    Robert Aldwinckle
    ---

    Thursday, December 19, 2013 8:56 PM
    Answerer
  • Just tried something and it did work for me, to bring back the "disable  / always ignore" prompt. I am running Windows 7 sp1, with IE 10, Adobe Reader 11.

    I changed the value of:

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Safety\PrivacIE\DisableToolbars

    from 1 to 0. It is a REG_DWORD type.

    As soon as I did, clicking on a link to a PDF in IE brought up the prompt again rather than the tiny black box.

    This may not work for anyone else, anywhere - but I thought I would share, just in case.

    Thursday, April 3, 2014 2:03 PM
  • I am sorry to say that I still can not make the link (posted earlier) with this registry trix:http://www.adobe.com/enterprise/accessibility/pdfs/acro6_pg_ue.pdf

    It still opens in a white page with the little crossed-over-circle in it.
    I have also updated to the latest changes on both IE and Windows 7 compability updates. Still no-go with EPM activated.

    Regards


    /Aldus

    Thursday, April 3, 2014 2:16 PM
  • little crossed-over-circle in it.

    A blue one?  Sounds like ActiveX Filtering (as Rob first guessed.)

    Have you tried using ProcMon yet?   Take two traces, one of the problem and one of it working normally and compare for their essential differences.  E.g. filter first with Process and Thread, find a divergence and then back up with more detail from there to find out what causes that difference.



    Robert Aldwinckle
    ---

    Thursday, April 3, 2014 5:46 PM
    Answerer
  • Hi!

    It is same as the ActiveXFiltering sign yes! But ActiveXFiltering is not "explicitly" turned on (only difference when I try is EPM on and off). (On my Windows 7x64 IE11 it is a "gray" circle).

    I have not tried ProcMon yet. I am still hoping that Microsoft And Adobe solves this BUG. It has to be one of the most common cases of all when it comes to an external viewer embedded in IE11.

    If I recall (from my wifes laptop, but not tried in corporate environment) this correctly works just fine in Windows 8.1x64 with IE11 and EPM on. There you will get the "Run control" warning and you can bypass EPM.

    Regards


    /Aldus

    Friday, April 4, 2014 6:59 AM
  • same as the ActiveXFiltering sign

    a "gray" circle

    So it's not the same.  ActiveXFiltering is definitely blue.  And there would be another indicator in the Address bar.

    still hoping that Microsoft And Adobe solves this BUG. It has to be one of the most common cases of all when it comes to an external viewer embedded in IE11.

    You have just reminded me of another closely related case I have to test when I get to a W7sp1 Pro X64 system I have intermittent access to

    http://answers.microsoft.com/en-us/ie/forum/ie11-windows_7/videos-still-will-not-play-in-ie-11-you-force-us/5b0b6d45-0c80-411e-adc3-ca90e194539a?page=2 

    So the common factors are embedded media, IE11 and W7sp1.  In the case of the video though I'm not sure where W8.1 is getting its control--seems not to be from Flash support and not something that is controllable by Manage Add-ons.  But I doubt that it really matters which control it is; the type of it probably matters more.

     

    In case it gets us somewhere diagnosing your case, can you try that example too please?

     



    Robert Aldwinckle
    ---

    Friday, April 4, 2014 5:47 PM
    Answerer
  • http://www.adobe.com/enterprise/accessibility/pdfs/acro6_pg_ue.pdf

    It still opens in a white page with the little crossed-over-circle in it.

    How about trying a different tack from diagnosis?  E.g. you could stop trying to open the .pdf using ActiveX and instead get the prompt about what you want to do:  Open, Save, or Save as...   Then try changes from that.  To do that with Acrobat Reader you would just use its Preferences menu to uncheck Open in browser  (Ctrl-k  etc.  I don't have AR in my Surface RT so I'm just going on memory for this option.)



    Robert Aldwinckle
    ---

    Friday, April 4, 2014 7:01 PM
    Answerer
  • http://www.adobe.com/enterprise/accessibility/pdfs/acro6_pg_ue.pdf

    It still opens in a white page with the little crossed-over-circle in it.

    How about trying a different tack from diagnosis?  E.g. you could stop trying to open the .pdf using ActiveX and instead get the prompt about what you want to do:  Open, Save, or Save as...   Then try changes from that.  To do that with Acrobat Reader you would just use its Preferences menu to uncheck Open in browser  (Ctrl-k  etc.  I don't have AR in my Surface RT so I'm just going on memory for this option.)



    Robert Aldwinckle
    ---

    That's bug number 2? One of the first things that I tried was to disable the Adobe ActiveX helper. So it is still "disabled" from that try, but strangely still present on the "Currently loaded addons". So I guess that disabling add-ons is not working on IE11 on Win7x64?

    I have not tried uninstalling Adobe Reader and then reinstalling it without having browser support: Is there a way to just uninstall the browser add-on? I think this would be an acceptable solution.

    Regards


    /Aldus

    Monday, April 7, 2014 7:02 AM
  • In case it gets us somewhere diagnosing your case, can you try that example too please?

    I got an interesting result from trying to disable "Tracking Protection Lists". Now I get a Gray/Black Square with a gray/black "close button" inside it. Its similar in size and position to the Crossed circle. Is is just a picture and does not interact in any way. Adobe PDF Reader addon shows as loaded but is "disabled". Version 11.0.6.70.

    Regards


    /Aldus

    Monday, April 7, 2014 7:20 AM
  • Next test: Enable the Adobe Reader Addon: Now I get the "Run control and skip EPM" message back! Very interesting indeed! So the tracking protection somehow triggers from the use of the Adobe Reader addon? I only use the lists provided on the IEGallery page.

    Can it be that there is some url that is blocked that the Addon is using? Or is it just logging somewhere what PDF:s I am trying to read? That would just be sad.

    Regards


    /Aldus

    Monday, April 7, 2014 7:30 AM
  • Facts and solutions (thanks Robert A. for giving the correct pointers):

    * Disabled addons are still loaded by IE11 but they are in fact "disabled" and will not be used.

    * Tracking protection can be shown as a crossed gray circle WITHOUT being shown in the browser adressbar and it does not have any "ALT" text sign to give a tooltip explaining if it is a "ActiveX filtering"=blue or a "Tracking protection"=gray.

    * Enabling the "Adobe PDF Reader" addon now works with latest IE11 and compability upgrades in Win7 x64. It correctly brings up a message (at the bottom of the browser) to let you choose to disable EPM (= "Run control" button) if you disable Tracking Protection.

    * When this question was originally posted there was another prompt with "Always ignore" but that prompt has been replaced with "Run control"/"Don't run". I do not know if you can revert the "Run control" or if it will permanently allowed.

    Regards


    /Aldus



    • Marked as answer by Aldus_Monitor Monday, April 7, 2014 7:41 AM
    • Edited by Aldus_Monitor Monday, April 7, 2014 7:48 AM Historical note
    Monday, April 7, 2014 7:41 AM