locked
Can't expand folder for shared mailbox RRS feed

  • Question

  • Hi,

    We had a little problem with shared mailboxes last week where some users lost theirs.

    Now there is someone who can't access their shared mailbox no matter what. They got their full access added back during last week, but it never showed up.

    Today we tried to manually add it to the users Outlook and received the following message whenever we tried to expand the mailbox.

    "Can't display the folder. Can't open the folders. Can't reach the file C:\users\xxxxx\AppData\Local\Microsoft\Outlook\mailaddress.ost because it is being used by another process. Close the program that's using the file and try again. You may need to restart your computer".

    We have tried clearing the folder above, making a new outlook profile and re-installing Office but none of these have worked.

    I should mention that user can access the mailbox just fine through OWA.

    Do you have any ideas how we can resolve this?

    • Moved by Manu Meng Wednesday, October 2, 2019 1:50 AM relocate
    Tuesday, October 1, 2019 1:51 PM

All replies

  • Hi,

     

    Thanks for visiting our forum, here we mainly focus on general issues about Exchange server, while your question is more related to Outlook client. So I'll move your thread to the dedicated forum for Outlook.

     

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thanks for your understanding and hope your question will be resolved soon.

     

    Regards,

    Kelvin Deng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com


    Wednesday, October 2, 2019 1:49 AM
  • Hi Alan,

    I can advise you to follow the steps below:

    • In the same PowerShell window, run the cmdlet below to disable AutoMapping for the user. Change the "sharedmailbox" section with the identity (email address, alias or name) of the shared mailbox and the "problematicuser" with the identity of the user:

    Add-MailboxPermission -Identity sharedmailbox -User problematicuser -AccessRights FullAccess -InheritanceType All -AutoMapping $false

    • Close Outlook in problematic user's client, and delete the current and all old Outlook profiles:
      Navigate through "Control Panel > User Accounts > Mail (Microsoft Outlook xx) > Show Profiles" and remove all profiles there which are related to the current account.

    • If there are any OSTs left after this, delete them or move them to an irrelevant location.

    • In the same PowerShell window, run the cmdlet below to re-enable AutoMapping for the user:

    Add-MailboxPermission -Identity sharedmailbox -User problematicuser -AccessRights FullAccess -InheritanceType All -AutoMapping $true

    • Create a new Outlook profile and allow it some time before the shared mailbox is automatically mapped.


    If the problem persists even after this, try to remove all permissions for the user on the shared mailbox instead of disabling AutoMapping and follow the same steps afterwards. 

    Regards,
    Burak V.




    • Edited by Burak VAROL Wednesday, October 2, 2019 9:30 AM
    Wednesday, October 2, 2019 9:25 AM
  • Hi Alan,

    Just check in to see if the suggestions of Burak VAROL was helpful.

    Besides, you can also try to clear the registry value of Outlook.

    1. Close your Outlook client.
    2. Press Win + R to open Run, type "regedit" and press Enter.
    3. Go to HKEY_CURRENT_USER\Software\Microsoft\Office\X.0\Outlook
    4. Rename the "Outlook" folder to "Outlook-1"
    5. Restart your Outlook and see if there is any difference.

    (Important: Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur. )

    Hope this can be helpful.

    Regards,

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, October 3, 2019 6:27 AM
  • Hi Alan,

    Have you got the issue fixed?

    I'm writing to see if the reply above is helpful to you. If yes, would you mind helping mark the reply as answer? So that others who might have a similar question can benefit from your thread? Thanks for your understanding and support.

    Regards, 

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Monday, October 7, 2019 9:24 AM
  • Hi,

    Here I will provide a brief summary of this post for your information. This will make answer searching in the forum easier!

    Request/Expectation:

    "Can't display the folder. Can't open the folders. Can't reach the file C:\users\xxxxx\AppData\Local\Microsoft\Outlook\mailaddress.ost because it is being used by another process. Close the program that's using the file and try again. You may need to restart your computer".

    Solution Summary:

    Please follow the steps below:

    • In the same PowerShell window, run the cmdlet below to disable AutoMapping for the user. Change the "sharedmailbox" section with the identity (email address, alias or name) of the shared mailbox and the "problematicuser" with the identity of the user:

    Add-MailboxPermission -Identity sharedmailbox -User problematicuser -AccessRights FullAccess -InheritanceType All -AutoMapping $false

    • Close Outlook in problematic user's client, and delete the current and all old Outlook profiles:
      Navigate through "Control Panel > User Accounts > Mail (Microsoft Outlook xx) > Show Profiles" and remove all profiles there which are related to the current account.

    • If there are any OSTs left after this, delete them or move them to an irrelevant location.

    • In the same PowerShell window, run the cmdlet below to re-enable AutoMapping for the user:

    Add-MailboxPermission -Identity sharedmailbox -User problematicuser -AccessRights FullAccess -InheritanceType All -AutoMapping $true

    • Create a new Outlook profile and allow it some time before the shared mailbox is automatically mapped.


    If the problem persists even after this, try to remove all permissions for the user on the shared mailbox instead of disabling AutoMapping and follow the same steps afterwards. 



    Reference Links:

    No.

    Regards, 

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.




    Thursday, November 14, 2019 7:36 AM