none
Since KB3194798 "EnableLinkedConnections" is not working anymore (Mapping Shares, MMC on Network Share)

    Question

  • Hello together,

    since we have installed KB3194798 we can not open Management Consoles (*.MMC) if they are stored on Network Shares. We had this Problem also in Windows 7 and solved it with the Regkey "EnableLinkedConnections". If we uninstall the Patch, its working fine again.

    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\ EnableLinkedConnections =1

    Since these are cumulative updates, we can't uninstall just the problematic thing.

    Has anyone else been having this issue? Is there a workaround?

    Same problems can come up if you Map shares with a LogonScript. I see some others have the same problem!

    Regards

    Florian

    Wednesday, October 19, 2016 11:26 AM

All replies

  • Hi Afraskai,

    Is it available to access the network share directly from the Windows Explorer? Have you got any error or warning messages or are there any error messages recorded in the Event Viewer(Windows Logs\Application, System)?

    "Same problems can come up if you Map shares with a LogonScript"
    Try to configure it as a startup script.

    Best regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, October 20, 2016 2:05 AM
    Moderator
  • Hi MeipoXu,

    in here we don´t have any Problems with Network Shares (we map them with GPO Preferences). We can access the Shares with Explorer and with commandline.

    The Problem we have is described in this Article:

    https://technet.microsoft.com/de-de/library/ee844140%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396

    The solution worked very well till we installed the patch KB3194798.

    In my link "Same problems can come up if you Map shares with a LogonScript" others had the Problem with Network Shares - sorry for that misdirection.

    Sorry the Message is in german, I post and try to translate it :)

    "The File "P:\...Management.msc" cannot be opened. Possibly the file does not exist, it´s not a MMC Console or it is created with a higher Version. It could be also possible that you dont have permissions to Access this file."

    Regards

    Florian


    • Edited by Afraskai Thursday, October 20, 2016 7:57 AM
    Thursday, October 20, 2016 7:53 AM
  • Hi Afraskai,

    According to the error messages, it seems that there is a compatibility issue or a permission issue.
    Please check the MMC version from its properties. Ensure it is corresponding to your system`s mmc version(C:\Windows\System32\MMC.exe).

    To verify whether it is related to the UAC, we could try to disable UAC temporarily to have a test. Try to change UAC level. I am not sure how you open the MMC. If it is possible, please try to use an administrator account or run it as administrator.

    Best regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, October 21, 2016 6:47 AM
    Moderator
  • Hello MeipoXU,

    thanks for your Answer, the Problem is not the MMC, because the same MMC can be opened if i uninstall KB3194798!

    Also if the patch is installed and i copy the mmc File locally, it works! Since the Patch the regkey "EnablelinkedConnections" is not honored anymore.

    We open the MMC via navigating with Explorer to the Network Drive\Path, then we doubleclick the file.

    If UAC is on Default Setting an you are logged on a an Administrator, UAC Comes up. After that the Error Message is comming up.

    If UAC is fully disabled, UAC is not comming up, but the errormessage is comming up.

    Friday, October 21, 2016 8:04 AM
  • Hi, i found some people which have the same Problem with Windows 8.
    Friday, October 21, 2016 1:45 PM
  • We have the same problem with a Windows 10 1607 user with EnableLinkedConnections = 1 no longer having any effect after the installation of KB3194798. The setting was in use due to some applications not showing mapped network drives when UAC is turned on and a program runs elevated.

    After uninstalling this KB, the behavior of users being able to see their mapped drives in affected programs has resumed.

    I'm guessing Microsoft may have intentionally disabled this behavior, possibly due to it being considered a security risk. However, what are the alternatives? Discontinue use of these business-critical applications? Disable UAC?

    Friday, October 21, 2016 7:41 PM
  • Hi, 

    Same problem here. After installing KB3194798 the network drives are no longer usable by elevated apps. But it seems only to affect network drives pointing to a DFS-share. I have created a non-DFS share and added an additional network drive and it is still working in elevated apps.

    I have now removed KB3194798 and blocked in WSUS, migrating to non-DFS shares is no Option.

    Saturday, October 22, 2016 7:09 AM
  • Hi,

    we have the Apps also on DFS Shares - i´ll try it tomorrow what happens if it´s not a DFS Share. Im happy to have only 120 Pilot Windows 10 machines...

    Maybe there is a option to fix it on the DFS Servers?!

    Sunday, October 23, 2016 3:44 PM
  • Sorry, but uninstalling the Patch is NO solution. Patches are now cumulative, we won´t have any security risks etc. And we will have the Problem next month again.

    @MeipoXu: The best option would be that you contact internal people which can help with a solution. I dont want to open a support ticket and pay 500$ for a failure which is not our fault.

    Update 2016-10-24: The Problem exists only on DFS Shares. Regular Shares are working.

    Thanks for your Feedback.

    Florian



    • Edited by Afraskai Monday, October 24, 2016 9:18 AM
    Monday, October 24, 2016 8:18 AM
  • Because of KB3194798, we started having an issue w/ an program (AutoCAD) that needs to be run as Administrator for our network customization, but since installing KB3194798...  AutoCAD would not see DFS network drive letters.

    To resolve this, I am now using Group Policy to deploy network drive mappings, instead of a login script.

    Changing the way we do drive mappings, is a large undertaking, but we planning to do this soon anyway, but now we have KB3194798 making this a priority. 

    Hope this helps someone. 

    Tuesday, October 25, 2016 4:31 PM
  • Are there any Updates on this?
    Thursday, October 27, 2016 8:28 AM
  • Same problem here sorry to say!

    All centralized logon scripts that were dependent of EnableLinkedConnections suddenly stopped working. All users need to run them manually as a temporary solution...

    Is this by design or a bug??


    Thursday, October 27, 2016 10:24 AM
  • Anyone willing to work with me to open a support case on this issue?  If so, email me at Susan-at-msmvps.com (change the -at- to @)
    Thursday, October 27, 2016 4:19 PM
  • The product team is aware of the problem and is an official known issue
    with the update.
    
    
    Was told the following:
    At this time there is no ETA on a fix.
    
    We have been told to use the following workarounds in the meantime:
    
    
    
    1. Mapping the drive to the direct UNC path rather than using DFSN
    
    2. Using Group Policy to deploy network drive mappings, instead of a
    login script.
    
    Monday, November 07, 2016 9:56 PM
  • Hello Susan, thank you so much for your Feedback!
    Tuesday, November 08, 2016 3:41 PM
  • Hi

    KB3194798 does also affect network drives mapped via GPO :(

    Tuesday, November 08, 2016 8:07 PM
  • Does November 8, 2016—KB3198586 (OS Build 10586.679) fix the Issue? This Update is not released internal yet...so I cant test it.

    November 8, 2016—KB3198586 (OS Build 10586.679)

    --> Addressed issue that prevents users from accessing network resources after logon after they’ve installed KB3185614

    Known issue in this security update (KB3185614)

    Symptoms

    Consider the following scenario:
    • You try to access a file server by using the SMBv1 protocol through an application such as File Explorer.
    • The application uses the CONNECT_INTERACTIVE flag for the WNetAddConnection API.
    • You're using a computer that's logged in through Microsoft Account credentials.
    • The network credentials you're using to access the file server share are not present in Credential Manager.
    • The firewall profile on the computer is set to Public.
    In this scenario, you receive the following error message:
    A specified logon session does not exist. It may already have been terminated.


    Wednesday, November 09, 2016 2:33 PM
  • Unfortunately, this update is only for Windows 10 1511 and not for 1607 :(

    Monday, November 14, 2016 6:20 AM
  • No fix in December Updates. What and when will be the solution?
    • Edited by WisiM Thursday, December 15, 2016 4:58 PM
    Thursday, December 15, 2016 4:57 PM
  • I opened a case on this issue. Microsoft stated a fix would be released in February. They couldn't tell me if it would be in the cumulative or in a separate update.
    Monday, December 19, 2016 7:31 PM
  • You should consider that all fixes will now be part of a cumulative update.
    Tuesday, December 20, 2016 1:22 PM
  • I opened a case on this issue. Microsoft stated a fix would be released in February. They couldn't tell me if it would be in the cumulative or in a separate update.

    Thanks, that was next on my list, too. So for now I can do other things ;-)
    Thursday, December 22, 2016 9:31 AM
  • Our organization is still testing with v1511 and I can confirm that the issue with EnableLinkedConnections and DFS still exists even after applying KB3198586 (10586.679) in case anyone else comes across this thread.

    I'll be applying KB3205386 (10586.713) this afternoon to see if that resolves the issue.

    Tuesday, December 27, 2016 7:39 PM
  • As of today, Jan 18, we are having the similar issues. I hope MS will release a fix soon. 
    Thursday, January 19, 2017 12:11 AM
  • Microsoft !!!

    Fix this and do not add Xbox crap to the settings app!

    Friday, February 17, 2017 11:25 AM
  • Wow, I too face the same issue. I know the preferred method is to use GPO to manage drive mapping; however, in certain cases it’s not feasible and much easier to granularly control drive mapping via script.
    Friday, February 17, 2017 7:31 PM
  • I have the same problem with Windows 10 Pro 1067 when the users are local administrator and unit mapped to DFS. 

    I hope that microsoft resolve it soon.

    My provisional solution is:

    We locate the logon script file:

    \\domain.com\sysvol\domain.com\Policies\{XXXX-XX-XXX-XXXX-XXXX}\User\Scripts\Logon\login.vbs

    Do a bat file that execute the another file:

    C:\Windows\SysWOW64\cmd.exe /c cscript "\\domain.com\sysvol\domain.com\Policies\{XXXX-XX-XXX-XXXX-XXXX}\User\Scripts\Logon\login.vbs"

    Do a task, that it's execute when the users do login, with a 30 seconds delay and run our bat file. 

    All this can be done through group policies.

    We can use it provisionally until Microsoft provides us with a definitive solution.



    www.juegosred.com En la Red de Redes


    Monday, February 20, 2017 12:34 PM
  • Did March Cumulative Update for Win10 Ent 1607 fix this issue?

    https://support.microsoft.com/en-us/help/4013429/windows-10-update-kb4013429

    Thursday, March 16, 2017 1:32 AM
  • After installing KB4013429 and applying the following registry string, I was able to map network drives via login script.

    New-ItemProperty -Path "HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" -PropertyType DWORD -Name 'EnableLinkedConnections' -Value 1

    I'm not sure, but a few days ago, I could of sworn that Microsoft mentioned fixing the mapped drives issue in the article. maybe I imagine it.....

    • Proposed as answer by savednotes Tuesday, March 21, 2017 6:10 PM
    Tuesday, March 21, 2017 4:57 PM