locked
App-V Client Upgrade from 5.0 SP2 to App-V 5.1 HF4 RRS feed

  • Question

  • I'm testing an App-v package created using 5.0 SP2 sequencer by deploying it on a upgraded App-V Client from 5.0 SP2 to App-V 5.1 HF4.

    It appears installation of the package went through without any issues. However, when I launch the shortcut via start menu or desktop shortcut I'm getting below error :

    ---------------------------
    Microsoft Visual C++ Runtime Library
    ---------------------------
    Runtime Error!

    Program: C:\ProgramData\App-V\C8423F27-512E-4C49-AC7A-849515B1A5...

    R6034
    An application has made an attempt to load the C runtime library incorrectly.
    Please contact the application's support team for more information.
    --------------------------------------------------------------------------------------------

    I investigated further and saw the MSVCP and MSVCR libraries reside in same directory where application executable is present.

    Also, package works perfectly on older App-V client - 5.0 SP2

    Any assistance is appreciated.

    Thursday, November 3, 2016 7:29 PM

All replies

  • If possible I would try running the package through the 5.1 sequencer to see if that makes any difference (select update, choose the package but don't actually update anything).

    You'd have to do a lot of digging to get to the root cause but I'd put effort to updating the packages to 5.1 first.

    Also it might be worthwhile to (just in case) load the software natively onto the 5.1 machine and see if that works, and see if that makes the App-V package work.  I can say from personal experience I've been fooled by the, 'those environments are the same' statement before.  Wouldn't be a bad idea.

    Thursday, November 3, 2016 9:41 PM
  • Thanks for your inputs agallucci.

    I've now tried both options:

    1. Updating existing .appV file using 5.1

    2. Running native install using 5.1

    In both of the above cases, I'm getting the same 'Runtime Error!'

    I'm not sure if this is an issue with App-V 5.1 in handling Libraries which resides in root folder.

    Coz I've never seen this issue with 5.0 SP2

    ---------------------------
    Microsoft Visual C++ Runtime Library
    ---------------------------
    Runtime Error!

    Program: C:\ProgramData\App-V\A414E085-A197-41AA-B801-A1080359E5F6\0A2C5D5D-9D2D-4307-9538-7D723AD46337\Root\VFS\Pro...

    R6034
    An application has made an attempt to load the C runtime library incorrectly.
    Please contact the application's support team for more information.

    ---------------------------
    OK   
    ---------------------------


    Friday, November 4, 2016 3:24 PM
  • Not sure if this is what you are doing, but what I meant by running the native install on the machine is totally outside of App-V install the software manually, and see if you get the same error with that version.

    I think its worthwhile to rule out there isn't something else different on the machines (like a VC runtime) that don't really have anything to do with App-V.

    I went through a few of the change logs for SP2 to Sp3, and then for 5.1 RTM but didn't see anything, however I can tell you the change lists are not always accurate.  Very often there are other 'fixes' included that don't make it to the change list.

    Friday, November 4, 2016 4:01 PM