locked
Windows 7 wakes up less than a minute after it enters sleep RRS feed

  • Question

  • I've recently built a Windows 7 Pro x64 system and I'm having some problems with sleep mode. I have hibernation disabled and have it set to sleep after 1 hour. This works fine but less than 1 minute after it goes to sleep it will wake up. I've checked the system log and every hour this happens. Here is an example of the system logs that show up every hour:

    Log Name:      System

    Source:        Microsoft-Windows-Kernel-Power

    Date:          5/14/2011 5:18:01 AM

    Event ID:      42

    Task Category: (64)

    Level:         Information

    Keywords:      (4)

    User:          N/A

    Computer:      Home

    Description:

    The system is entering sleep.

    Sleep Reason: System Idle

    _______________________________

     

    Log Name:      System

    Source:        Microsoft-Windows-Kernel-General

    Date:          5/14/2011 5:18:31 AM

    Event ID:      1

    Task Category: None

    Level:         Information

    Keywords:      Time

    User:          N/A

    Computer:      Home

    Description:

    The system time has changed to ‎2011‎-‎05‎-‎14T09:18:31.500000000Z from ‎2011‎-‎05‎-‎14T09:18:02.437508900Z.

    _______________________________

     

    Log Name:      System

    Source:        mvs91xx

    Date:          5/14/2011 5:18:31 AM

    Event ID:      17

    Task Category: None

    Level:         Information

    Keywords:      Classic

    User:          N/A

    Computer:      Home

    Description:

    Adapter is detected.

    _______________________________

     

    Log Name:      System

    Source:        Microsoft-Windows-Power-Troubleshooter

    Date:          5/14/2011 5:18:44 AM

    Event ID:      1

    Task Category: None

    Level:         Information

    Keywords:      

    User:          LOCAL SERVICE

    Computer:      Home

    Description:

    The system has resumed from sleep.

    Sleep Time: ‎2011‎-‎05‎-‎14T09:18:01.314306900Z

    Wake Time: ‎2011‎-‎05‎-‎14T09:18:31.936800800Z

    Wake Source: Device -Realtek PCI GBE Family Controller

     

    I understand the system is waking because of the NIC but I don't want to disable Wake on LAN because I have shares setup for the Home Theater PC in the other room that I want to be able to access even if this PC is in sleep. I've disabled Internet time synchronization and verified the Windows Time service is disabled. Is there a way I can keep this computer in sleep with Wake on LAN enabled and have it wake up only when one of the network shares is accessed? Thanks in advance for any suggestions.

    Saturday, May 14, 2011 1:34 PM

Answers

  • Well I figured out a way around this. I set the option in the NIC properties to only allow a Magic Packet to wake up the PC. I just wrote a script to send a wake on LAN request prior to accessing the network shares and the PC stays asleep until I intentionally wake it up.
    Sunday, May 15, 2011 6:08 PM
  • Hi,

     

    I am glad to hear you have found a workaround. Your efforts and sharing are appreciated. I hope this workaround will give the clue for the communities who encounter the similar issue.

     

    Thanks. Have a nice day!

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Niki Han Monday, May 23, 2011 2:30 AM
    Tuesday, May 17, 2011 9:21 AM

All replies

  • Well I figured out a way around this. I set the option in the NIC properties to only allow a Magic Packet to wake up the PC. I just wrote a script to send a wake on LAN request prior to accessing the network shares and the PC stays asleep until I intentionally wake it up.
    Sunday, May 15, 2011 6:08 PM
  • Hi,

     

    I am glad to hear you have found a workaround. Your efforts and sharing are appreciated. I hope this workaround will give the clue for the communities who encounter the similar issue.

     

    Thanks. Have a nice day!

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Niki Han Monday, May 23, 2011 2:30 AM
    Tuesday, May 17, 2011 9:21 AM