none
"Always available offline" option and Offline Files tab dissapeared in folder options

    Question

  • I am still having issues getting offline files to work correctly. I have a notebook running Windows 7 Pro 64, that syncs with a desktop also running Win7 Pro 64. After a clean install, due to the many issues I've had dealing with Offline Files before, I just synced 1 folder to see if it would work. And it did. Windows 7 synced the folder and it was made available offline. I could easily make folders available offline by simply right-clicking on a folder and clicking the option "Always available offline".  I was also able to successfully sync my Documents, Desktop and Favorites folders (using folder redirection).

    Oddly, when I tried to make a new folder available offline a few weeks later, the option is gone for any other folders (new or previously existing). And when I right-click on a folder (or file) and choose Properties, the Offline Files tab no longer shows as well.

    I have a fairly simple home network setup. My notebook computer syncs with a desktop PC also running Windows 7 Professional 64 (I call this the "Server" PC). Nothing has changed network-wise or configuration wise on either PC. I haven't messed with any network settings or played around with offline files settings since the last successful sync. No new networking hardware has been added either.

    Screenshots below...

    screenshot 1: See the three folders below with the green sync icon over them? But notice how the "Always available offline" option is missing from the menu when I right-click on any folder...

    screenshot 2 (below): If I right-click on one of those "original" 3 folders and go to Properties, notice how the Offline Files tab is visible? However, I can no longer uncheck this folder from being available offline. If I uncheck the "Always available offline" check box, Apply then hit OK, nothing happens. And when I go back into the Properties for that folder, the check box is checked again. It's like it doesn't even save my settings.

    Oh, and another strange issue while I'm here. The "Media" folder shown below doesn't actually sync. It shows that it's marked to be available offline, but as soon as I disconnect from the network, it's not available. But the other 2 folders DO sync regularly. Only the Media folder doesn't sync at all (the media folder just has a few video files less than 10MB).

    screenshot2

    screenshot 3 (below): Here is screen shot of me trying to make the "ClientData" folder available offline, but the "Always available offline" options does not appear when I right-click on it.

    screenshot3

    Any ideas as to what would cause this and/or how to fix? Keep in mind that I disabled and re-enabled offline files, increased the space reserved for offline files, played with the group policy settings trying to force the folder to sync, and then I reformatted the database, all to no avail.

    Thanks in advance.

    • Edited by eq07 Thursday, October 29, 2009 11:31 PM spelling correction
    Sunday, October 4, 2009 6:13 PM

All replies

  • I suggest that you create a new user profile and check if the issue exists with it.

    If the issue is still present, I suspect that the offline folder cache is corrupt. Please try to reset the cache.

    1. Open Control Panel\All Control Panel Items\Sync Center
    2. Click “Manage Offline Files”.
    3. Click “View your offline files”.
    4. Clear all contents.
    5. Click the “Disk Usage” tab.
    6. Click “Delete temporary files”.

    If the issue persists, please use the “Method 2” in the following article.

    How to re-initialize the offline files cache and database

    After the above step you may manually check if the cache is cleared.


    Arthur Xie - MSFT
    • Proposed as answer by MightySW Wednesday, November 17, 2010 8:45 PM
    Tuesday, October 6, 2009 8:58 AM
    Moderator
  • Thank you for your reply.

    The first option didn't make a difference. I created a new profile, and tried to make a folder available offline. NO offline file related menu items appear. No "Make available offline" option is visible.

    I performed options 2 and 3 (deleting the temp offline files AND re-initializing the cache) several times, actually. No avail either.
    Wednesday, October 7, 2009 3:07 AM
  • I had the same problem.

    I found the solution on our win2k3 share, that we connected.
    On the share options there is a setting called caching. 
    This option will configuring the offline access.

    Probably you have to take a look there?

    Regards
    Wednesday, October 7, 2009 2:09 PM
  • @ Chrone: Thanks for recommendation, but that doesn't work either. On the server PC (running Windows 7 Pro 64, not Windows Server), the cache option was set to "make this share available offline by request" (I might have the words wrong a little). It was NOT set to disable. I also changed it to "Make this share automatically available offline" but that didn't work either...
    • Edited by eq07 Wednesday, October 7, 2009 10:48 PM edit
    Wednesday, October 7, 2009 10:37 PM
  • Did you all the steps from Arthur XIE?
    1. Open Control Panel\All Control Panel Items\Sync Center
    2. Click “Manage Offline Files”.
    3. Click “View your offline files”.
    4. Clear all contents.
    5. Click the “Disk Usage” tab.
    6. Click “Delete temporary files”.


    Did you already recreated the share?

    Thursday, October 8, 2009 5:40 AM
  • You may try In-place Upgrade to repair the system. I suspect that the cache folder has problems. We do not have permissions to delete and re-create manually.
    Arthur Xie - MSFT
    Friday, October 9, 2009 3:40 AM
    Moderator
  • Did you all the steps from Arthur XIE?
    1. Open Control Panel\All Control Panel Items\Sync Center
    2. Click “Manage Offline Files”.
    3. Click “View your offline files”.
    4. Clear all contents.
    5. Click the “Disk Usage” tab.
    6. Click “Delete temporary files”.


    Did you already recreated the share?


    Hi, yes I've done that about 10 times across 4 re-installations of Windows 7 RTM (yes, I have re-installed four times due to offline files problems thinking it would resolve them. It worked fine for 2-3 days on average before the problem of disappearing items resurfaced).

    I don't know if it's a file type that causes Offline Files to become corrupt or what. I sync basic Word & Excel docs, video files, HTML files and some program data like Quicken & Quickbooks. It probably doesn't make a difference.

    All I know that I can get it working again after reinstalling windows, but it always "breaks" days later. I gave up reinstalling Windows to fix it after last attempt.
    Saturday, October 10, 2009 2:11 AM
  • Thank you Arthur. Please see my response above.

    Here's something to think about: Although it's strange that I can get Offline Files working for a few days after reinstalling Windows before it breaks a few days later, but I wonder if mapping to a default HIDDEN network share or mapping to a drive letter the same as the server PC makes a difference at some point.

    Let me explain: I have drive H:\ on the notebook computer (the client PC that uses Offline Files) mapped to \\server\h$\ on the server (I'm simply trying to replicate my main data drive on the server, which is drive H:\ also). Notice the h$ drive, which isn't a regular shared folder? However, before you say THAT is or may be the cause..

    Immediately after the 3rd re-install of Windows, INSTEAD of mapping drive H: on the notebook to \\server\h$\, I went to the Server PC and shared drive H:\ as simply "h". Then I mapped drive H:\ on the notebook to \\server\h (without the hidden share $). THEN I setup Offline Files and marked drive H:\ as available offline. Offline Files started the sync process and everything worked--for a few hours. After I restarted the computer, the same issue happened again.

    I hope that makes sense. I just edited my post to make it more clear lol

    Do you think something around this is causing the problem?
    • Edited by eq07 Saturday, October 10, 2009 2:43 AM correction
    Saturday, October 10, 2009 2:29 AM
  • If you are in a domain, have you checked Group Policy?

    You may be disabling Offline Files from a Group Policy if you run the following command on your notebook from the command prompt with administrative privileges, it will create a report containing all currently effective Group Policy settings. Here you can check if this is the case:

    GPRESULT /H GPRESULT.HTML


    Ray
    Saturday, October 10, 2009 11:41 PM
  • If you are in a domain, have you checked Group Policy?

    You may be disabling Offline Files from a Group Policy if you run the following command on your notebook from the command prompt with administrative privileges, it will create a report containing all currently effective Group Policy settings. Here you can check if this is the case:

    GPRESULT /H GPRESULT.HTML


    Ray

    No, I'm not in a domain. This sync is between two computers running Windows 7 Pro RTM only. I ran the command anyway to see the results. Nothing disabled...
    Sunday, October 11, 2009 1:55 AM
  • Is this an issue I can call Microsoft support about? Does Windows 7 have to be released first? And can I get support if this was from technet subscription? I think a Microsoft Engineer needs to take a look at this problem in detail to resolve it (hopefully).

    Anyone know the answers to those questions?
    Tuesday, October 13, 2009 12:29 AM
  • Hi Eriq07 and forum,

    I am using a Windows 7 Enterpreise 64-bit system.  When I browse the network and right click on any folder I don't see the "offline files" tab.

    I have tried this in folders hosted in Windows 2003 Server and Windows Vista and the result is the same, no way to make this folders available offline.

    This is a weird issue and I have been using offline folders for years in XP and Vista and never had this problem.  The folders I am trying to access work offline great in XP and Vista, I am able to see the offline tab in the properties.

    Please somebody out there. help us!

    Thanks!!
    • Proposed as answer by ayerkes Thursday, December 17, 2009 9:59 PM
    Thursday, October 29, 2009 8:33 PM
  • Hey.  Did you ever get this fixed?  Because if not, I have a solution that worked for me.  I had the exact problem you've described -- 64 bit version of Windows 7 (mine is Ultimate), "Always available offline" option not appearing on right click...etc.  

    Just out of curiosity, did you happen to use Windows Easy Transfer to move files from an old computer to move to Windows 7?  Because I have a suspicion that the problem lies somewhere in there.

    In any case, here's what I did, step by step. 

    1. Disable Offline Files (Control Panel\All Control Panel Items\Sync Center), click "manage offline files" then click disable.
    2. Restart the computer
    3. Delete the CSC folder (C:/Windows/CSC).  NOTE: You may have to change the permissions on the CSC folder in order to do this, and once that is done, you need to delete all the folders within the CSC folder first (starting with the farthest in, and working your way out), because the system will not allow you to delete a folder that still has anything inside it.  Once you have all the files within the CSC folder deleted, delete the CSC folder itself. 
    4.  Enable offline files.
    5. Restart the computer.  The CSC folder -- with its default settings, etc., will now be rebuilt, and when right-clicking a network folder, the "Always available offline" option should appear.
    • Proposed as answer by serenastra Thursday, November 29, 2012 1:23 PM
    Thursday, December 17, 2009 11:45 PM
  • Hey.  Did you ever get this fixed?  Because if not, I have a solution that worked for me.  I had the exact problem you've described -- 64 bit version of Windows 7 (mine is Ultimate), "Always available offline" option not appearing on right click...etc.  

    Thanks for the follow up. I will give this a try soon and post back with the results...
    Sunday, December 20, 2009 5:02 PM
  • That didn't work. In fact it actually made my situation worse. The "Always Available Offline" option is still not appearing. Some (not all) of my files were still syncing oddly, but since I deleted the CSC folder NOTHING is syncing anymore.

    Sunday, December 20, 2009 6:25 PM

  • Just out of curiosity, did you happen to use Windows Easy Transfer to move files from an old computer to move to Windows 7?  Because I have a suspicion that the problem lies somewhere in there.

    Never used Windows Easy Transfer.
    Sunday, December 20, 2009 6:27 PM
  • I have the same problem.  Windows explorer's search wasn't working for my network drives, so I tried to make them 'always available offline'.  I was able to partially sync one mapped drive, but I have 3 others that will not sync at all.  The always available offline option is there, but when I click it nothing happens.  The 'offline files' tab in properties disappears.

    Other issues I have with W7 64-bit after 2 days of use:

    1. Favorites doesn't work in explorer.  When I give it commands nothing happens at all.
    2. Office SP2 makes live search buggy in Office.  I uninstalled it, rebuilt the index, and it works again.  Happened on several machines with W7 and Vista.  Very annoying.
    3. 'Automatically expand to folder' feature doesn't work when I search. Horribly annoying.

    Overall I heard good things about W7, but once again MS has failed to release an OS that works properly.  As bad as Vista was I might switch back.  It is always wise to wait until at least the first service pack before buying a new MS OS.
    Wednesday, December 23, 2009 11:15 PM
  • This may have been overkill but I created a video reproducing the problem:

    http://www.utipu.com/app/invited/id/fbe777dd  
    Wednesday, December 23, 2009 11:37 PM
  • Update: I purchased a new computer and tried setting up Offline Files again. One thing that I've done differently this time is NOT redirecting home folders and Offline Files appears to be working ok.

    Previously, I would redirect the My Documents, Favorites and Download folders to a network folder FIRST, then mark those folders to be available offline. I have 3 of my computers (all running Windows 7) setup so that the Documents folder location is on a mapped network drive (H:\Users\Username) and Offline Files doesn't work AT ALL on any of those PCs. This time I didn't set that (yet) on the new computer.

    Allthough I hesitant to do on this working computer, I will change the folder location again and see if Offline Files complete breaks again. If it does, then this tells us that Offline Files doesn't work with redirected folders in Windows 7...
    Sunday, January 24, 2010 8:09 PM
  • A little bit dated on my response here, but this might help. When you do your redirection for your My documents don't use the drive letter but rather the UNC path. i.e. do NOT use H:\My Documents but rather use \\servername\share\My Documents. Have not tested this, but seen lots of issues using the drive letter vs. the UNC path.

    HTH.

    Mike

    • Proposed as answer by MightySW Wednesday, November 17, 2010 8:45 PM
    Thursday, April 22, 2010 8:55 PM
  • I just had an event where I was not connecting properly to my offline files (was in offline mode even though my master-computer was on and running). Then I went to the Offline Files -center to check-out and saw suddenly that the whole system was disabled!

    I had not done anything like that, so it feels like the whole offline files shut itself down somehow. Now I have lost all recent edits to any files since (I dunno when, but maybe a few weeks) the offline files disabled itself..

    If anyone knows how that could have happened, please inform. I suppose the edits to the files just have disappeared because neither the master or the offline versions do not show the newer edits. I have a backup system on the server-side, but it seems that the edits have been made in the offline mode and not synced before this happened.

    So if you have problems mentioned above, check that the system is enabled first :)

    LasseS.


    LasseS.
    Thursday, January 26, 2012 1:23 PM
  • I know this is old, but I thought I'd post it here since it seems to be the top result for this kind of issue. On fresh installs I couldn't get it to work for any user on a PC that had windows 7 Pro.  the "Always Available offline" was missing from the context menu.  Even for admins.  So I figured it had to be a system issue.  I compared context menu registry keys from one PC to the other and found the only difference was a missing "{474C98EE-CF3D-41f5-80E3-4AAB0AB04301}" key under HKEY_CLASSES_ROOT\AllFileSystemObjects\ShellEx\ContextMenuHandlers.  I added this key and without even a reboot, it was available.  I hope this helps someone else out.

    -Austin
    • Proposed as answer by Austin Cherry Thursday, June 28, 2012 7:45 PM
    Thursday, June 28, 2012 7:45 PM
  • Hey.  Did you ever get this fixed?  Because if not, I have a solution that worked for me.  I had the exact problem you've described -- 64 bit version of Windows 7 (mine is Ultimate), "Always available offline" option not appearing on right click...etc.  

    Just out of curiosity, did you happen to use Windows Easy Transfer to move files from an old computer to move to Windows 7?  Because I have a suspicion that the problem lies somewhere in there.

    In any case, here's what I did, step by step. 

    1. Disable Offline Files (Control Panel\All Control Panel Items\Sync Center), click "manage offline files" then click disable.
    2. Restart the computer
    3. Delete the CSC folder (C:/Windows/CSC).  NOTE: You may have to change the permissions on the CSC folder in order to do this, and once that is done, you need to delete all the folders within the CSC folder first (starting with the farthest in, and working your way out), because the system will not allow you to delete a folder that still has anything inside it.  Once you have all the files within the CSC folder deleted, delete the CSC folder itself. 
    4.  Enable offline files.
    5. Restart the computer.  The CSC folder -- with its default settings, etc., will now be rebuilt, and when right-clicking a network folder, the "Always available offline" option should appear.

    I was experiencing this with a Windows 7 Pro X64 computer connecting to a 2003 server and this resolution worked for me, thank you.  For reference, this was a fresh Factory Win7 Install so there was previously no offline files set up.  When browsing to Manage offline files I was unable to view or delete files  as those options were greyed out.  Once i completed the above tasks they were then not greyed out and visible.  Also good to note that other computers (WinXP, Vista, and 7) were able to successfully sync offline files with the same server before this issue occurred so it was diffidently a problem with that computer specifically.

    Cheers

    Friday, September 7, 2012 5:27 PM
  • I messed around for 4 hours trying to get offline files to work with our windows server 2003 and a new win7 laptop. When ever I chose the "always available offline" for a folder, it did noting.  I enable offline files on the server group policy, change/added registry keys as suggested on several forms, disabled and re-enabled the offline feature in win7. None of these worked.  So I decided I would try the "CSC" folder option. When I tried to open the folder it would not let me, so I went into the advanced settings and set permission for access by the current user.  As soon as I accepted the changes, low and behold sync started up on the folders I had added to my offline group earlier. I didn't need to delete the folder and reboot, only give the current user permission to access and modify the folder contents.

    Thanks for the help.

    PS- I did use easy transfer to transfer settings from an XP machine to the Win7 machine. I have no clue if this caused the issue or not.

    Thursday, November 15, 2012 3:03 PM
  • Hey.  Did you ever get this fixed?  Because if not, I have a solution that worked for me.  I had the exact problem you've described -- 64 bit version of Windows 7 (mine is Ultimate), "Always available offline" option not appearing on right click...etc.  

    Just out of curiosity, did you happen to use Windows Easy Transfer to move files from an old computer to move to Windows 7?  Because I have a suspicion that the problem lies somewhere in there.

    In any case, here's what I did, step by step. 

    1. Disable Offline Files (Control Panel\All Control Panel Items\Sync Center), click "manage offline files" then click disable.
    2. Restart the computer
    3. Delete the CSC folder (C:/Windows/CSC).  NOTE: You may have to change the permissions on the CSC folder in order to do this, and once that is done, you need to delete all the folders within the CSC folder first (starting with the farthest in, and working your way out), because the system will not allow you to delete a folder that still has anything inside it.  Once you have all the files within the CSC folder deleted, delete the CSC folder itself. 
    4.  Enable offline files.
    5. Restart the computer.  The CSC folder -- with its default settings, etc., will now be rebuilt, and when right-clicking a network folder, the "Always available offline" option should appear.
    This answer worked for me when I was trying to activate offline files on a new install of Win 7 Pro.  The button to enable was there, but it would not activate when I rebooted.  Followed the above procedure and it worked a dream. Thanks!
    • Proposed as answer by serenastra Thursday, November 29, 2012 1:23 PM
    • Unproposed as answer by serenastra Thursday, November 29, 2012 1:23 PM
    Thursday, November 29, 2012 1:23 PM
  • The above answer worked perfectly for me too. Brand new HP ProBook 4540S with Windows 7 Pro 64-bit installed on a network running Server 2003.

    Thanks, you saved us after an hour of fooling around. BTW, our site has 20+ computers of various vintages, all have been set up over time to synchronize their documents onto the server and this is the first time we've ever run into this problem. 

    Jim

    Monday, June 3, 2013 11:37 PM
  • I've encountered this issue on a MS Windows 7 Pro. SP1 machine that is joined to a Windows domain. A group policy on the domain enables the offline files feature.

    "Always available offline" option reappeared after re-initializing the cache of offline files, which can be done with the following command (copy-paste it to the terminal window - cmd.exe) that changes a value in the Registry:

    REG ADD "HKLM\SYSTEM\CurrentControlSet\Services\Csc" /v FormatDatabase /t REG_DWORD /d 1 /f

    The command takes effect after Windows restarts.

    -- rpr.

    Monday, December 9, 2013 8:25 AM
  • Thanks to whoever posted the solution about deleting the CSC folder(and all of the other steps too!) above. Our user had this problem for weeks and we could not figure it out. This has fixed the issue with my account so far. Hopefully it will work for him too. Thank you so very much
    Thursday, August 21, 2014 7:27 PM
  • IM GOING TO WRITE THIS IN ALL CAPS BECAUSE AFTER SEARCHING FOR 4-5 HOURS OF TRYING THINGS THAT NEVER WORKED THIS RESOLVED MY ISSUE HURRAY!!!! KEY FACTOR HERE IS TO KEEP CHANGING THE WRITES AND OWNERSHIP OF FILES UNTIL YOU CAN TOTALLY DELETE THE CSC FOLDER. FROM THERE JUST FOLLOW THE INSTRUCTIONS OF @SERERNASTRA MAJOR KUDOS THANKS!!!!
    Wednesday, July 27, 2016 6:04 PM