No Audio Device - Realtek HD Audio / KB888111


  • Hi, I understand that this topic has been discussed in great detail here and other forums, yet I have seemingly run into the intractable problem of not being able to hear sound from my computer.  I will write everything I did and provide as much detail as possible.

    I am running XP SP3 on Dell Vostro 200 and an integrated Realtek HD Audio card.  The problem occurred after I cleaned my desk area which included opening the case and getting rid of the dustballs inside the Vostro.

    This is what I know:

    ·          It’s not a hardware problem – I can hear sound when I test the hardware in the Utility Partition

    ·          Currently there is “No Audio Device” in the Sounds and Audio Devices Panel.  All of the dropdowns are grayed out on the Audio tab.  All services including Windows Audio, Realtek ones and others are started.  The alert logs have no information pertinent to this problem.

    ·          In the Device Manager:

    o         There are no question marks “?” or exclamation points “!” devices.

    o         Under “Sound, video, and game controllers”

    §          Audio Codecs

    §          Legacy Audio Drivers

    §          Legacy Video Capture Devices

    §          Media Control Devices

    §          Video Codecs

    §          Realtek High Definition Audio driver - enabled and working properly.  Details include:

    Driver Version:
    C:\WINDOWS\system32\wdmaud.drv      File Version : 5.1.2600.5512 (xpsp.080413-2108), Microsoft

    §          I used to see “Microsoft WINMM WDM Audio Compatibility Driver” but no longer do.  The driver set specifies wdmaud.sys and wdmaudio.inf, and I have numerous of each:


    wdmaud.sys      5.1.2600.2180    81 KB    C:\i386
    wdmaud.sys      5.1.2600.2180    81 KB    C:\from realtek cab
    wdmaud.sys      5.1.2600.2180    81 KB    C:\WINDOWS\$NtUninstallKB920872$
    wdmaud.sys      5.1.2600.2929    81 KB    C:\WINDOWS\$hf_mig$\KB920872\SP2QFE
    wdmaud.sys.000            5.1.2600.2929    81 KB    C:\WINDOWS\$NtServicePackUninstall$
    wdmaud.sys      5.1.2600.2929    81 KB    C:\WINDOWS\$NtServicePackUninstall$
    wdmaud.sys      5.1.2600.5512    82 KB    C:\WINDOWS\ServicePackFiles\i386
    wdmaud.sys      5.1.2600.5512    82 KB    C:\WINDOWS\system32\drivers
    wdmaud.sys      5.1.2600.5512    82 KB    C:\WINDOWS\SoftwareDistribution\Download\9866fb…

    wdmaudio.inf                             24 KB    C:\i386
    wdmaudio.inf                             24 KB    C:\WINDOWS\inf

    Both wdmaudio.inf files are the same size and the beginning text is: 

    DriverVer =07/01/2001,5.1.2535.0

    In my registry I have:


                DriverDesc        Microsoft WINMM WDM Audio Compatibility Driver
                DriverVersion  5.1.2535
                InfPath              wmdaudio.inf 

    o         Under “System devices”

    §          Microsoft UAA Bus Driver for High Definition Audio.  Enabled and working properly.  Details include:

    Driver Version:
    C:\WINDOWS\system32\DRIVERS\hdaudbus.sys  File version : 

    I have numerous hdaudbus.sys files…

    hdaudbus.sys       135 KB  C:\i386 (HDA Bus Driver v1.0)
    hdaudbus.sys       136 KB  C:\WINDOWS\$NtServicePackUninstall$ (HDA Bus Driver v1.0a)
    hdaudbus.sys       141 KB  C:\WINDOWS\ServicePackFiles\i386 (HAD Bus Driver v1.0a)
    hdaudbus.sys       136 KB  C:\WINDOWS\system32\drivers (HD Audio Bus Driver v1.0a)
    hdaudbus.sys       136 KB  C:\Mozilla Downloads\Microsoft KB888111\...\commonfiles (HD Audio Bus Driver v1.0a)
    (and a similar few others…)

    Other things I’ve tried:

    ·          Reinstalled latest chipset/motherboard drivers from Dell

    ·          Commented out the ExcludeFromSelect=* line from machine.inf

    ·          Talked/chatted with Dell Support for ~8 hours (as it’s under warranty) and they couldn’t help, so they wanted me to talk to their “Software” dept which is fee-for-service.

    ·          Done a clean boot by disabling all startup services.

    ·          With a Dell rep’s suggestion I did a system restore to a previous date and that actually worked…, but I was not happy with some of the things they uninstalled (like a Roxio Creative Audio Driver or something…).  So I undid the rollback and now I’m having the problem again, and I have no previous dates to rollback to (in retrospect my bad.)

    ·          I’m using latest Realtek drivers from Dell / Realtek (v 2.28)

    ·          DxDiag (Direct X Diagnostic Tool) > Sound > Test DirectSound:

    DirectSound test results: Failure at step 3 (DirectSoundCreate): HRESULT = 0x88780078 (No driver )
    Device Name:    Realtek HD Audio Output
    DeviceID:          HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_10280238&REV_1000\4&3806C722&12&0201
    Drivers Name:   RTkHDAud.sys
    Drivers Version: 5.10.0000.5888

    I have a software engineering background and I’m still lost.  For some reason I think there is a version mismatch somewhere.  As far as I can tell I have the appropriate driver versions, but something just isn’t hooking up to allow this stuff to work.

    I will gladly do anything, short of reinstall the operating system.  There are at most a handful of files involved with this problem and I refuse to think that a complete reformat/reboot is the way to solve this problem.  I will delete any and all necessary files, delete any and all necessary registry entries, and then re-install any drivers and make any new registry entries as needed.  I can’t believe an OS reinstall is the best choice.

    Other Questions:

    1.       My guess is wdmaudio.inf, which specifies driver version 5.1.2535.0, relates to wdmaud.sys.  However all of my wdmaud.sys files do not have that version.  Does this matter?

    2.       For hdaudbus.sys, why does the driver version differ from the file version?

    3.       I find it weird that hdaudbus.sys files of same file version have different sizes (141 KB vs 136 KB).  Why would that be?

    Thank you all!

    Thursday, July 23, 2009 4:39 AM

All replies

  • I guess my post above is lengthy and likely long-winded, and likely to discourage people from reading it.  So maybe I'll summarize and simultaneously bump this in hopes of attracting those who may have some insight.

    - Have Integrated Realtek HD Audio sound card, running XP3
    - Verified it's not a hardware problem.
    - Device Manager: No unknown devices, all enabled and working properly.  But see "No Audio Device" on Sound panel.
    - Realtek High Definition Audio Driver.  Downloaded v2.28 from Dell and Realtek.  Driver details:
      - Driver Version:
      - C:\WINDOWS\system32\wdmaud.drv      File Version : 5.1.2600.5512 (xpsp.080413-2108), Microsoft

    - I do NOT SEE Microsoft WINMM WDM Audio Compatibility Driver (but I used too.)  I do have those system files:
      - wdmaud.sys      5.1.2600.5512    82 KB    C:\WINDOWS\system32\drivers
      - wdmaudio.inf                            24 KB    C:\WINDOWS\inf
        wdmaudio.inf has a line:
        DriverVer =07/01/2001,5.1.2535.0
    - Microsoft UAA Bus Driver for High Definition Audio details:
      - Driver Version:
      - hdaudbus.sys      136 KB  C:\WINDOWS\system32\drivers (HD Audio Bus Driver v1.0a)

    - I have also tried:
      - reinstalling the chipset drivers
      - rolling back to SP2 then to install SP3
      - Talked to Dell support for ~8 hrs with no luck, spent about 30 hrs of my time.
      - Done a clean boot by disabling all of my startup services.

    I would seriously like any help on this.  I will be glad to delete any files and registry settings and put new files anywhere and type in registry settings.  A complete reformat just seems like taking a hummer to kill an ant.
    Thursday, July 23, 2009 9:17 PM
  •  I had the same problem with one of my systems one time, I kept installing the driver and after a reboot, it no longer worked. I finally downloaded the driver and each time I booted the computer up one of the first things I would do is click on the driver image I had in a folder and reinstall it for that day. I thought about the problem for a long time and started to wonder if the driver was too (for lack of a better term ) advanced for my XP , incompatable. I went to the bios manufactures site and downloaded a couple of drivers that were legacy, older. I tried each one going back by one update of the driver at a time, going back each time to the previous driver. the second one I tried (two updates), worked without having any problem. mine was solved by using a legacy driver that I made sure was for the bios on my system
    Friday, July 24, 2009 12:01 AM
  • Right on, I'll give that a try.  So do you mean the audio drivers or the motherboard chipset drivers?  I'm just a little confused from what you wrote.
    Friday, July 24, 2009 1:53 PM
  • Im talking about the chipset driver, I ended up going to the bios manufacurers site and downloading several for the chipset of my mobo, and doing the downgrade, one upgrade back each time. the second one did it for me
    • Proposed as answer by securityguy14 Saturday, July 25, 2009 8:42 PM
    Friday, July 24, 2009 4:23 PM