locked
Deleted Certificates back after restart RRS feed

  • Question

  • Hello 
    This may have nothing to do with hyper-v but can't find anything on this when I google so I am taking a chance people here will know something.

    In my hyper-v windows 10 machine I have some certificates that I would like to delete.  So I go mmc - add snapin - certificates - my user account. Mark the certificate and delete it. 

    Now it is gone. Until I restart the machine, then it is back again... Why is this and how do I remove it permanently. I first thought it came back from the server on start up but it comes back when there is no server too.

    • Moved by BrianEhMVP Wednesday, January 18, 2017 4:07 PM
    Wednesday, January 18, 2017 9:31 AM

All replies

  • How is your VM created?  Is it a VDI VM?  In that case, you could be starting with the same base image each time your VM is started.

    . : | : . : | : . tim

    Wednesday, January 18, 2017 2:25 PM
  • Hello

    It is not the same image, if I request more certs and then delete all again, next time I restart all the new as well as the old certificates is back.

    So I can get more, just never fewer it seems..

    Wednesday, January 18, 2017 5:23 PM
  • Hi ,

    Did the issue occur with all the Certificates or just your personal Certificates?
    I saw it is a personal Certificate issued by winlabnet on your image, sine they issued these Certificates, have you tried ask them? They may have more resource to help you.

    In addition, I found a similar case that might be helpful. As Guido van Brakel said, it also could also be that the self-signed certificate is autoenrolled again. Or you could refer to Mervyn Zhang's suggestion to discuss in the IIS forum, they are the best resource for this kind of issue.
    New Self Signed Certificate on every reboot
    https://social.technet.microsoft.com/Forums/windowsserver/en-US/f32b1c68-75c5-41ae-bb1e-19b3a24b6f0e/new-self-signed-certificate-on-every-reboot?forum=winserversecurity

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, January 20, 2017 7:03 AM
  • Well I am winlabnet too, this is just a test environment with a virtual server and a virtual client. Anyway if I turn the server off and log in without server connection to the client, remove all personal certificates and restart(still with server off). They still come back. So I guess it might be some permission problem. I tried right clicking one of them but dont really see any obvious way to "take ownership" as was suggested in the other thread.

    It is not the end of the world for me right now  so I will not investigate this further now.

    Thanks for your help.

    Friday, January 20, 2017 9:00 AM
  • Did you ever figure this out? I am having the same issue.
    Friday, November 1, 2019 11:48 AM