locked
MP Reg: Registration request body is invalid. RRS feed

  • Question

  • Hello 

    We have changed the SCCM2012R2Sp1 site from HTTP to HTTPS. Created certificates for the clients, distribution point and IIS.

    The OSD deployments are going good, however after the deployment the client cannot register itself to the Management Point. 

    In the MP_RegistrationManager we get the error ->
    MP Reg: Registration request body is invalid.
    MP Reg: Registration failed.

    On the client in the CcmMessaging.log ->
    Failed to open to WMI namespace '\\.\root\ccm' (80041003)

    The AD schema is not extended, clients are managed with DNS. 

    In the client push installation we use the string ->
    /UsePKICert /NOCRLCheck SMSSITECODE=*** FSP=******* SMSSLP=******* SMSMP=****** DNSSUFFIX=******** CCMHTTPSSTATE=31

    The management point is already reinstalled. 

    Thanks in advance!

    Thursday, December 17, 2015 2:59 PM

All replies

  • First, don't use CCMHTTPSSTATE, it's undocumented and unsupported to set it manually.

    Have you checked the MP_RegistrationManager.log on the MP?

    Is the WMI error happening on all clients or just one?


    Jason | http://blog.configmgrftw.com | @jasonsandys

    Thursday, December 17, 2015 3:25 PM
  • Hello Jason

    I also tried it without CCMHTTPSSTATE parameter (same result)

    Yes all clients have the WMI error "Failed to open to WMI namespace '\\.\root\ccm' (80041003)" (Image is captured with SCCM)

    Yes I checked the MP_RegistrationManager.log on the MP


    Thursday, December 17, 2015 4:10 PM