none
DISM to clean up component store RRS feed

  • General discussion

  • EDIT: Main question is, what does /Online refer to - my mounted image or my "current running operating system"?

    I've got the following folders and files:

    D:\Test

    D:\Test\Images

    D:\Test\Images\WIN7.vhdx

    D:\Test\Offline

    First, does anyone know about the Win10 ADK and when you install it on a x64 machine, the Deployment and Imaging Tools Environment starts you in C:\Windows 10 ADK\Assessment and Deployment Kit\Deployment Tools and uses the dism.exe in that folder, whereas you should be using the one a few folders down, in .\amd64\DISM\dism.exe?  Anyway, took me a bit to figure that one out.

    Anyway, I am following this page.

    To mount the image, i issue this:

    Dism /Mount-Image /ImageFile:D:\test\images\WIN7.vhdx /index:1 /MountDir:D:\test\offline

    And it appears mounted (is this now able to be referenced by "dism /online..." or no? is being "online" different than being "mounted"? From other docs, /Online "specifies that the action is to be taken on the operating system that is currently running" which I took to mean my mounted image, and not, say, the OS that i'm logged in to (but i could be wrong).

    Anyway, now my image is mounted. But if I issue this:

    Dism /Image:D:\test\offline /Cleanup-Image /AnalyzeComponentStore

    I get "Error: 87 The analyzecomponentstore option is not recognized in this context."

    So I try using "/online":

    Dism /Online /Cleanup-Image /AnalyzeComponentStore

    That DOES give me a report, but I want to make sure that it's working on my mounted image, and not my "current running OS" which again, I assume is the OS I'm logged in to. Am I missing something here?

    That reference page above says I should be able to start the cleanup if the report recommends it (it does, again, if it's the correct report). So I issue this:

    Dism /Image:D:\test\offline /Cleanup-Image /StartComponentCleanup

    Again I get the same Error 87 from above, but with the "startcomponentcleanup" piece being unrecognized.

    Trying /online:

    Dism /Online /Cleanup-Image /StartComponentCleanup

    Seems to start trying, and then around ... wait, what? seems like that worked.

    Now I'll try the /resetbase

    Dism /Online /Cleanup-Image /StartComponentCleanup /ResetBase

    Interesting. Apparently, I never did the commands using /Online all the way through the process. I tried the /Online on another command and got an Error 14098 Corrupt Component Store.

    I'm going to leave this post here for anyone else (or my future self when I search for this stuff again)


    ~if this were /. this sig would be funny


    • Changed type owen_i Wednesday, December 14, 2016 8:46 PM Maybe a typo on the MS page...
    • Edited by owen_i Wednesday, December 14, 2016 8:53 PM
    Wednesday, December 14, 2016 8:45 PM

All replies

  • Online refers to the currenly running operating system, rather than another operating system that was mounted on a local folder somewhere else on the machine.

    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Thursday, December 15, 2016 12:57 AM
    Moderator
  • that's great - thanks for the clarification!

    so, now that i know that, the component store cleanup just doesn't work.

    any thoughts on that? :/


    ~if this were /. this sig would be funny

    Thursday, December 15, 2016 6:07 PM