locked
SharePoint Extentions not configured and Central Admin not working RRS feed

  • Question

  • ADMINS: Please move this message to the pre-2010 SharePoint Setup/Admin forum. I accidentally posted this in the wrong place. Sorry.

    I inherited a pair of virtual machines that have TFS 2010 and WSS 3.0 loaded, and that apparently have a history of problems and general flakiness that haven't been solved. Part of this I attribute to the DB tier existing on a VM (a configuration not recommended I've been led to understand). But there are two main problems that I can see right off the bat, both SharePoint-related:

    1. In the TFS Admin Console, the Sharepoint Extenstions node gives the following error: "TF249064: The following web service returned an response that is not valid: http://[TFS app tier server name]:17012/_vti_bin/TeamFoundationIntegrationService.asmx. This web service is used for the Team Foundation Server Extentions for SharePoint products. Either the extentions are not installed, the request resulted in HTML being returned, or there is a problem with the URL. Verify that the following URL points to a valid SharePoint web application and that the application is available: http://[TFS app tier server name]:17012. If the URL is correct and the Web application is operating normally, verify that a firewall is not blocking access to the Web Application."

    (Looking at the various web sites in IIS, it appears that port 17012 equals the "SharePoint Central Administration v3")

    2. The SharePoint Central Administration v3 web site is apparently inaccessible. The "Windows SharePoint Services Administration" service, the "SharePoint Central Administration v3" IIS app pool, and the "SharePoint Central Administration v3" website in IIS all say "Started," but clicking on the START--> PROGRAMS--> ADMINISTRATIVE TOOLS shortcut opens IE with a web address of http://[TFS app tier server name]:17012/ (the correct address, I should think) and an error page that says "The website declined to show this webpage" along with the usual 404-style error blather. So no SharePoint admin site, just an error.

    Strange thing is, the various SharePoint portals hosted in this WSS3.0 installation are all working fine, with the exception of occassional five-minute periods each day where the SharePoint portals come up (you see the SharePoint portal homepage and theme) but all of the various TFS items on the page (bug lists, progress charts, et cetera) give errors that say "Web Part can't be found" and so on. Then a few minutes later the errors clear up and the portals are fine again.

    Does anyone have any ideas of how to address this problem? I've tried running the SharePoint Products and Technoligies Configuration Wizard" several times to no discernable effect, and I've tried a variety of IIS reboots/tweaks recommend on various other threads where others couldn't get into their Central Administration page. I'm not sure where to go from here, but wonder if I can just blow out the Central Admin app pool and IIS central admin website wholesale, then re-run the SharePoint Configuration Wizrd to regenerate it. If I took such a drastic action, woulf the currently working SharePoint portals be affected? Or is the Central Administration website pretty well divorced from the Timer Service and the running of the site proper. Whatever happens, I don't want to do anything that will kill the working portals.

    Thanks.

     


    • Moved by Seven M Friday, August 19, 2011 9:09 AM moss post (From:SharePoint 2010 - Setup, Upgrade, Administration and Operation)
    Wednesday, August 17, 2011 5:03 AM