locked
Stuck on Updating reboot loop for 26 hours and counting RRS feed

  • General discussion

  • I have a PC with Steadystate running, it boots up to the login screen and says that The system is currently being updated and will be shut down when the updates are complete. Then it reboots, boots up and does the same thing. its been doing this non stop for 26 hours now. Any ideas? Same thing happens in safe mode.
    Wednesday, November 7, 2007 3:58 PM

All replies

  • This happened to me the other day on two of our systems, after several reboots (about 10) and forced shutdowns it finally stopped. The funny thing is it even locks the Admin account so there is no way around it.

    I would also love to know if anyone has encountered this problem.


    Wednesday, November 7, 2007 10:47 PM
  • Hi all,

     

    It seems problem was encountered during the update process.

     

    The following workaround works on my test machine. Please check if it works on your side.

    -----------------------------

    1. When the “The system is currently being updated and will be shut down when the updates are complete” message appears, I reset the computer by pressing the reset button on the computer case.

    2. When the system starts, press F8 key on the keyboard.

    3. When the Windows Advanced Options menu appears, select Safe Mode, and then press Enter.

    4. Log onto Windows by using the built-in Administrator account. (User name: administrator, password is blank by default unless you set one during the installation of the system)

     

    If the system is accessible now, we can also find some clues from the following logs:

     

    1. System Event log

    2. “%SystemRoot%\SCTWindowsUpdates.log” and “%SystemRoot%\WindowsUpdate.log”

     

    Best Regards,

     

    Thursday, November 8, 2007 3:00 AM
  • Its doing the same thing under safe mode, it still says profile locked that its about to reboot.

     

    It's been 2 days now rebooting.

     

    Thursday, November 8, 2007 7:07 PM
  • Under Safe Mode, press Ctrl+Alt+Delete. When the classic logon window appears, please check if we can log on with the built-in administrator.  (User name: administrator, no password by default, unless you set one before. This account will not be disable during the Schedule Software Updates)

     

    Regards,

    Friday, November 9, 2007 6:09 AM
  • its working fine for me now but when i was having the issue, you would reboot (even in safe mode) the box would pop up saying the computer was being updated... When you would login with any account, even administrator, it would say it was locked.

    I can always try to dig up logs but it has updated several times sense that problem happened.





    Friday, November 9, 2007 9:17 PM
  • Mine is still doing this, even under safe mode I get the account of locked and that it's about to reboot (yes, even with the classic logon)

    Friday, November 9, 2007 11:10 PM
  • Please check if other modes can be entered or not. If so, we can perform further actions to restore the system. On my test computer, the built-in administrator account is still accessible under Safe Mode.

     

    Regards,

    Monday, November 12, 2007 6:24 AM
  • I'm having the same type of problem.
    Windows Vista Business upgraded to Ultimate
    after the automatic windows updates where installed in September.
    The system keeps re-booting and coming up with configuring updates and then re-boots configuring updates.
    I've tried the Safe mode and it still goes into configuring updates.
    I've tried to Ctrl-Alt-Del and can not break in.
    I've tried to do a repair and that doesn't work
    What else can we do.
    I can get into command mode in safe mode or from the Install DVD.
    What files can I modify to stop the loop?.


    Thursday, December 20, 2007 5:40 PM
  • Hi Bill,

     

    How about running System Restore under Safe Mode with command prompt:

     

    Start System Restore from a command prompt

    http://windowshelp.microsoft.com/Windows/en-US/Help/6b969e00-d4ec-4d3a-bffe-b96107e3bda91033.mspx

     

    As I know, if you have tried to perform a System Repair, System Restore is also available when letting you “Choose a recovery tool”. The screenshot in the following website may help you find the option:

     

    http://vistaultimate.windowsreinstall.com/repairstartup/repairstartup.htm

     

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Regards,

     

     

    Friday, December 21, 2007 6:07 AM
  • I am having this same issue running on Windows XP, however I am able to log in as the local administrator account when booting in to safe mode. This computer has SteadyState updates enabled, but is not connected to any network/Internet. It also has a custom vbs update script that updates our anti-virus (Sophos).

     

    My belief was that updates would fail due to no network connectivity. It seems like a poor design to have the updates hang instead of fail/reboot when there is no connection.

     

    Even though I am able to log in as the local administrator, I cannot disable updates because the service is not able to start in safe mode.

     

    So...how can I disable the scheduled updates? No matter what I try, when I reboot normally it still comes up and says that the computer is installing updates but never does anything and will not allow me to log in using any account.

    Monday, March 3, 2008 10:45 PM
  •  

    Hi,

     

    As I know, if there is connection problem, update will be terminated after about 30 minutes. Thus, I suspect another problem was encountered.

     

    If we can log into Safe Mode, you can make related registry changes to check the result:

     

    1. Enter Safe mode and log on with admin.

    2. Click Start and then Run. Type in regedit and press Enter.

    3. Locate the following branch:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Windows SteadyState\Parameters

     

    Configure as the following:

     

    AutomaticUpdateDay  0

    EnableAutomaticUpdates 0

    UpdateScriptTimeLimitMinutes 0

    UpdateDisableNotify 0

     

    4. Restart the computer to check the result.

     

    If you have WDP enabled, we can also consider deleting the Cache.WDP file under drive C to check if there is any change.

     

    Best Regards,

     

    Wednesday, March 5, 2008 1:53 AM
  • Thanks - I found out that it was the custom update script that was hanging (since the machine had no Internet connection) so I just turned that off.

     

    Should I change UpdateScriptTimeLimitMinutes to have SteadyState skip the custom update script it if takes longer than a certain interval?

    Wednesday, March 5, 2008 2:08 AM
  • This is a message to any person with this issue. I have managed to fix the problem by booting into safe mode. Then when the message comes up and the logon screen press CTRL+ALT+DEL twice to bring up the classic logon screen. Then login as the built in administrator. Straight after you login the system will close the dialog box and shut down the computer instantly. Then turn the computer back on and it will not attempt to update. Then login and disable the automatic updating option in steadystate and thats it. I uninstalled steadystate then since i was only messing with it on my pc.
    Saturday, May 17, 2008 2:51 PM
  • a little late on my repply, but I am currently locked out of mine...only able to run on safe mode..

    Allready installed/repared win XP twice and still locked out...my original user accound in not available, and I have no permission to perform admin tasks.  Any suggestions?

    Saturday, May 17, 2008 11:49 PM
  • In safe mode, you can log in as the built-in administrator account.  From there, you can disable WDP and reenable your account.
    Sunday, May 25, 2008 4:16 PM
  • You can also kill the steadystate service by going into manage on your pc and then connecting into the other PC through action and connect to another computer.  Obviously they have to be networked but if you can kill the steadystate service you can then login normally to the other PC's normal account and disable the automatic updates.  My question to everyone is, has anyone figured out why steadystate is doing this?  I know it has to do with custom scripts, but I need it to update my AVG program so I need to know how to make it work.  Thanks
    Thursday, March 19, 2009 10:12 PM
  • Hope you fought your way through.  If not, maybe recovery console would be an option.

    http://support.microsoft.com/kb/307654

    Boot from CD.  Use can disable the SteadyState service.  I think this will get you in.

    Disable disables a Windows system service or driver. The variable service_or_driver is the name of the service or driver that you want to disable. When you use this command to disable a service, the command displays the service's original startup type before it changes the type to SERVICE_DISABLED. Note the original startup type so that you can use the enable command to restart the service.

    Monday, April 20, 2009 9:27 PM
  • If you are in a domain environment, you can also disable the steady state service with MMC and use services to connect to the remote computer.  I have had to do this on occasion.  If I remember correctly, once I got in I had to disable updates in SteadyState then reboot. 

    Tuesday, April 21, 2009 12:01 PM