none
Windows 10 Sysprep Failure RRS feed

  • Question

  • I am trying to sysprep Windows 10 Education installation for use to deploy.  I am getting an errors starting:

    2016-08-18 08:49:14, Error                 SYSPRP Package Microsoft.Messaging_3.19.1001.

    0_x86__8wekyb3d8bbwe was installed for a user, but not provisioned for all users. This package will not function properly in the sysprep image.

    2016-08-18 08:49:14, Error                 SYSPRP Failed to remove apps for the current user: 0x80073cf2.

    2016-08-18 08:49:14, Error                 SYSPRP Exit code of RemoveAllApps thread was 0x3cf2.

    2016-08-18 08:49:14, Error      [0x0f0082] SYSPRP ActionPlatform::LaunchModule: Failure occurred while executing 'SysprepGeneralizeValidate' from C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2
    2016-08-18 08:49:14, Error                 SYSPRP SysprepSession::Validate: Error in validating actions from C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2
    2016-08-18 08:49:14, Error                 SYSPRP RunPlatformActions:Failed while validating SysprepSession actions; dwRet = 0x3cf2
    2016-08-18 08:49:14, Error      [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = 0x3cf2
    2016-08-18 08:49:14, Error      [0x0f00d8] SYSPRP WinMain:Hit failure while pre-validate sysprep generalize internal providers; hr = 0x80073cf2
    2016-08-18 08:49:23, Info       [0x0f0052] SYSPRP Shutting down SysPrep log
    2016-08-18 08:49:23, Info       [0x0f004d] SYSPRP The time is now 2016-08-18 08:49:23

    Everything is fine prior to that.  I took this list from the setupact text file in the Sysprep folder. 

    Before I tried running sysprep, I tried to remove apps by running these commands:

    Get-AppxPackage | % {if (!($_.IsFramework -or $_.PublisherId -eq "cw5n1h2txyewy")) {$_}} | Remove-AppxPackage and

    Get-AppXProvisionedPackage -online | Remove-AppxProvisionedPackage -online

    Could this be why Sysprep is failing?    Thanks.  mewarren123

    Thursday, August 18, 2016 4:29 PM

All replies

  • I am having the same issue.

    Microsoft.Messaging_3.19.1001.0_x86__8wekyb3d8bbwe is also stopping me from sysprep. I removed all Apps except Store and Calculator. In powershell if you try remove this Microsoft messenging app it says package cannot be found. Looked in infusedApps and only have calculator and Store listed nothing else.

    I was able to sysprep Windows 10 image with nothing installed on it. Apps were also removed from that and it worked no problem. Do you have microsoft 2016 on your image? I thought it could be Skype for business but i removed that but no fix.

    EDIT...........................

    Found a fix. It seems that during updates or possibly VMWARE software creates unknown user profiles on windows. Delete these profiles and sysprep will run.

    1. Run the Import-Module Appx PowerShell cmdlet.
    2. Run Import-Module Dism.
    3. Run Get-AppxPackage -AllUser | Where PublisherId -eq 8wekyb3d8bbwe | Format-List -Property PackageFullName,PackageUserInformation.

      • Get-AppxPackage -AllUser | Format-List -Property PackageFullName,PackageUserInformation

    Last command is one that will show if app is on another account.

    Then just deleted the users in user accounts. This has helped with my sysprep on 3 separate  machines.

    Hope this helps you.

    • Edited by Win10MakesMeCry Monday, August 22, 2016 1:34 PM Found a Method to answer the question
    • Proposed as answer by Win10MakesMeCry Monday, August 22, 2016 1:34 PM
    Saturday, August 20, 2016 9:57 AM
  • Hello, i am having the same trouble.. I have Windows 10 Enterprise x32 installed and wanted to prepare an image for future deployment..  I wanted to uninstall and clean Windows from Cortana and other useless Apps like Xbox and the rest of that mess...

    I tried to sysprep the system and I received this error:

    2017-06-15 12:33:28, Info                  SYSPRP ===          Beginning of a new sysprep run          ===
    2017-06-15 12:33:28, Info                  SYSPRP ========================================================
    2017-06-15 12:33:28, Info       [0x0f004d] SYSPRP The time is now 2017-06-15 12:33:28
    2017-06-15 12:33:28, Info       [0x0f004e] SYSPRP Initialized SysPrep log at C:\Windows\System32\Sysprep\Panther
    2017-06-15 12:33:28, Info       [0x0f0054] SYSPRP ValidatePrivileges:User has required privileges to sysprep machine
    2017-06-15 12:33:28, Info       [0x0f007e] SYSPRP FCreateTagFile:Tag file C:\Windows\System32\Sysprep\Sysprep_succeeded.tag does not already exist, no need to delete anything
    2017-06-15 12:33:28, Info       [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'OOBE'
    2017-06-15 12:33:28, Info       [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'GENERALIZE'
    2017-06-15 12:33:28, Info       [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'SHUTDOWN'
    2017-06-15 12:33:28, Info       [0x0f00d7] SYSPRP WinMain:Pre-validing 'cleanup' internal providers.
    2017-06-15 12:33:28, Info                  SYSPRP RunExternalDlls:Running platform actions specified in action file for phase 3
    2017-06-15 12:33:28, Info       [0x0f00ba] SYSPRP SysprepSession::CreateSession: Successfully created instance with mount path C:, action file C:\Windows\System32\Sysprep\ActionFiles\Cleanup.xml, and mode <null>
    2017-06-15 12:33:28, Info                  SYSPRP SysprepSession::Validate: Beginning action execution from C:\Windows\System32\Sysprep\ActionFiles\Cleanup.xml
    2017-06-15 12:33:28, Info                  SYSPRP ActionPlatform::GetStringValue: Getting REG_SZ value SysprepMode under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep
    2017-06-15 12:33:28, Info                  SYSPRP ActionPlatform::GetValue: Getting value SysprepMode under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep
    2017-06-15 12:33:28, Warning               SYSPRP ActionPlatform::GetValue: Error from RegQueryValueEx on value SysprepMode under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep; dwRet = 0x2
    2017-06-15 12:33:28, Info                  SYSPRP SysprepSession::CreateXPathForSelection: Sysprep mode in registry is <null>
    2017-06-15 12:33:28, Info                  SYSPRP ActionPlatform::GetStringValue: Getting REG_SZ value PROCESSOR_ARCHITECTURE under key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
    2017-06-15 12:33:28, Info                  SYSPRP ActionPlatform::GetValue: Getting value PROCESSOR_ARCHITECTURE under key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
    2017-06-15 12:33:28, Info                  SYSPRP SysprepSession::CreateXPathForSelection: Processor architecture in registry is x86
    2017-06-15 12:33:28, Info       [0x0f0080] SYSPRP ActionPlatform::LaunchModule: Found 'Sysprep_Clean_Validate_Opk' in C:\Windows\System32\spopk.dll; executing it
    2017-06-15 12:33:28, Info       [0x0f0081] SYSPRP ActionPlatform::LaunchModule: Successfully executed 'Sysprep_Clean_Validate_Opk' from C:\Windows\System32\spopk.dll without error
    2017-06-15 12:33:28, Info       [0x0f00d7] SYSPRP WinMain:Pre-validing 'generalize' internal providers.
    2017-06-15 12:33:28, Info                  SYSPRP RunExternalDlls:Running platform actions specified in action file for phase 1
    2017-06-15 12:33:28, Info       [0x0f00ba] SYSPRP SysprepSession::CreateSession: Successfully created instance with mount path C:, action file C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml, and mode <null>
    2017-06-15 12:33:28, Info                  SYSPRP SysprepSession::Validate: Beginning action execution from C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml
    2017-06-15 12:33:28, Info                  SYSPRP ActionPlatform::GetStringValue: Getting REG_SZ value SysprepMode under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep
    2017-06-15 12:33:28, Info                  SYSPRP ActionPlatform::GetValue: Getting value SysprepMode under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep
    2017-06-15 12:33:28, Warning               SYSPRP ActionPlatform::GetValue: Error from RegQueryValueEx on value SysprepMode under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep; dwRet = 0x2
    2017-06-15 12:33:28, Info                  SYSPRP SysprepSession::CreateXPathForSelection: Sysprep mode in registry is <null>
    2017-06-15 12:33:28, Info                  SYSPRP ActionPlatform::GetStringValue: Getting REG_SZ value PROCESSOR_ARCHITECTURE under key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
    2017-06-15 12:33:28, Info                  SYSPRP ActionPlatform::GetValue: Getting value PROCESSOR_ARCHITECTURE under key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
    2017-06-15 12:33:28, Info                  SYSPRP SysprepSession::CreateXPathForSelection: Processor architecture in registry is x86
    2017-06-15 12:33:28, Info       [0x0f0080] SYSPRP ActionPlatform::LaunchModule: Found 'ValidateBitLockerState' in C:\Windows\System32\BdeSysprep.dll; executing it
    2017-06-15 12:33:28, Info       [0x0f0081] SYSPRP ActionPlatform::LaunchModule: Successfully executed 'ValidateBitLockerState' from C:\Windows\System32\BdeSysprep.dll without error
    2017-06-15 12:33:28, Info       [0x0f0080] SYSPRP ActionPlatform::LaunchModule: Found 'SysprepGeneralizeValidate' in C:\Windows\System32\AppxSysprep.dll; executing it
    2017-06-15 12:33:28, Info                  SYSPRP Entering SysprepGeneralizeValidate (Appx) - validating whether all apps are also provisioned.

    2017-06-15 12:33:28, Error                 SYSPRP Package Microsoft.Messaging_3.26.24002.0_x86__8wekyb3d8bbwe was installed for a user, but not provisioned for all users. This package will not function properly in the sysprep image.

    2017-06-15 12:33:28, Error                 SYSPRP Failed to remove apps for the current user: 0x80073cf2.

    2017-06-15 12:33:28, Error                 SYSPRP Exit code of RemoveAllApps thread was 0x3cf2.

    2017-06-15 12:33:28, Error      [0x0f0082] SYSPRP ActionPlatform::LaunchModule: Failure occurred while executing 'SysprepGeneralizeValidate' from C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2
    2017-06-15 12:33:28, Error                 SYSPRP SysprepSession::Validate: Error in validating actions from C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2
    2017-06-15 12:33:28, Error                 SYSPRP RunPlatformActions:Failed while validating SysprepSession actions; dwRet = 0x3cf2
    2017-06-15 12:33:28, Error      [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = 0x3cf2
    2017-06-15 12:33:28, Error      [0x0f00d8] SYSPRP WinMain:Hit failure while pre-validate sysprep generalize internal providers; hr = 0x80073cf2
    2017-06-15 12:33:31, Info       [0x0f0052] SYSPRP Shutting down SysPrep log
    2017-06-15 12:33:31, Info       [0x0f004d] SYSPRP The time is now 2017-06-15 12:33:31

    After that I have readed a lot but still not found a definitive solution.. I made the list of apps for all users, and this app  " Microsoft.Messaging_3.26.24002.0_x86__8wekyb3d8bbwe " were not installed for my current domain user  "adm.xxxxxxxxx

    So I have tried to reinstall it  with this command also for my user

    Add-AppxPackage -register "C:\Program Files\WindowsApps\Microsoft.Messaging_3.26.24002.0_x86__8wekyb3d8bbwe\appxmanifest.xml" -DisableDevelopmentMode

    now from the list i see it installed:

    Get-AppxPackage -allusers | Select Name, PackageFullName

    PackageFullName        : Microsoft.Messaging_3.26.24002.0_x86__8wekyb3d8bbwe
    PackageUserInformation : {S-1-5-21-360300243-75750520-3477292634-1001 [uxxxxxxte]: Installed,
                             S-1-5-21-2807370171-153237904-595379991-8437 [AOLC\adm.paxxxxi]: Installed,
                             S-1-5-21-360300243-75750520-3477292634-500 [Administrator]: Installed,
                             S-1-5-21-2807370171-153237904-595379991-10202 [AOLC\axx.xxxxxxxx]: Installed}

    What should I do for to solve this situation? Do you hava any advice please?

    Thank you so much in advance..

    UPDATE: from this link i tried to do what they say but something goes wrong

    PS C:\Windows\system32> Import-Module Appx
    PS C:\Windows\system32> Import-Module Dism
    PS C:\Windows\system32> Remove-AppxPackage -Package Microsoft.Messaging_3.26.24002.0_x86__8wekyb3d8bbwe
    PS C:\Windows\system32> Remove-AppxProvisionedPackage -Online -PackageName <Microsoft.Messaging_3.26.24002.0_x86__8wekyb
    3d8bbwe>
    In riga:1 car:52
    + Remove-AppxProvisionedPackage -Online -PackageName <Microsoft.Messagi ...
    +                                                    ~
    Operatore '<' riservato per utilizzi futuri.
        + CategoryInfo          : ParserError: (:) [], ParentContainsErrorRecordException
        + FullyQualifiedErrorId : RedirectionNotSupported

    but I wrote wrong with "<" and ">" so I wrote it without them and it says that it is "impossible to find the file specified"

    PS C:\Windows\system32> Remove-AppxProvisionedPackage -Online -PackageName Microsoft.Messaging_3.26.24002.0_x86__8wekyb3
    d8bbwe
    Remove-AppxProvisionedPackage : Impossibile trovare il file specificato.
    In riga:1 car:1
    + Remove-AppxProvisionedPackage -Online -PackageName Microsoft.Messagin ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Remove-AppxProvisionedPackage], COMException
        + FullyQualifiedErrorId : Microsoft.Dism.Commands.RemoveAppxProvisionedPackageCommand



    Thursday, June 15, 2017 10:50 AM