locked
The detection failed, this can be due to a corrupted installation database (single farm) RRS feed

  • Question

  • Greetings all,

    I'm trying to follow up on an issue with MOSS 2007 SP2 upgrade in which it's reported that detection fails and it could be due to a corrupt installation.

    The suggested fix is to find and repair the missing patches via the registry as compared to a good installation elsewhere.  I'm not sure how that would help someone with a single server/farm environment.  I have nothing to compare it to.  I have another 2003 Server R2, but nothing else with sharepoint on it.

    I wanted to follow up on the thread but it was locked.  Additionally, it was for 2010, but I couldn't find similar posts for 2007.

    http://social.technet.microsoft.com/Forums/en/sharepointadmin/thread/cfa66cd3-2aa2-44ee-9393-ffae41d4f70c

    Thanks.

    Monday, June 13, 2011 9:50 PM

All replies

  • Hi brollman,

     

    If the solutions from the thread which you mentioned above can’t solve this issue, I would like to suggest you to refer to the following blog post, try the method there, maybe this could help you to solve this problem:

    http://moss2007.kbnk.info/Patching/solved-the-detection-failed-this-can-be-due-to-a-corrupted-installation-database.html.

     

    Thanks & Regards,

    Peng Lei

    Tuesday, June 14, 2011 6:00 AM
  • >I wanted to follow up on the thread but it was locked.  Additionally, it was for 2010, but I couldn't find similar posts >for 2007.

    >http://social.technet.microsoft.com/Forums/en/sharepointadmin/thread/cfa66cd3-2aa2-44ee-9393-ffae41d4f70c

    1. It was not for 2010 - it was for 2007.

    2. It was closed and locked because a post was marked as an answer (and confirmed as an answer by several people) years ago.

    In such a case you should in any case (if the thread isn't locked) start a new thread rather than adding a new question to a closed thread.

    Moderator pre-SP 2010 forums


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Tuesday, June 14, 2011 9:57 AM
  • Thanks, I will try that and get back to you.
    Tuesday, June 14, 2011 1:19 PM
  •  

    Peng,

    In my registry under HKEY_CLASSES_ROOT\Installer\Products\00002109410100000000000000F01FEC there are no further child registries called Patches to rename as old.

    In the 2nd option, I don't have another Sharepoint Machine, just the one.  What next?

     

    Tuesday, June 14, 2011 9:30 PM
  • Mike,

    Apologies, I had a follow up so I was just trying to add information to the post.

    I don't have a second sharepoint machine to pull from so whatever I do has to be either with this server or another 2003 R2 without sharepoint.

    Also, the answer mentions a registry key that doesn't exist in that location.

     

    Thanks!

    Tuesday, June 14, 2011 9:32 PM