none
CentOS 7.5 & Linux Integration Services v4-2-4-2

    Question

  • I have high pings to a CentOS 7.5 imported Azure server (time=200ms ) & was told that updating the kernel to the latest & then upgrading Linux Integration Services may help.

    Linux Integration Services v4-2-4-1 was already installed so I did a yum upgrade then after rebooting tried to upgrade to Linux Integration Services v4-2-4-2 though now cannot do an upgrade as I get an error 'Unsupported kernel version'. Checking the pdf that was provided I have noticed that Microsoft only supports up to 7.4.

    Anyone know when Microsoft will be updating their Linux Integration Services to 7.5?

    Kernel: 3.10.0-862.2.3.el7.x86_64

    CentOS Linux release 7.5.1804 (Core)

    Cheers

    Monday, May 14, 2018 4:26 AM

All replies

  • Similar issue. Upgraded to CentOS 7.5 and can't install Microsoft Linux Integration Services
    Friday, May 18, 2018 12:28 PM
  • CentOS/RHEL 7.5 will be supported in upcoming LIS 4.2.5 release.
    Sunday, May 20, 2018 9:50 PM
  • Chris, do you know when is this new release expected?
    Tuesday, May 29, 2018 8:05 AM
  • It has been released now, you can get it from here:
    https://www.microsoft.com/en-us/download/details.aspx?id=55106
    Wednesday, May 30, 2018 7:03 AM
  • Hi, 

    Linux release 7.5.1804 (Core) [3.10.0-862.2.3.el7.x86_64] is serviced by LIS 4.2.5, but the Linux release version 7.5.1804 (Core) [3.10.0-862.3.3. el7.x86_64] does not work.

    Anyone know when Microsoft will be updating their Linux Integration Services to 7.5?

    CentOS Linux release 7.5.1804 (Core) [Kernel: 3.10.0-862.3.3.el7.x86_64]


    Charles B. - RS

    • Proposed as answer by Chris Valean Saturday, June 23, 2018 1:28 PM
    • Unproposed as answer by Chris Valean Saturday, June 23, 2018 1:28 PM
    Thursday, June 21, 2018 2:45 PM
  • Here has a similar problem:

    [root@cygnus LISISO]# ./install.sh
    your running kernel 3.10.0-693.17.1.el7.x86_64 is not your latest installed kernel, aborting installation
    [root@cygnus LISISO]# uname -a
    Linux cygnus.microservicebnu.local 3.10.0-693.17.1.el7.x86_64 #1 SMP Thu Jan 25 20:13:58 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

    Someone know how to fix this?

    Thursday, June 21, 2018 3:08 PM
  • Here has a similar problem:

    [root@cygnus LISISO]# ./install.sh
    your running kernel 3.10.0-693.17.1.el7.x86_64 is not your latest installed kernel, aborting installation
    [root@cygnus LISISO]# uname -a
    Linux cygnus.microservicebnu.local 3.10.0-693.17.1.el7.x86_64 #1 SMP Thu Jan 25 20:13:58 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

    Someone know how to fix this?

    This is a different situation, documented and known.

    What happens is that you indeed are running the 17.1 kernel, however as the warning says, you might have installed a different kernel.

    This might imply that you either are not using the updated kernel or have not rebooted the VM yet, so for that reason the LIS installation gives the warning.

    Please remove any other newer kernels from the 3.10.0-693 series, or boot the system using the latest kernel from the series there that you might have.

    Thursday, June 21, 2018 3:12 PM
  • Here has a similar problem:

    [root@cygnus LISISO]# ./install.sh
    your running kernel 3.10.0-693.17.1.el7.x86_64 is not your latest installed kernel, aborting installation
    [root@cygnus LISISO]# uname -a
    Linux cygnus.microservicebnu.local 3.10.0-693.17.1.el7.x86_64 #1 SMP Thu Jan 25 20:13:58 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

    Someone know how to fix this?

    This is a different situation, documented and known.

    What happens is that you indeed are running the 17.1 kernel, however as the warning says, you might have installed a different kernel.

    This might imply that you either are not using the updated kernel or have not rebooted the VM yet, so for that reason the LIS installation gives the warning.

    Please remove any other newer kernels from the 3.10.0-693 series, or boot the system using the latest kernel from the series there that you might have.


    I understand your reply, but I'm using the kernel official, releases in repositories...so need waiting communities develop updating...
    Friday, June 22, 2018 2:59 PM
  • Hi, 

    Linux release 7.5.1804 (Core) [3.10.0-862.2.3.el7.x86_64] is serviced by LIS 4.2.5, but the Linux release version 7.5.1804 (Core) [3.10.0-862.3.3. el7.x86_64] does not work.

    Anyone know when Microsoft will be updating their Linux Integration Services to 7.5?

    CentOS Linux release 7.5.1804 (Core) [Kernel: 3.10.0-862.3.3.el7.x86_64]


    Charles B. - RS

    LIS 4.2.5-1 has been released now at it offers support for the latest RHEL 7.5 kernel.

    Saturday, June 23, 2018 1:29 PM
  • Here has a similar problem:

    [root@cygnus LISISO]# ./install.sh
    your running kernel 3.10.0-693.17.1.el7.x86_64 is not your latest installed kernel, aborting installation
    [root@cygnus LISISO]# uname -a
    Linux cygnus.microservicebnu.local 3.10.0-693.17.1.el7.x86_64 #1 SMP Thu Jan 25 20:13:58 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

    Someone know how to fix this?

    This is a different situation, documented and known.

    What happens is that you indeed are running the 17.1 kernel, however as the warning says, you might have installed a different kernel.

    This might imply that you either are not using the updated kernel or have not rebooted the VM yet, so for that reason the LIS installation gives the warning.

    Please remove any other newer kernels from the 3.10.0-693 series, or boot the system using the latest kernel from the series there that you might have.


    I understand your reply, but I'm using the kernel official, releases in repositories...so need waiting communities develop updating...

    Can you please closely check what kernels you have installed on that system?

    As the error states, there must be some newer kernel which prevent LIS installation, as that would not work if you get to boot into a different kernel.

    Saturday, June 23, 2018 1:30 PM