none
USMT Error RRS feed

  • Question

  • This one is driving me nuts.  Please help.

    I have recently built a Server 2012 server and copied over my Deploymentshare.  I have installed ADK not WAIK on my new server which (apparently) contains a copy of USMT.  I did chose it during install.

    Now, whenever I deploy an image I am faced with this:

    I dont use USMT, nor do I copy user states.  I always do fresh installs without the need for this tool.  How in the hell do I either turn it off, or clear this error.   Searches have me going in loops.

    Thanks!


    Regards JH



    • Edited by _Jonnie Sunday, July 7, 2013 9:55 PM
    Sunday, July 7, 2013 9:54 PM

All replies

  • OK so I have SkipUserData=YES in my customsettings.ini.

    I changed this to no, and during the setup I selected not to copy user state and not to restore user state as well as copying the contents of "c:\Program FIles (x86)\Windows Kits\8.0\Assesment and Deploymentkit\User State Migration Tools\" to its corresponding folder inside "\..\Tools\x64\USMT5" on my deploymentshare and this seems to have resolved it.  However I am unsure which of the two actions fixed it.

    Is there a CaptureUserState=NO and RestoreUserState=NO setting for customsettins.ini?


    Regards JH


    • Edited by _Jonnie Monday, July 8, 2013 3:54 PM SkipUserData Added
    Monday, July 8, 2013 8:39 AM
  • Jonnie,

    SkipCapture actually has nothing to do with USMT, it is used to capture the image after the deployment. If you want to disable USMT from running in your deployment just disable the Capture User State step in the State Capture group and the Restore User State in the State Restore group in your task sequence.

    Both WAIK and Windows ADK use USMT, just ADK uses a newer version. I would check your deployment logs to narrow down your failure.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”


    Monday, July 8, 2013 11:54 AM
  • Sorry I meant SkipUserData=YES.  It has been edited above.

    Does this just skip the form accepting the defaults?  Or do the variables on the form need to be declared?


    Regards JH


    • Edited by _Jonnie Monday, July 8, 2013 3:55 PM Because I say so!
    Monday, July 8, 2013 3:53 PM
  • Yes, skipping a wizard pane will just accept the defaults or whatever is explicitly set in CustomSettings.ini (or MDT Database).

    As Frank said, just disable the Capture/Restore steps for both User State/Groups.  The other thing you can set is USMTOfflineMigration=FALSE since that's the only USMT related Task Sequence that, by default, has a variable set for it's conditional run.


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Monday, July 8, 2013 4:17 PM
    Answerer