locked
Netoworking problem with Centos 7.2 on Hyper-V 2008R2. RRS feed

  • Question

  • I was able to install the server just fine, and networking worked during the install (enough to get ntp data, at least I think it did).  But when I log into the server and try to do anything, it's obvious the network isn't working.  I can ping the loopback interface, and the server's IP, but can't ping the default gw or any other device by it's IP address.

    I am new to Centos 7 and just running Linux on Hyper-V in general.  So, if someone has some ideas, I'd be very grateful. 

    Thanks.

    Friday, March 25, 2016 9:59 PM

All replies

  • Perhaps virtual switch configutration is not exactly what you have expected.

    M.

    Friday, March 25, 2016 10:04 PM
  • How would I go about investigating this?   I tried looking at some interface commands, but the cmdlets were noted as non-existent. 
    Monday, March 28, 2016 2:22 PM
  • No ideas...    Well, I've been reading around but haven't found much. 
    Wednesday, March 30, 2016 2:46 PM
  • What sort of host are you running on? What sort of interface have you connected to the virtual switch?

    When you run "ip addr" are you getting the results you expect for eth0?


    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    Wednesday, April 13, 2016 8:51 PM