locked
Lync 2013 call forwarding (working and non-working scenario) RRS feed

  • Question

  • Hi guys!

    We are trying to solve a non-working scenario in Lync 2013 voip calling.

    SCENARIO 1 that does not work:

    Person A with a mobile phone calls Person B who's telephone number is not located on Lync SIP TRUNK. Person B answers the call and then he wishes to transfer this call to Person C. He call Person C until he hears call ringing tone from him and then he transfer this call to him. When Person C answer the call he does not hear Person A and call get's disconnected after cca. 20seconds.

    SCENARIO 2 that does work:

    Person A with a mobile phone calls Person B who's telephone number is not located on Lync SIP TRUNK. Person B wishes to transfer this call to Person C who's number is located on Lync SIP trunk. In this scenario he first wait that Person C answer/accept his call, then he transfer call from Person A to him. This way Person C is able to hear Person A.

    Anyway how to figure it out if this is a problem on provider side or on Lync 2013 server side?

    with best regards,


    bostjanc





    • Edited by B_C_R Wednesday, February 19, 2014 11:04 AM
    Wednesday, February 19, 2014 10:57 AM

All replies

  • There are a few ways to test the issue.  I'd see if you can replace Person C with someone at a different firm or provider and see if scenario 1 works then.  I'd also run the logger on the mediation server and look for any obvious issues.

    Where is Person B, they're not on your sip trunk, are they outside of your company? 

    How are you connected to the PSTN?  Are you directly connected or using a qualified gateway?


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    Wednesday, February 19, 2014 3:54 PM
  • Hi there Anthony.

    1st of all thank you for your reply.

    if I replace Person C with someone else (by that I mean someone that is not on Lync SIP TRUNK, than it works).

    Person B has an ordinary telephone which is a none SIP supported phone. He is located in our firm, and his IP telephone is connected to providers pbx.

    How are we connected to the PSTN? We have a SIP TRUNK with our provider. Between us and provider there is only one "switch" and no gateways.

    Could you bee so kind and let me know how to log the mediation server calls?

    Do I need to mark only MEDIATION in logger? Or mark to trace anything else?


    bostjanc

    Thursday, February 20, 2014 9:22 AM
  • One thought, have you tested disabling Refer support, or is it perhaps on?  If you go to Lync Control Panel -> Voice Routing -> Trunk Configuration, check if Refer support is set to none.  If it isn't, turn it off when you can make the change, wait a bit, and make another test call.

    For logging, check the Mediation Server box and the S4 box and see what you can see.


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    • Proposed as answer by Eason Huang Sunday, February 23, 2014 1:31 PM
    • Unproposed as answer by B_C_R Monday, February 24, 2014 2:28 PM
    Thursday, February 20, 2014 3:36 PM
  • Hi there.

    We will test it this wednesday and post the results.


    bostjanc

    Monday, February 24, 2014 2:29 PM
  • Refer support wasn't set to none.

    If we change it to none, and restart Mediation service, unfortunatelly there are no differences.

    We have also tried editing: C:\Program Files\Microsoft Lync Server 2013\Mediation Server\MediationServerSvc.exe.config

    FROM:

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <runtime>
        <generatePublisherEvidence enabled="false"/>
      </runtime>
    </configuration>

    TO:

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
    <appSettings>
                    <add key="20.20.20.20.ReferredBySupported" value="true"/>
        </appSettings>
      <runtime>
        <generatePublisherEvidence enabled="false"/>
      </runtime>
    </configuration>

    But that didn't do anything useful.


    bostjanc

    Monday, March 3, 2014 12:28 PM