none
Access Denied error for the User having "Read" Permissions RRS feed

  • Question

  • Hi All,

    we have an MOSS 2007 environment on production server. we have created sharepoint user group named "Home Visitors" having "Read" permission on Site collection level, site level and subsite level. All the "NT Authority\Authenticated users" are member of "Home Visitors" Group. But when any user tries to access the site collection, he is able to access home page but not the site and subsites and it poses "Access Denied" error. However, when we add "NT Authority\Authenticated users" to the "Home Members" group (having "Contribute" Acess on all the sites and site collection level),all the sites are accessible to the users with Site Actions" visible with Contribute permission which is not desirable in our scenario on production server. What could be the reason the group named "Home Visitors" having "Read" Acccess is getting "Aceess Denied" error on all subsites but not on the home page of the site collection.

    Thanks and Regards,

    Amreesh Sharma


    Thanks and Regards, Amreesh Sharma MCTS MOSS 2007 ------------------------------- SharePoint Administrator
    Monday, December 27, 2010 1:17 PM

All replies

  • Does sub site inherit permission from parent ?

    If users are able to access home page then try to inherit permissions from parent (root) site.

    If this will not work then add single user seperately from Home Visitors group to subsite with Read permission and check.


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Monday, December 27, 2010 1:37 PM
  • One possiblility to check would be to see if permissions inheritance was broken on the subsite.  When you break inheritance of permissions it takes a snapshot of the existing permissions as a starting point in the object where it was broken.  So if you break inheritance of permissons on a sub site it will retain the contribute setting for the built in Members group.  But if you later add a new group to the top level that setting will only cover the top level.  Adding a user to either group later is then always done at the top level, but gives the user rights whereever the group has rights already.  So check to make sure permission inheritance wasn't broken before you created the visitor group.  If it was simply add the existing visitor group to the subsite and give it read permissions.
    Paul Stork SharePoint Server MVP
    • Marked as answer by Leoyi Sun Thursday, January 6, 2011 9:05 AM
    • Unmarked as answer by Mike Walsh FIN Friday, January 7, 2011 10:58 AM
    Monday, December 27, 2010 1:41 PM
  • Hi Prateek. Thanks for your quick reply. The permissions are not inheriting from the parent site but the "NT Authority\Authenticated Usres" is added to subsites in"Home Visitors" Group with Read permission but still it gives access denied error. If i open another window with site collection admin and open the people and groups and open the Home visitors group in the subsite and then again open the subsite with the user having Read permission, it works fine. But after some time if i open with user having Read permission, it again gives "Access Denied" error. Sometomes it works fine and again gives "Access Denied" error. Any ideas????

     


    Thanks and Regards, Amreesh Sharma MCTS MOSS 2007 ------------------------------- SharePoint Administrator
    Monday, December 27, 2010 1:46 PM
  • Hi Paul,

    The subsites are not inheriting the permissions of the parent site. Is it making the difference and the reason for the access denied error. The problem is with the out of the box "Home Visitor Group" with Read acess. But if i add "NT Authority\Authenticated users" in "Home Members" group having contribute permission it works fine but shows site actions which is what i dont want. Please suggest.


    Thanks and Regards, Amreesh Sharma| MCTS MOSS 2007| SharePoint Administrator
    Monday, December 27, 2010 2:10 PM
  • Anreesh

    Check your master page select  in the master page gallery , it must not be checked out or in pending state .

    Cheers

    VJ

     

    Monday, December 27, 2010 10:20 PM
  • Hi Amreesh,

    could it be that you have got publishing feature enabled in your site? If so then make sure that "NT authority\Authenticated users" is added to the group "Style Resource Readers" and that this group has restricted read access to the style library and read access to the masterpage gallery (/_catalogs/masterpage).

    Another reason for access denied messages that I have seen is the batch compilation attribute http://support.microsoft.com/kb/953459/en-us in the web.config although this only happens for sites which are edited by sharepoint designer.

     

    • Proposed as answer by rhymeAsyluM Monday, May 18, 2015 5:11 PM
    Tuesday, December 28, 2010 6:59 AM
  • Hi Moss_Test_Dummy,

    I habe publishing features enabled on both site collection as well as site level. I have checked master page gallery, it is checked in all are published. Home page is default.aspx and it is using Wecome page layout for which publishing features enabled. I have given "Read Permission" to "Style Resource Readers" Group. and all my sites and subsites are inheriting permissions from the parent site. Still i am getting the same error. any clue?.....


    Thanks and Regards, Amreesh Sharma| MCTS MOSS 2007| SharePoint Administrator

     

    Moderator Note: Your reply here covers the two previous posts. There is no need to write each person a personal reply. The next reply thus deleted.

    • Edited by Mike Walsh FIN Tuesday, December 28, 2010 12:43 PM Moderator Note added
    Tuesday, December 28, 2010 12:34 PM
  • hi Amreesh

     

    Go to advance permissions and ensure the read permission has got OOB items checked .

    try differentiate with Contribute Permission and check what option in read permission you select lets you login .

    also open ULS logs and try  search for  keyword "Access denied" will let you know what is causing access denied error message .

    check if you have any custom solution deployed and what happens if you retract those solution , are you able to login ?

     

    Cheers

    VJ

    Friday, December 31, 2010 2:49 AM
  • Thnaks mate for you reply. will check and get back to the same thread i still face any problem regarding this.
    Thanks and Regards, Amreesh Sharma| MCTS MOSS 2007| SharePoint Administrator
    Friday, December 31, 2010 11:54 AM
  • I am facing the same issue on our server.
    Friday, December 31, 2010 3:40 PM
  • How to open ULS logs?
    Friday, December 31, 2010 3:48 PM
  • By default it is under C:\Program Files\common files \Microsoft Shared\Web Server Extensions\12\ Logs

    and if you have changed it then please check location under "central admin > Operations > Logging and reporting > Diagnostic Logging > Trace Log " which will give you exact path


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    • Edited by Pratik Vyas Friday, December 31, 2010 3:53 PM add
    Friday, December 31, 2010 3:52 PM
  • SharePoint ULS logs can be seen by using http://www.codeplex.com/ULSViewer desktop viewer. I am not using it roght now but you can download and see if it is helpful. and new version is http://sharepointlogviewer.codeplex.com/.
    Thanks and Regards, Amreesh Sharma| MCTS MOSS 2007| SharePoint Administrator
    Friday, December 31, 2010 4:04 PM
  • Hi VJ,

    I checked the Group permission having "Read" Permission. It is having "Can view  only"permissions. and contribure permission is having different permissions which are same permission as for the site collection level.

    Visitor Group having Read permission + the "Limited acces" in the end but it is uneditable. is it causing the issue. when i go to the Vistor Group settings it shows like this:

    URL:                                                                                            PERMISSION LEVEL

    http://intranet.nobelbiocare.net :                                                    Read, Limited Access

    http://intranet.nobelbiocare.net/_catalogs/masterpage:   Read

    http://intranet.nobelbiocare.net/gmp:        Read, Limited Access

    http://intranet.nobelbiocare.net/gmp/npdd:   Read

    http://intranet.nobelbiocare.net/gmp/standard: Read

    http://intranet.nobelbiocare.net/hr :                 Read

    http://intranet.nobelbiocare.net/rd:               Read, Limited Access

    gmp, hr and rd are subsites.

    Any ideas? The access works fine with the contribute permission.

                         


    Thanks and Regards, Amreesh Sharma| MCTS MOSS 2007| SharePoint Administrator
    Monday, January 3, 2011 11:54 AM
  • Hi Amreesh

    Did u see anything in the ULS logs ,look for the keyword access denied in the uls logs (very imp)and paste the trace, that will let us know the exact problem .

    also try create a new sitecollection with team site template and couple of subsites and check if you are facing the same problem .

    also go to site quotas and locks and ensure the site is not locked .Is it possible for you to run psconfig wizard once and then check.

     

    Waiting for u r ULS logs traces

     

    Cheers

    VJ

     

    Tuesday, January 4, 2011 2:38 AM
  • Hi VJ,

    The ULS logs latest on the production server are:

    01/04/2011 19:43:31.86  OWSTIMER.EXE (0x0AF8)                    0x1108 Office Server                  Office Server Shared Services  6pk4 Verbose  Exiting GetTimerJobsInNextInterval(). Found 0 jobs in interval 
    01/04/2011 19:43:31.86  OWSTIMER.EXE (0x0AF8)                    0x1108 Office Server                  Office Server Shared Services  6pj4 Verbose  End Execute() of JobScheduler 
    01/04/2011 19:43:31.86  OWSTIMER.EXE (0x0AF8)                    0x1108 Windows SharePoint Services    Timer                          8e46 Verbose  End invoke timer job Shared Services Timer Job, id {96096FFC-AB04-4919-B728-1FC21D18B6B8}, DB n/a 
    01/04/2011 19:43:36.86  OWSTIMER.EXE (0x0AF8)                    0x1258 Windows SharePoint Services    Timer                          5utp Verbose  Scheduled timer job Variations Propagate Site Job Definition, id {90FBFE77-43B5-4C68-BBB3-57F38347D942} at 04 Jan 2011 19:44:36 +0100 (now is 04 Jan 2011 19:43:36 +0100) 
    01/04/2011 19:43:36.86  OWSTIMER.EXE (0x0AF8)                    0x0E40 Windows SharePoint Services    Topology                       88b9 Verbose  Determining if the current user is a SharePoint Farm Administrator 
    01/04/2011 19:43:36.86  OWSTIMER.EXE (0x0AF8)                    0x0E40 Windows SharePoint Services    Timer                          8e45 Verbose  Begin invoke timer job Variations Propagate Site Job Definition, id {90FBFE77-43B5-4C68-BBB3-57F38347D942}, DB {FB3BD001-2EC8-4806-9A4E-1DE6E42AFD51} 
    01/04/2011 19:43:36.86  OWSTIMER.EXE (0x0AF8)                    0x0E40 Windows SharePoint Services    Database                       880l Verbose  ConnectionString: 'Data Source=NBCVCNCPH001V1;Initial Catalog=WSS_Content_9cca3a724664492ca0a163a61e2038d3;Integrated Security=True;Enlist=False;Connect Timeout=15'    ConnectionState: Closed ConnectionTimeout: 15 
    01/04/2011 19:43:36.86  OWSTIMER.EXE (0x0AF8)                    0x0E40                                1624                           8acb Verbose  Reverting to process identity 
    01/04/2011 19:43:36.86  OWSTIMER.EXE (0x0AF8)                    0x0E40                                1624                           8acc Verbose  Current user before SqlConnection.Open: Name: NOBELBIOCARE\nbc_moss_farm_1 SID: S-1-5-21-1370467521-2853904403-1986950576-61833 ImpersonationLevel: None 
    01/04/2011 19:43:36.86  OWSTIMER.EXE (0x0AF8)                    0x0E40                                1624                           8acf Verbose  Current user after SqlConnection.Open: Name: NOBELBIOCARE\nbc_moss_farm_1 SID: S-1-5-21-1370467521-2853904403-1986950576-61833 ImpersonationLevel: None 
    01/04/2011 19:43:36.86  OWSTIMER.EXE (0x0AF8)                    0x0E40 Windows SharePoint Services    Database                       880m Verbose  SqlCommand: 'dbo.proc_GetRunnableWorkItems'     CommandType: StoredProcedure CommandTimeout: 0     Parameter: '@RETURN_VALUE' Type: Int Size: 0 Direction: ReturnValue Value: ''     Parameter: '@ProcessingId' Type: UniqueIdentifier Size: 0 Direction: Input Value: 'e69de8b0-952d-484b-a2c0-14b420a98382'     Parameter: '@SiteId' Type: NVarChar Size: 0 Direction: Input Value: ''     Parameter: '@WorkItemType' Type: UniqueIdentifier Size: 0 Direction: Input Value: '5a4b0e0e-0579-4a5d-b233-c2932f031912'     Parameter: '@BatchId' Type: NVarChar Size: 0 Direction: Input Value: ''     Parameter: '@MaxFetchSize' Type: Int Size: 0 Direction: Input Value: '100'     Parameter: '@ThrottleThreshold' Type: Int Size: 0 Direction: Input Value: '0' 
    01/04/2011 19:43:36.86  OWSTIMER.EXE (0x0AF8)                    0x0E40 Windows SharePoint Services    Timer                          8e46 Verbose  End invoke timer job Variations Propagate Site Job Definition, id {90FBFE77-43B5-4C68-BBB3-57F38347D942}, DB {FB3BD001-2EC8-4806-9A4E-1DE6E42AFD51} 

    and the Event Viwer logs are:

    The description for Event ID ( 8214 ) in Source ( Windows SharePoint Services 3 ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: A request was made for a URL, http://localhost:86, which has not been configured in Alternate Access Mappings. Some links may point to the Alternate Access URL for the default zone, http://nbciiscph012v:86. Review the Alternate Access mappings for this Web application at http://nbciiscph012v:34455/_admin/AlternateUrlCollections.aspx and consider adding http://localhost:86 as a Public Alternate Access URL if it will be used frequently. Help on this error: http://go.microsoft.com/fwlink/?LinkId=114854.

    A runtime exception was detected. Details follow.

    Message: Could not find stored procedure 'proc_ar_BumpCacheInvalidationCounter'.

    Techinal Details:

    System.Data.SqlClient.SqlException: Could not find stored procedure 'proc_ar_BumpCacheInvalidationCounter'.

    at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)

    at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)

    at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)

    at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)

    at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async)

    at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result)

    at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)

    at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()

    at Microsoft.Office.Server.Data.SqlSession.ExecuteNonQuery(SqlCommand command)

    at Microsoft.Office.Server.ApplicationRegistry.MetadataModel.DataAccess.AbstractMaterializer.DistributedCacheInvalidate(Type metadataObjectType, Boolean objectCache)

    at Microsoft.Office.Server.ApplicationRegistry.MetadataModel.DataAccess.AbstractMaterializer.DistributedCacheInvalidate()

    at Microsoft.Office.Server.ApplicationRegistry.Infrastructure.SqlSessionProvider.SetSharedResourceProviderToUse(String sharedResourceProviderName)

    at Microsoft.Office.Server.UserProfiles.BDCConnector.RefreshConfiguration(String sspName)

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     


    Thanks and Regards, Amreesh Sharma| MCTS MOSS 2007| SharePoint Administrator
    Tuesday, January 4, 2011 6:49 PM
  • Hi Amreesh

    Seems the logs collected do not have any relevant traces to the issue you are facing  .

    Ensure you are collecting ULS logs for access denied from the WFE where the webapplication is provisioned .

    and the uls logs must contain "Access denied" then only we know whats the Problem.

    Try deactivate publishing feature on the subsite and check if users from the visitors group are able to login .

     

    Cheers

    Vj

    Wednesday, January 5, 2011 2:24 AM
  • Hello VJ,

    I am colleague of Amreesh and have collected the ULS logs of both the WFEs and here they are:

     

    WFE1:

    01/07/2011 09:14:05.02  w3wp.exe (0x0C70)                        0x0980 Windows SharePoint Services    General                        8xfr Verbose  PermissionMask check failed. asking for 0x04000000, have 0x08431061 
    01/07/2011 09:14:05.02  w3wp.exe (0x0C70)                        0x0980 Windows SharePoint Services    General                        8kh7 High     Access denied. 
    01/07/2011 09:14:05.02  w3wp.exe (0x0C70)                        0x0980 Windows SharePoint Services    General                        8gs1 Verbose  Access Denied for /rd/Pages/default.aspx. StackTrace: Microsoft.SharePoint.Utilities.SPUtility:Void HandleAccessDenied(System.Exception), Microsoft.SharePoint.SPGlobal:Void HandleUnauthorizedAccessException(System.UnauthorizedAccessException), Microsoft.SharePoint.Library.SPRequest:Void GetFileAndFolderProperties(System.String, System.String, Microsoft.SharePoint.Library.ListDocsFlags, Boolean, Int32 ByRef, System.Object ByRef, System.Object ByRef, UInt32 ByRef, UInt32 ByRef), Microsoft.SharePoint.SPWeb:System.Object GetFileOrFolderProperties(System.String, Microsoft.SharePoint.Library.ListDocsFlags, Boolean), Microsoft.SharePoint.SPFolder:System.Collections.Hashtable PropertiesCore(Boolean), Microsoft.SharePoint.SPFolder:System.Collections.Hashtable get_Properties(), Microsoft.SharePoint.... 

     

    WFE2:

    01/07/2011 09:01:31.44  w3wp.exe (0x08E4)                        0x0390 Windows SharePoint Services    General                        8xfr Verbose  PermissionMask check failed. asking for 0x04000000, have 0x08431061 
    01/07/2011 09:01:31.44  w3wp.exe (0x08E4)                        0x0390 Windows SharePoint Services    General                        8kh7 High     Access denied. 
    01/07/2011 09:01:31.44  w3wp.exe (0x08E4)                        0x0390 Windows SharePoint Services    General                        8gs1 Verbose  Access Denied for /gmp/standard/Pages/default.aspx. StackTrace: Microsoft.SharePoint.Utilities.SPUtility:Void HandleAccessDenied(System.Exception), Microsoft.SharePoint.SPGlobal:Void HandleUnauthorizedAccessException(System.UnauthorizedAccessException), Microsoft.SharePoint.Library.SPRequest:Void GetFileAndFolderProperties(System.String, System.String, Microsoft.SharePoint.Library.ListDocsFlags, Boolean, Int32 ByRef, System.Object ByRef, System.Object ByRef, UInt32 ByRef, UInt32 ByRef), Microsoft.SharePoint.SPWeb:System.Object GetFileOrFolderProperties(System.String, Microsoft.SharePoint.Library.ListDocsFlags, Boolean), Microsoft.SharePoint.SPFolder:System.Collections.Hashtable PropertiesCore(Boolean), Microsoft.SharePoint.SPFolder:System.Collections.Hashtable get_Properties(), Microsoft.S... 

    When we add any user or NT authority \ authenticated users in the Home members Group (Having Contribute access) .. all works fine and all the users can access the subsites like /gmp and /rd or so without any problem but with edit permissions......as soon as we remove the user from Home Members group and add him to the Home Visitors Group ( Having Read Access)...the first time user is able to access the sub site but when the user comes back to the same sub site he\she gets access denied error....

    Please Suggest.

     

    Regards

    Lalit

     

     

    Friday, January 7, 2011 10:20 AM
  • Do you have any control/webpart in the page which write to the list.Something like visitor counter().

    Do you have any Audience Targetting in the Navigation.

     

    Share the complete error in the ULS log. what you shared half of the stacktrace for the error.

    Sunday, January 9, 2011 5:37 PM
  • I was just grappling with this issue myself (read-only = access denied) today and finally figured out the cause of the problem..at least on my end.  The site itself was fine, but the libraries (including the Pages library where the site's default.aspx page resides) were all set to require approval by default.  Items that require approval are left in a draft state, and by default, users with read-only access can't see drafts.

    Both the approval setting and the security requirements for drafts can be adjusted in the Versioning settings of the library.  Pick your poison.

    Thursday, August 18, 2011 1:17 AM
  • Also had the issue. Had to enable 'Browse Directories' site permission in the Read permission level settings.
    Thursday, November 17, 2011 8:05 AM
  • Just to add my two pence .. I've had this a couple of times where All Authenticated users had view permissions at Site Collection and a sub site (non inherited) and I had to manually add read permissions to the site pages document library. Jules
    Friday, January 20, 2012 12:57 PM
  • Same problem here.

    Other groups with Read permissions could access fine to the site collection, but the new created group with the same permissions could'nt ("Access is Denied"). Finally I had to change the level of permissions "Read" and mark the "Browse User Information" permission.

    Looking at the Logs I found Access Denied errors when trying to look for the Audiences of the user, I supose that it was thrown when looking to show the left side menu. Still I don't know why, I happened but this workaround works for me.

    The LOG errors were like these:

    w3wp.exe (0x3394)                        0x810C SharePoint Portal Server       User Profiles                  62mk High     GetUserAudienceIDs::GetUserAudienceIDs() failed in SharePoint Group membership resolution (Exception Message : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) StackTrace    at Microsoft.SharePoint.Utilities.SPUtility.HandleAccessDenied(Exception ex)     at Microsoft.SharePoint.SPGlobal.HandleUnauthorizedAccessException(UnauthorizedAccessException ex)     at Microsoft.SharePoint.Library.SPRequest.GetGroupsDataAsSafeArray(String bstrUrl, UInt32 dwGroupsScope, String bstrValue, UInt32 dwValue, UInt32& pdwColCount, UInt32& pdwRowCount, Object& pvarDataSet)     at Microsoft.SharePoint.SPGroupCollection.InitGroups(Boolean fCustomUsers, String[] strNames, Int32[] groupIds)     at Microsoft.SharePoint.SPGroupCollection.InitGroups()     at Microsoft.SharePoint.SPGroupCollection.Undirty()     at Microsoft.SharePoint.SPBaseCollection.System.Collections.IEnumerable.GetEnumerator()     at Microsoft.Office.Server.Audience.AudienceManager.GetUserAudienceIDs(String accountName, SPWeb web, Boolean loadAudiences, Boolean loadSharePointGroups, Boolean loadMemberships) . No SharePoint Group IDs will be returned. 

    w3wp.exe (0x3394)                        0x810C Office Server                  Office Server General          900n Critical A runtime exception was detected. Details follow.  Message: Thread was being aborted.  Techinal Details: System.Threading.ThreadAbortException: Thread was being aborted.     at Microsoft.Office.Server.WebControls.AudienceLoader.UpdateAudienceRunTimeCheckHashs(Boolean loadAudiences, Boolean loadMemberships, Boolean loadSharePointGroups)     at Microsoft.Office.Server.WebControls.AudienceLoader.EnsureCurrentUserAudienceIDs(Boolean loadAudiences, Boolean loadMemberships, Boolean loadSharePointGroups)     at Microsoft.Office.Server.Audience.AudienceManager.IsCurrentUserInAudienceOf(AudienceLoader audienceLoader, String audienceTextRepresentation, Boolean showUntargetedAudience) 

    w3wp.exe (0x3394)                        0x810C SharePoint Portal Server       User Profiles                  62mp Exception (Watson Reporting Cancelled) System.Threading.ThreadAbortException: Thread was being aborted.     at Microsoft.Office.Server.WebControls.AudienceLoader.UpdateAudienceRunTimeCheckHashs(Boolean loadAudiences, Boolean loadMemberships, Boolean loadSharePointGroups)     at Microsoft.Office.Server.WebControls.AudienceLoader.EnsureCurrentUserAudienceIDs(Boolean loadAudiences, Boolean loadMemberships, Boolean loadSharePointGroups)     at Microsoft.Office.Server.Audience.AudienceManager.IsCurrentUserInAudienceOf(AudienceLoader audienceLoader, String audienceTextRepresentation, Boolean showUntargetedAudience) 

    w3wp.exe (0x3394)                        0x810C SharePoint Portal Server       User Profiles                  62mq Assert   IsCurrentUserInAudienceOf throws exception. Return false. StackTrace:   at Microsoft.Office.Server.Audience.AudienceManager.IsCurrentUserInAudienceOf(AudienceLoader audienceLoader, String audienceTextRepresentation, Boolean showUntargetedAudience)     at Microsoft.Office.Server.Audience.AudienceManager.IsCurrentUserInAudienceOf(String audienceTextRepresentation, Boolean showUntargetedAudience)     at Microsoft.Office.Server.Audience.AudienceManager.CheckRuntimeRender(String isIncludedFilter)     at Microsoft.SharePoint.SPWeb.InitFromWebPartManager(SPWebPartManager manager, HttpContext context)     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.LoadWebParts()     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.OnPageInitComplete(Object sender, EventArgs e)     at System.EventHandler.Invoke(Object sender, EventArgs e)     at System.Web.UI.Page.OnInitComplete(EventArgs e)     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)     at 

    w3wp.exe (0x3394)                        0x810C Office Server                  Office Server General          900n Critical A runtime exception was detected. Details follow.  Message: Thread was being aborted.  Techinal Details: System.Threading.ThreadAbortException: Thread was being aborted.     at Microsoft.Office.Server.Audience.AudienceManager.IsCurrentUserInAudienceOf(AudienceLoader audienceLoader, String audienceTextRepresentation, Boolean showUntargetedAudience)     at Microsoft.Office.Server.Audience.AudienceManager.IsCurrentUserInAudienceOf(String audienceTextRepresentation, Boolean showUntargetedAudience) 

    w3wp.exe (0x3394)                        0x810C SharePoint Portal Server       User Profiles                  62mn Exception (Watson Reporting Cancelled) System.Threading.ThreadAbortException: Thread was being aborted.     at Microsoft.Office.Server.Audience.AudienceManager.IsCurrentUserInAudienceOf(AudienceLoader audienceLoader, String audienceTextRepresentation, Boolean showUntargetedAudience)     at Microsoft.Office.Server.Audience.AudienceManager.IsCurrentUserInAudienceOf(String audienceTextRepresentation, Boolean showUntargetedAudience) 

    w3wp.exe (0x3394)                        0x810C SharePoint Portal Server       User Profiles                  62mo Assert   IsCurrentUserInAudienceOf throws exception. Webpart won't be shown. StackTrace:   at Microsoft.Office.Server.Audience.AudienceManager.IsCurrentUserInAudienceOf(String audienceTextRepresentation, Boolean showUntargetedAudience)     at Microsoft.Office.Server.Audience.AudienceManager.CheckRuntimeRender(String isIncludedFilter)     at Microsoft.SharePoint.SPWeb.InitFromWebPartManager(SPWebPartManager manager, HttpContext context)     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.LoadWebParts()     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.OnPageInitComplete(Object sender, EventArgs e)     at System.EventHandler.Invoke(Object sender, EventArgs e)     at System.Web.UI.Page.OnInitComplete(EventArgs e)     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)     at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)     at System.Web.UI.Page.ProcessRequest()     at System.W 

    ...

    Thursday, January 10, 2013 9:23 AM
  • Hi Amreesh,

    could it be that you have got publishing feature enabled in your site? If so then make sure that "NT authority\Authenticated users" is added to the group "Style Resource Readers" and that this group has restricted read access to the style library and read access to the masterpage gallery (/_catalogs/masterpage).

    Another reason for access denied messages that I have seen is the batch compilation attribute in the web.config although this only happens for sites which are edited by sharepoint designer.

     

    Thank you! Style Resource Readeers permisson worked for me.!
    Monday, May 18, 2015 5:12 PM