locked
Content Type Create Site from Template Error RRS feed

  • Question

  • Hi All,

    I'm running WSSv3. We have 300 sites deployed, all have a list titled "Issues Log". in order to make it easier to make changes, I created a new custom list content type with the required columns as site columns. The site columns inlcude a number of calculated columns.

    We've just gone through the process of updating all "Issue Log" to use this content type as the default and to hide the old content type. The List is working well with all columns showing the expected data. 

    I now want to update the site template so that any new sites that are created have the "Issue Log" list using the custom content type. I don't get any errors when making modifications to the site and saving it as a template. However, when I create a new site based on the updated template I get an Error

    "The formula refers to a column that does not exist.  Check the formula for spelling mistakes or change the non-existing column to an existing column."

    The content type has a choice column titled "Severity" with options such as Minor, Major, Catastrophic. I also have another column titled "Severity_calc" where I do an series of If statement to set this column to 1 if Minor, 2 if Major and 3 if Catastrophic. These numbers are then used by another 4 calculated columns that are all part of the content type to show various probabilities etc.. I foolishly decided to set "Severity_calc" to "Hidden" in the contety type because I didn't want it appearing in the List View form. Testing showed that everything was working so I left it as hidden.

    Could it be because "Severity_calc" is set to hidden which is why I am getting the error? When I try and set "Severity_calc" to Optional, I still get the same error when i update the site template and try and create a new site.

    Sorry about the long post but I am really stumped here and wanted to provide as much information as possible to assist those willing to help.

    Thanking you all in advance.

    Regards,

    Speculatore

    Sunday, August 14, 2011 12:48 AM

All replies

  • Thank you for the post.

     

    The error states that column/columns referred in the formula does not exist. The site content types and site columns are not included in the manifest when you save a site as template. You may try to create columns directly to the list/library instead of using the existing site columns and use it in the formula.

    Thanks ,

    Manas

    Wednesday, August 31, 2011 9:01 AM