CD drive not working RRS feed

  • Question

  • Ok, So I have looked at the other forums and tried to go into all of those device manager things such as regedit" and devmgmt.msc and followed the steps but no luck. I have no Upper/ Lower filters to be deleted and when I went to that devmgmt one it doesn't show a DVD/CD-Rom. I repeated the steps just in case, but nothing. I have restarted my computer several times and have tried to play cds and dvds but nothing is working. It sounds like it is starting up and running the cd/dvd, but then it doesn't. I have an HP pavilion Entertainment PC and have Windows Vista^tm Business. I honestly don't know what to do and am a broke college student, so I can't take it in to be fixed. Please help me!!!!!!
    Thursday, February 3, 2011 2:06 AM


  • Hi,

    Based on the current status, I would like to propose the following suggestions.
    1.I would like to share an article with you.
    Your CD drive or DVD drive is missing or is not recognized by Windows or other programs
    2.Restart the computer and boot in BIOS ( Boot in BIOS by pressing Del, F2 or other keys which is different from brands of computers), then check if CD-ROM can be detected in BIOS.
    If CD-ROM can't be detected in BIOS, the issue may be related to hardware defect. To identify this, you can test this CD-ROM to check if it can be read properly in another available computer. If it is the case, I need to suggest that you contact hardware manufacturer for support.
    3. What is the optical CD/DVD drive, SATA or IDE? If it is SATA optical drive, you may need to configure settings in BIOS to let AHCI chipset use PATA emulation mode. For more information, please visit the following website.
    SATA optical drives are not available after you start a Windows Vista-based computer
    Hope this helps.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, February 4, 2011 10:00 AM