none
Timesheet won't Load - Project Server 2010 RRS feed

  • Question

  • Greetings!   Points anyone?   :-)      We have a user who can access PWA homepage - however, when clicking on "timesheet" - she get's a blank screen.  Verified the user is in fact using IE 8.0.   Validated she has current assignments and notifications are processing correctly for her.    There is however, a yellow triangle that indicates "error" in the lower left of the screen.   When clicking on "details" - it reads:

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2)

    Timestamp: Wed, 16 May 2012 19:10:50 UTC

    Message: 'ID' is null or not an object

    Line: 2

    Char: 297056

    Code: 0

    URI: http://usrvscmip001/_layouts/jsgrid.js?rev=RJan1D%2BbWf4hpFO%2BLJvCpw%3D%3D

    Out of curiosity, I added the user to the Admin group - not only did this action not work in allowing her to see the timesheet, she also could not see admin permissions such as "Server Settings".     Still getting error in lower left.

    Any advice?

    Monday, May 21, 2012 5:02 PM

All replies

  • Randy,

    Try clearing the user's browser Temporary Internet Files and restart the browser. It has fixed similar error for me in the past.


    Prasanna Adavi, PMP, MCTS http://thinkepm.blogspot.com

    Monday, May 21, 2012 6:49 PM
    Moderator
  • Yes  - we did try that - not change.    Still getting that error in the lower left.      I am thinking strongly that it has a lot to do with this issue (message: 'ID' is null or not an object).    I even removed her from the ERP and then added her back in....  Same result.

    Monday, May 21, 2012 8:17 PM
  • Is user able to reproduce this issue on different system?

    Request user to access Manage Timesheet page and open any past timesheet.

    My timesheet will show current timesheet period, which has possible corrupt or bad data causing  error in JSGrid.


    Hrishi Deshpande – DeltaBahn Senior Consultant
    Blog | < | LinkedIn

    Monday, May 21, 2012 11:10 PM
    Moderator
  • Randy, if the user logs on to another computer does he/she experience the same issue?

    Marc Soester [MVP] http://marcsoester.blogspot.com

    Tuesday, May 22, 2012 1:38 AM
    Moderator
  • What's the zone under which the site is being displayed? Did you try adding it to Trusted Sites or Local Intranet Sites?

    Thanks

    Prasad

    Tuesday, May 22, 2012 2:32 AM
  • I believe the issue is occurring for particular user and limited to that particular machine.

    1. Try logging in to PWA from any other machine with the same user account and record what happens

    2. If it works all right there then next step is to check log in to the original machine with problem machine with any other user account

    3. When I say any other user account its not about EPM login but about machine login.

    4. So log in to the computer with a different user account and then try logging in to PWA with same user

    Post the results what happens after that.

    I have faced similar issue in past and have almost tried everything other than this and nothing worked. Before I could try this thing user's machine was re-installed. So I lost my chance to test this.

     

    Abhijeet M. Mohite --------------------------------------------------------------------------------------------------------------------------------------If you found this post helpful, please "Vote as Helpful";. If it answered your question, Plase "Mark as Answer"

    Tuesday, May 22, 2012 6:48 AM
  • Hi,

    I'm facing excatly, the similar issue since a few days ..

    But it can be related to that :

    http://social.technet.microsoft.com/Forums/en-US/projectserver2010general/thread/998cc04e-a20f-4f59-9736-41b79099de84 ?

    ilys

    Wednesday, May 23, 2012 10:16 AM
  • This setting was already checked in the users options - but thanks for the post.    :)

    Wednesday, May 23, 2012 6:34 PM
  • She can get to the PWA home page - so the security options & zones should not play a role in this particular problem (or am I missing something?)   Thanks for the reply!
    Wednesday, May 23, 2012 6:35 PM
  • Marc,

    I just had her log on to my PC.  She can see her timesheet without an issue.   So it's something within the settings of her PC.    Any ideas?   Should I go through the advanced internet options line by line and match them to mine?   

    Thanks!

    Randy

    Wednesday, May 23, 2012 6:37 PM
  • No - this only happens on her machine.   We are able to successfully retrieve her time sheet when she logs on to my machine.     Managing Timesheets does not allow her to display any timesheets on her machine.   Thanks!
    Wednesday, May 23, 2012 6:39 PM
  • How about clearing IE history?


    Hrishi Deshpande – DeltaBahn Senior Consultant
    Blog | < | LinkedIn

    Wednesday, May 23, 2012 6:40 PM
    Moderator
  • Hi Randy,

    It is good that we identified the issue to the PC. The next step you need to do is look into variances between your PC and the other PC. I presume that it is a browser related issue, but cant be certain. Worth case you may need to re-build the machine. Sorry that I cant pinpoint the issue, but at least you know where to look on your PC.Let me know if you have any questions.

    Thanks


    Marc Soester [MVP] http://marcsoester.blogspot.com

    Wednesday, May 23, 2012 10:33 PM
    Moderator
  • Hi, in my case, it was solved by resetting the IE advanced options.

    ilys

    Thursday, May 24, 2012 9:02 AM
  • We have exactly the same problem. Everything works. The user can even see most of the old timesheet. But when he wants to enter time in his latest timesheet, the screen stays completely empty. No error message, also not from IE 9.0.

    If the user logs in on a different PC, everything works fine.

    The user could key in his timesheets for months on his PC without any problem and he says there was no change on his PC the last few days. He has the necessary knowledge to answer this question properly, he is an ASP.NET developer.

    If we have to re-build his PC, then I feel we should stop using Project Server. There surely must be a proper way to investigate and solve this problem ?

    Tuesday, July 17, 2012 3:48 AM
  • Your comment that he is an ASP.NET developer is interesting because I have 2 developers who have the same or very similar issues.  They have recently started to post their time with other machines...

    This must be some sort of Internet Options setting or some type of add-in running.


    JP

    Monday, July 23, 2012 6:41 PM