none
Windows Hello not working with fingerprint reader if W10 Ent is deployed with MDT 2013 U2 RRS feed

  • Question

  • Hi everybody,

    As I wrote in the title, I experienced a very very odd problem with my HP Probook 440 G3.
    I'm trying to testing Windows Hello feature, but I was able to make it working only if I install my corporate VL copy of W10 Ent from the original media (ISO brought to USB key), or if I install the 90 day evaluation version, downloaded from MS site.

    In such cases, when I swipe my finger on the reader, the Windows Hello setup completes successfully.

    With the same install.wim file taken from the VL ISO, the OS deployed by a standard MDT 2013 U2 Task Sequence seems to behave differently. In fact, I got a "something went wrong" error while trying to complete Windows Hello setup.

    Biometric device is "Synaptic FP Sensors (WBF) (PID=003f)", whose driver has been directly downloaded from MS catalog in each scenario: the failing one and the working one.

    Thanks for any help :)

    Please also note that I've already tried to reset fingerprint and TPM contents from HP Bios, among different installations, with no success of course :/


    • Edited by DashKappei Tuesday, January 12, 2016 2:50 PM
    Tuesday, January 12, 2016 2:49 PM

All replies

  • See Keith's FAQ https://social.technet.microsoft.com/Forums/en-US/ef0a9119-63b6-45ae-a871-866ea62ee3e8/mdt-technet-forum-faq-getting-started-guide?forum=mdt and refer to the section on driver troubleshooting.

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.


    Wednesday, January 13, 2016 10:18 PM
    Moderator
  • I've got the same issue with a different model of laptop.

    If I install any version of Windows 10, from USB or over the network by running the setup.exe from WinPE, after the install and manually installing the fingerprint driver the Windows Hello fingerprint setup works without issue.

    If I install using the same source media but using MDT and Standard Client Task Sequence then once the install completes manually installing the fingerprint driver the Windows Hello fingerprint setup gives the "Sorry, something went wrong." error every time.

    I've tried disabling steps in the task sequence ( Inject Drivers, Apply Patches, Apply Local GPO package ) to try and find which step is causing the issue without success. The same error keeps appearing.

    Has anyone else fixed this issue? It shouldn't be a driver issue as the drivers should be the same.

    Friday, February 17, 2017 3:43 AM
  • It appears my issue is to do with using the Administrator account. If I create a new account the Windows Hello fingerprint setup works without issue. I had no idea the Administrator account was prevented, by design apparently, from setting up Windows Hello.
    • Proposed as answer by CamScottAU Tuesday, February 21, 2017 12:06 AM
    Tuesday, February 21, 2017 12:06 AM