none
DPM 2012 SP1 - Exchange 2010 and 2013, Replica is inconsistent RRS feed

  • Question

  • Hi,

    We have DPM 2012 backing up some of our VMs, including Exchange 2010 and Exchange 2013. We have never had a successful backup with no errors for the Exchange databases. Have tried:

    1. Restarting IIS on Exchange servers

    2. Installing Visual C++ on Exchange 2013

    3. Dismounting mailbox databases and truncating logs

    4. All vsswriter statuses are stable

    Error messages on the Exchange 2010 are:

    "Event 9782 MSExchangeIS: Exchange VSS Writer (instance f7510d9f-4e76-44ce-8e62-f4f6b262fc7b:5) has completed the backup of database 'Admin Mailbox' with errors. The backup did not complete successfully, and no log files were truncated for this database."

    "Event 2007 ESE: Information Store (1780) Shadow copy instance 5 aborted."

    Error messages on Exchange 2013 are:

    "Event 2038 MsExchangeRepl: Microsoft Exchange VSS Writer backup failed. No log files were truncated. Instance 4da58804-0535-469d-a2c3-6df332dfab33. Database f39b8e25-7a5c-4baf-b4fe-fbe8844fc463."

    "Event 2006 ESE: Information Store - Primary Staff (7416) Shadow copy instance 2 completed successfully."

    "Event 2034 MsExchangeRepl: The Microsoft Exchange Replication service VSS Writer (Instance 4da58804-0535-469d-a2c3-6df332dfab33) failed with error FFFFFFFC when processing the backup completion event."

    Please help. Backups worked fine in DPM 2010. SQL databases are being backed up successfully from same DPM 2012 server.

    Thank you.

    Wednesday, August 28, 2013 4:01 AM

All replies

  • SM06,

    What version of DPM2012 are you on?

    ensure that the C++ is installed on DPM server

    Install Visual C++ Redistributable for Visual Studio 2012 Update 1 on your DPM 2012 SP1 server. http://www.microsoft.com/en-us/download/details.aspx?id=30679

    What versions of Exchange 2010 and Exchange 2013? Are they DAGs

    Are you using any other backups (windows backup, 3rd party, log shipping?)

    What are the errors inside the DPM console when trying to protect these?

    The errors you are seeing are related to Exchange VSS related.  You may need to reseed your databases.

    Ensure that circular logging is turned OFF on any databases trying to be backed up.

    Exchange 2013 - http://technet.microsoft.com/en-us/library/dd876874(v=exchg.150).aspx

    Please post in the Exchange VSS forums and if needed open a support case. 


    Regards, A.Nadar, This posting is provided "AS IS" with no warranties, and confers no rights.


    Thursday, August 29, 2013 2:28 AM
    Moderator
  • Thank you A.Nadar,

    We've just discovered and fixed the issue now, and all exchange databases are now checking OK and backing up fine.

    We had installed Visual C++ Redistributable for Visual Studio 2012 Update 3 (Update 1 is no longer around) on our DPM 2012 SP1 server, but hadn't known it was also needed to be installed on the Exchange servers as well. Once we did this, it started working again.

    Does it need to be installed on Exchange servers as I couldn't find anything in official documentation or Google searches to tell us this, except for one article. Pretty annoying.

    Thanks for your reply.

    • Proposed as answer by RogerG781MVP Wednesday, March 5, 2014 6:26 PM
    Thursday, August 29, 2013 2:52 AM
  • Thanks for this info, i had the same error. The installation of Visual C++ Redistributable for Visual Studio 2012 on Exchange 2013 and DPM 2012 R2 was the solution for this error.

    Wednesday, March 5, 2014 6:26 PM
  • Thanks, I have installed "Visual C++ Redistributable for Visual Studio 2012 Update 4" only in Exchange 2013 server and solved the problem.

    Visual C++ Redistributable for Visual Studio 2012 Update 4
    http://www.microsoft.com/en-us/download/details.aspx?id=30679

    Wednesday, March 26, 2014 12:29 AM
  • Installation of Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.61030 on DPM 2012 R2 and Exchange Server 2013 solved this problem
    Sunday, November 30, 2014 11:39 AM