locked
USMT Network backup RRS feed

  • Question

  • Hello all!

    I'm having an issue with getting MDT to back up any files. I've tried a number of different switches and options, as well as setting the backup share on my server to allow FULL CONTROL to EVERYONE. It still refuses to put any files there.

    Here is my current customsettings.ini section for backing up:

    ScanStateArgs=/v:5 /o /c
    LoadStateArgs=/v:5 /c

    SkipUserData=NO
    UserDataLocation=NETWORK
    UDShare=\\FileServer\UserBackup$
    UDDir=%OSDComputerName%

    ComputerBackupLocation=NETWORK
    BackupShare=\\FileServer\ComputerBackup$


    If I set UserDataLocation=Auto, it does the hardlink migration on the HDD and works perfect. Domain permissions/groups and all.

    I did try designating the UDDir directory with an actual name instead of a variable. it didn't even create the folder!

    I can open command line from within my WinPE, map a drive to the backup share, and save a file to it. No authentication, no problem. So connection and permissions are (in theory) out of the question.

    I'm also not clear on the difference between computerbackuplocation and userdatalocation - does user data just do profiles and computerbackup takes an image of the whole drive??

    I've been searching for a solution for weeks now, any help would be appreciated. Just try to go easy on this n00b :)

    -Johnno

    Friday, June 26, 2015 12:51 PM

All replies

  • SkipUserData=YES

    You want to specify to MDT to skip when you've pre-provided all of the information in the custom settings file.  This is a pretty good blog article about automation of USMT -

    https://scriptimus.wordpress.com/2011/05/25/mdt-2010-user-state-migration/

    Friday, June 26, 2015 1:56 PM
  • ComputerBackupLocation is used for doing a full capture (WIM file), whereas UserDataLocation is for migrating profiles by using USMT (MIG file).

    If you don't plan to make full backups then add the following settings:

    SkipComputerBackup=YES
    ComputerBackupLocation=NONE

    UserDataLocation=NETWORK
    UDShare=\\SERVER\SHARE$
    UDDir=%OSDComputerName%

    The permissions for your share should be Everyone=Change and Read. Then click on the Security tab, click Advanced and remove everyone if it's listed. Add only the accounts that will be used for MDT such as the Administrators group (Full control) and the account(s) used to connect to the deployment share when you run the wizard (Modify).


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Friday, June 26, 2015 3:30 PM
  • Thanks MrBrooks, I will be skipping the section once I get it working properly.

    All of the other pages show my pre-selected values typed or selected on the page when it opens, this one doesn't work for the user data backup, and shows a blank text area for user data restore.

    Usually I would set permissions more specific, but I allowed everyone as full control for testing, to rule out permission problems.

    Any other ideas?


    • Edited by JohnnoK Monday, June 29, 2015 7:02 PM typo
    Monday, June 29, 2015 7:00 PM
  • If you don't skip the user data wizard then you won't see it pre-filled like other pages. I hope that works in the next version of MDT.

    If this post is helpful please vote it as Helpful or click Mark for answer.

    Monday, June 29, 2015 8:00 PM