locked
Unable to call from communicator to analog extensions RRS feed

  • Question

  • Hello,

    I have configured the audicodes mp118 as per the following article:
    http://www.lynclog.com/2011/04/analog-phone-support-with-lync-2010.html

    And crossed checked with 


    http://blogs.technet.com/b/daveh/archive/2009/02/01/integrating-audiocodes-mp-114-mp-118-media-gateways-with-microsoft-unified-communications-products.aspx


    I have only two internal extensions 7771 and 7772 which are connected with physical analogue phone. My OCS 2007  extensions for user1 is 6309 and user2 is 6308 and user3 is 6307.


    Normalization rule details:


    My phone pattern regular expression: ^(\d{4})$


    Translation Pattern:$1


    when I am calling from 7771 and 7772 (Physical Phone1 and 2) I am receiving the calls in communicator but when I tried to call back I am getting an error during the call (ID:14005)


    I tried to take trace from frontend and getting: (This error I am getting when I am connecting from EDGE)


    ms-diagnostics: 14005;reason="Could not find profile in internal lookup";source="ocsfe.mydomain.com";ProfileName="unknown";appName="TranslationService"
    Server: TranslationService/3.0.0.0


    I tried many things but unable to resolve this issue. Please help.



    • Edited by Askwizard Sunday, April 1, 2012 6:32 AM
    Saturday, March 31, 2012 3:34 PM

All replies

  • Find the ACSyslog utility from AudioCodes and see what is getting sent from the Lync server back to the gateway.  It will run on a x64 machine when launched as admin, but on mine I have to close and open each time to take a new log.

    Please remember to click “Mark as Answer” if this resolved the issue.

    Saturday, March 31, 2012 4:21 PM
  • I think it is related to the location profile. When a domain user is trying to call from MOC he/she is getting the following error: (This error I am getting when and user is connection from internal network)

    TL_INFO(TF_PROTOCOL) [0]0848.0E88::04/01/2012-06:05:04.850.000000d4 (SIPStack,SIPAdminLog::TraceProtocolRecord:1224.idx(122))$$begin_record
    Instance-Id: 00000390
    Direction: outgoing;source="local"
    Peer: 192.168.0.7:49259
    Message-Type: response
    Start-Line: SIP/2.0 403 Forbidden
    From: "xyz"<sip:xyz@xyz.com>;tag=feb965b903;epid=e6c0272fd0
    To: <sip:7771;phone-context=dialstring@aaclab.com;user=phone>;tag=8F397143CD9CFD019B614EFD332BAC16
    CSeq: 1 INVITE
    Call-ID: c49aa4abce97493a864b23045f026a25
    Proxy-Authentication-Info: Kerberos rspauth="602306092A864886F71201020201011100FFFFFFFF01545B3F8268E0654385D67EA179651D", srand="E94518CD", snum="17", opaque="DB9D7160", qop="auth", targetname="sip/ocsfe.xyz.com", realm="SIP Communications Service"
    Content-Length: 0
    Via: SIP/2.0/TLS 192.168.0.7:49259;ms-received-port=49259;ms-received-cid=700
    ms-diagnostics: 12004;reason="No route found";source="ocsfe.xyz.com";appName="OutboundRouting"
    Server: OutboundRouting/3.0.0.0
    Message-Body: –
    $$end_record

    Not sure If I am missing anything.


    • Edited by Askwizard Sunday, April 1, 2012 7:15 AM
    Sunday, April 1, 2012 6:12 AM
  • I have created a new location profile and deleted the old one but no luck, I am trying route helper and getting the following screen.

    Unable to route response code 403 will be returned. It is definitely not going upto Audiocodes.

    Sunday, April 1, 2012 7:14 AM
  • Hi,

    have you also configure the Default PSTN usage with the right route?


    regards Holger Technical Specialist UC

    Sunday, April 1, 2012 11:33 AM
  • Can you test with a route of .* ?  that should try and route everything.


    Please remember to click “Mark as Answer” if this resolved the issue.

    Sunday, April 1, 2012 5:18 PM
  • I don't have any PSTN line, I am only trying to call internal extensions.
    Monday, April 2, 2012 3:57 AM
  • Can you please explain where to configure that?
    Monday, April 2, 2012 3:58 AM
  • Hi, the audiocodes-mp-114-mp is your external Gateway and you have to configure to reach this analog Gateway a Dial Plan, voice policy,PSTN usage, Trunk. You can use this link from Ken Lasko for descrition how to configure

    http://ucken.blogspot.de/2011/01/enterprise-voice-best-practices-in-lync_21.html


    regards Holger Technical Specialist UC


    Monday, April 2, 2012 9:36 AM
  • Hi,

     

    You can refer to the following instruction to configure Voice Route and PSTN Usage:

     

    http://technet.microsoft.com/en-us/library/gg425890.aspx

     

    http://technet.microsoft.com/en-us/library/gg398450.aspx

     

    Regards,

    Kent

    Monday, April 2, 2012 9:55 AM
  • Are you trying this on the internal network or from the edge?  I noticed that in the original posting and wonder if the results would be the same from your internal network.

    Please remember to click “Mark as Answer” if this resolved the issue.

    Monday, April 2, 2012 4:58 PM
  • In my first post I am trying from EDGE and 2nd post I am trying from internal network. Here is the global voice properties.

    Tuesday, April 3, 2012 6:08 AM
  • Hi

    Whats the IP address of the gateway on your network. The SIP trace above states that an outbound route was not found so I am wondering if the call is actually getting to the gateway.

    Could you run another trace and dial the number now you have made some changes and post it up along with the IP of the gateway please.

    Thanks

    Neil

    Tuesday, April 3, 2012 8:07 AM
  • Hi,Askwizard,

    Did you have event ID 49983 and 59352 in event log on your OCS server?

    If so there should be WMI not working correctly,please try to restart Windows Management Instrumentation Service or reboot OCS server and check again.

    Also here are some articles for configuring OCS work with Analog Gateway for your reference,you can check your voice routing configuration for Analog device.

    http://blogs.technet.com/b/jkunert/archive/2008/09/03/analog-gateways-connected-to-ocs-2007.aspx 

    http://ocsguy.com/2010/04/02/294/ (Part1)

    http://ocsguy.com/2010/04/08/making-analog-devices-work-with-ocs-%e2%80%93-part-2/ (Part2) 

    B/R

    Sharon


    Sharon Shen

    TechNet Community Support

    ************************************************************************************************************************

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.

    Wednesday, April 4, 2012 6:48 AM
  • The issue is resolved after I create new users in AD. Very strange.
    • Marked as answer by Askwizard Wednesday, April 4, 2012 1:11 PM
    Wednesday, April 4, 2012 1:11 PM