locked
High Ping "ms/ping" during playin online? RRS feed

  • Question

  • When i had xp my ms was below 30.
    When i now upgraded to windows 7 for tryin, my ms true the cmd --> ping www.google.se  = ~50ms 
    When i playin game online i have over 150 ms?  
    I took a look at the firewall, router, ports, almost everything, havent found yet.
    Even cheked option in the game. And still cant find how to fix my ping?
    PS:Not wireless!
    Have a Intel Xeon (TM) CPU 3.20 GHz, 1 GB Ram, 32-bit, Nvidia Quadro FX 3450/4000 SDI, and 24 mb connection.
    Please Help, windows 7 is a great system! Dont want it back to xp couse my ping!
    Thursday, May 7, 2009 7:23 PM

Answers

  • Your ping is reliant on the computer you're connecting to and network traffic between your computer and the server (as well as the time a game or whatnot processes packet information.) It's not a problem with Windows 7 RC.

    -Nick
    • Marked as answer by Nick FV Wednesday, June 3, 2009 3:14 AM
    Wednesday, June 3, 2009 3:14 AM

All replies

  • Hi Sebastian,

    can you try disabling IPv6 on your LAN and see if this solves the issue?

    1. Start -> Network and Sharing Center
    2. Click Manage Adapter Settings
    3. Right click on the Local Area Connection -> Properties
    4. Untick "Internet Protocol IPv6"
    5. Click OK

    See if this helps.
    Jabez Gan [MVP] - http://www.msblog.org Contributing Author for: (Sybex) MCTS: Windows Server 2008 Applications Infrastructure Configuration Study Guide: Exam 70-643
    • Proposed as answer by Placidcy Friday, March 24, 2017 10:22 AM
    Thursday, May 7, 2009 7:45 PM
    Answerer
  • Hi,

    It helped half way, in cmd --> ping www.google.se = ~60 ms
    But in the game it calm down to ~ 50-60 ms.
    So it helped o little bit and worsed if you know what i mean?

    Is there any more solves to fix my ms? Druring the game ant Internet Explorer?
    Thank You!... ;D

    Thursday, May 7, 2009 8:02 PM
  • Your ping is reliant on the computer you're connecting to and network traffic between your computer and the server (as well as the time a game or whatnot processes packet information.) It's not a problem with Windows 7 RC.

    -Nick
    • Marked as answer by Nick FV Wednesday, June 3, 2009 3:14 AM
    Wednesday, June 3, 2009 3:14 AM
  • Yes it is a problem with RC py ping on xp was 12ms i reformatted to win 7 release canidate 7100 and my ping now is 33-35ms, i wanted to see if  its a problem with my internet company so i created a partition and reinstalled xp, checked ping and it was 12ms once again. U cant say something unless u have witnessed it for yourself!! =)
    Sunday, June 28, 2009 8:08 PM
  • ok dude i have that same problem... well (had) this may not work for you but this it what i did:
    I reformatted again to a clean copy of windows, when the desktop loaded the first thing i did was go to www.speedtest.net and check my ms/ping.
    Result:10

    I installed a couple of software and nvidia drivers and Call Of Duty 4 then restarted and checked my ping again @ www.speedtest.net .
    Resut:10


    I then installed eset smart security 4 restarted and then checked again
    Result:26


    Bingo! anti-virus was teh problem. Same thing with NOD32 4.

    I uninstalled and restarted and checked.
    Result:10


    If u have an antivirus it "MAY"  be the cause of that problem.
    In other instances it may be something else like drivers or tcp/ipv4 registry errors.

    Thats what worked for me hope it works for u also, cause i have spent 2 days trying to figure out what was causing this tried tweaking, hax0ring the registry,google,yahoo, and slamming my head to the computer screen. none of the previous worked cept for teh above... =)

    If u still have  errors email me @ starrfox716@hotmail.de or starrfox716@yahoo.com "i use yahoo more" or if u have xfire xfire me @ starrfox716 and i will try my best to help.
    Monday, June 29, 2009 12:41 AM
  •  Back on Windows XP you could alter the registry to allow lager TCP frames and more of them before a ACK was needed. you could also allow longer TTL and reduce other exploration packets coming from your end. While this did not give you a lower ping it did help with time out issues and other problems that come from high ping.

    the changes were to the following keys

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

    SackOpts is set to 1
    DefaultTTL set to between 40-60
    TcpMaxDupAcks set to 2
    EnablePMTUDiscovery 1
    EnablePMTUBHDetect 0

    i dont know if these are there in win 7 or if they work in the same way that they did in win XP

    Monday, June 29, 2009 2:29 AM
  • Your ping is reliant on the computer you're connecting to and network traffic between your computer and the server (as well as the time a game or whatnot processes packet information.) It's not a problem with Windows 7 RC.

    -Nick
    nick im sorry to inform u but your wrong in this instance i have a duel boot on my system windows xp pro 64-bit and windows 7 64-bit i have installed battlefiled 2142 on both sides gona on my regular server that i play on and on xp my pig is an average of 72 on the same server on windows 7 my ping is over 200, so if anyone has any real solutions to this problem plz post them
    • Proposed as answer by jims2321 Wednesday, July 29, 2009 1:28 PM
    Wednesday, July 29, 2009 10:53 AM
  • Diablo,

    This is more likely an issue with a new tcp/ip stack driver immaturity in Windows 7, then anything else.  Windows XP, Vista and such have over the past several years undergone minor performance tweaks, we may just have to go thru the same maturation process with Windows 7.

    Jim
    Wednesday, July 29, 2009 1:30 PM
  • The disabling IPv6 didnt work for me. This is an issue with in Windows 7. I hope they fix this because this issue going to give them mega problems in the gaming community.
    Thursday, October 1, 2009 7:08 PM
  • We heard you the first time and its not the issue here. I also have duel boot with Vista and it run perfect on Vista.
    Thursday, October 1, 2009 7:10 PM
  • I agree Jim, this is really sad to see. They will kill the gamers with this. This problem is all over the net. I cant see why they missed it. I guess they dont play games at Microsoft. LOL SAD
    Thursday, October 1, 2009 7:13 PM
  • i think a few people are confused, not just here but every where. Some people seem to think that getting your ping higher is a good thing but its not its a very bad thing.

    50ms is good so dont worry
    150 ms is bad but still playing
    anything below 20ms is very good.

    Im going to help you here, this is one way to lower your ping.

    Step
    (1) Log into administrator.(Not an administrator account) log out and type administrator.(if you set a password when you first got your computer then type it in, if not then just press enter) If you are using the welcome screen hold Ctrl, Alt Delete. and type in administator.

    (2)Go to start, Run, type in gpedit.msc, press enter, Expand local computer policy, then expand administrative templates, then expand network, then click on Qos packet scheduler, then double click limit reservible bandwith, click it to enable, then put the bandwith % to %0. Then restart your computer(Restarting is very important)

    Ill explain what this does.

    Windows update reserves %20 of your bandwith for its updates, so your losing out, so this takes it away and gives it to you. when windows in downloading updates you internet will run a bit slower but over this is better.

    Also all the junk youv got from browsing slows down your internet. so delete your cookies, recent history and all that.

    Good luck.

    Also if playing with others who have high ping, this slows your down.

    To find out your ms on surtain servers, go to start, run, type cmd then enter. In the command box type ping and the server site or ip of which u want to play.

    Example; If you wanted to search servers for warcraft 3, stargate, diablo, type ping www.battle.net, for runescape, ping www.runescape.com, for darkthrone, ping www.darkthrone.com if u you dont know the server your game is playing from then google it.
    Sunday, October 18, 2009 12:54 AM
  • Game's working like adream for me,not issues at all...it might be cuz of my reg tweaks ^^
    cant beat that
    RR
    Sunday, October 18, 2009 1:54 AM
  • i think a few people are confused, not just here but every where. Some people seem to think that getting your ping higher is a good thing but its not its a very bad thing.

    50ms is good so dont worry
    150 ms is bad but still playing
    anything below 20ms is very good.

    Im going to help you here, this is one way to lower your ping.

    Step
    (1) Log into administrator.(Not an administrator account) log out and type administrator.(if you set a password when you first got your computer then type it in, if not then just press enter) If you are using the welcome screen hold Ctrl, Alt Delete. and type in administator.

    (2)Go to start, Run, type in gpedit.msc, press enter, Expand local computer policy, then expand administrative templates, then expand network, then click on Qos packet scheduler, then double click limit reservible bandwith, click it to enable, then put the bandwith % to %0. Then restart your computer(Restarting is very important)

    Ill explain what this does.

    Windows update reserves %20 of your bandwith for its updates, so your losing out, so this takes it away and gives it to you. when windows in downloading updates you internet will run a bit slower but over this is better.

    Also all the junk youv got from browsing slows down your internet. so delete your cookies, recent history and all that.

    Good luck.

    Also if playing with others who have high ping, this slows your down.

    To find out your ms on surtain servers, go to start, run, type cmd then enter. In the command box type ping and the server site or ip of which u want to play.

    Example; If you wanted to search servers for warcraft 3, stargate, diablo, type ping www.battle.net, for runescape, ping www.runescape.com, for darkthrone, ping www.darkthrone.com if u you dont know the server your game is playing from then google it.

    ScottJ,

    Nice work bro. This has made a nice difference gaming. Even all my pages open faster.  I have accumilated a few tweaks to help the issue Microsoft has not. I manually update Windows on a daily basis so this is perfect for me. I'm booting into Vista now and doing the same thing. 

    Thanks again.

    Tony 
    Sunday, October 18, 2009 5:23 AM
  • Game's working like adream for me,not issues at all...it might be cuz of my reg tweaks ^^
    cant beat that
    RR

    Good for you I hope it stays that way.
    Sunday, October 18, 2009 5:25 AM
  • Just ran some internet tests at speedtest.net. Vista Ultimate = 11 to 22 ping and Windows 7 = 39-69 ping plus it stops on the download test intermittently and it gave me an error on the upload once. These tests were ran 6 times each to get this average and they were at the same location. Though the internet is reponsive this effects FPS gaming heavily. There is still an issue there. :(  


    Thanks
    Sunday, October 18, 2009 6:04 AM
  • No problem glad its helped.
    Not sure how to do this on vista or windows 7.

    There is another ping teak that is pretty good or it used to be, i havent posted it because it can fail sometimes and make your ping higher.
    If any one wants to try it, let me know and ill post it. To do it you have to windows xp professional and the windows xp professional O.S(Operating System) Cd.
    With vista all you need is your computer.  so let me know
    Sunday, October 18, 2009 4:58 PM
  • i think a few people are confused, not just here but every where. Some people seem to think that getting your ping higher is a good thing but its not its a very bad thing.

    50ms is good so dont worry
    150 ms is bad but still playing
    anything below 20ms is very good.

    Im going to help you here, this is one way to lower your ping.

    Step
    (1) Log into administrator.(Not an administrator account) log out and type administrator.(if you set a password when you first got your computer then type it in, if not then just press enter) If you are using the welcome screen hold Ctrl, Alt Delete. and type in administator.

    (2)Go to start, Run, type in gpedit.msc, press enter, Expand local computer policy, then expand administrative templates, then expand network, then click on Qos packet scheduler, then double click limit reservible bandwith, click it to enable, then put the bandwith % to %0. Then restart your computer(Restarting is very important)

    Ill explain what this does.

    Windows update reserves %20 of your bandwith for its updates, so your losing out, so this takes it away and gives it to you. when windows in downloading updates you internet will run a bit slower but over this is better.

    Also all the junk youv got from browsing slows down your internet. so delete your cookies, recent history and all that.

    Good luck.

    Also if playing with others who have high ping, this slows your down.

    To find out your ms on surtain servers, go to start, run, type cmd then enter. In the command box type ping and the server site or ip of which u want to play.

    Example; If you wanted to search servers for warcraft 3, stargate, diablo, type ping www.battle.net , for runescape, ping www.runescape.com , for darkthrone, ping www.darkthrone.com if u you dont know the server your game is playing from then google it.
    I have vista 64 bit and I have higher ping than almost everyone I play with, so I decided to give this a try. Only problem is when I open Run and type in gpedit.msc it says the file cannot be found, why is that? There may be a simple answer to this but I just know enough about computers to get me by.
    Sunday, October 25, 2009 10:49 AM
  • Its because your on vista. For vista you have to manualy edit the registry. Sorry i cant help you with this because iv never used vista before, im an xp guy and always will be.
    Monday, October 26, 2009 3:51 PM
  • Hi people,

    I've just bought Windows 7 the other day, and when I started installing games today I've hit the same problem that a lot of people around forums are reporting. Windows 7 brings high ping to games. Fact #1.

    I could try to understand that Windows 7 needs some maturity time, but we did pay for it, and we want it to work, not degrade our system and performance. But what's worse is that this issue is not being taken seriously.

    I am the owner of a gaming web site with 50-60,000 unique visitors per day. Gaming community is huge around the internet. I am sure that soon, the word of this will start being posted not just on forums, but in news coverage on game web sites around the internet. So Microsoft will go into another Vista fiasco. Fact #2

    On my Windows XP there were no issues with ping. As soon as I've installed Windows 7, my games weren't looking like games anymore due to the high ping.

    We're your customers, we want to stay your customers, please fix it.

    [EDIT] I have Windows 7 Premium
    Wednesday, October 28, 2009 10:13 PM
  • Thanks for the help Microsoft. I've solved it myself.

    My Intel Mobo doesn't support Windows 7. But I've found that my network adapter has new W7 drivers. I've updated those and it works now smoothly. No problems anymore.
    Saturday, October 31, 2009 4:41 PM
  • Hi all,
    i know some ppl here said something about changing TcpAckFrequency doesnt solve the problem,but i really think it does by changing the value to 1 ,ppl will see a huge difference when browsing and playing games even though some games use UDP ports!!!
    Qos policy is applied here a long time ago too so i guess thats why also games here is just perfect ^^
    but i decided to quit online games now(personal stuff) so i leave this info for those who play :D
    for further details for those who are intrested in changing that registry entry ,leave the request here then i post it...
    Regards,
    RR
    Saturday, October 31, 2009 5:02 PM
  • Ok so besides many ppl say it might not work for games i insist also have something to share with yall gamers...
    try to do this first:  type CMD in the search box then right click on the Cmd.exe then run as administrator and after that type these:

    netsh interface tcp set global chimney=enabled
    netsh interface tcp set global ecncapability=enabled
    netsh interface tcp set global congestionprovider=ctcp

    one line at a time and then see if it works for any of ya!
    hope this helps :D

    all my best,
    RR
    Monday, November 2, 2009 5:42 PM
  • hi im back with another stuff..
    also use this command in the prompt :

    netsh winsock set autotuning off

    it might help as well
    Regards,
    RR
    Saturday, November 7, 2009 8:29 PM
  • i tried everything you posted, nothing helped, ping still is high...since getting windows 7 ping just tripled....sad realy dont want to go back to XP just becose of that
    Monday, November 23, 2009 11:24 PM
  • i have the same problem with windows 7 home premium, ping 130-140 ms when i use internet explorer or firefox.
    windows vista 60-70 ms
    please fix it :(
    Wednesday, November 25, 2009 11:09 PM
  • had no problem until i "upgraded" to windows 7

    Wednesday, January 13, 2010 5:32 AM
  • Hi jfj64,
    look to this thread at the end of it,just consider the last 2 or 3 posts!
    http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/ead6955c-e426-4f10-a63f-0fdd112a3438

    Kind regards,
    RR
    Thursday, January 14, 2010 2:10 PM
  • this is something that is only occuring in windows 7!!!!!    i have xp sp3 vista and win 7 64 bit on 3 diff hd's in my comp boot into same server with each OS and with windows 7 ping goes up by about 50-60 

    bottom line is i don't have to do any tweaking on other os to play any of the games so why should i have to with the newest OS ?

     

    wake up Microsoft!!!!!!!!!! 

    Thursday, August 5, 2010 12:24 PM
  • I have the same problem on my windows 7. It seems the problem is somewhat related to the sound drive, I don't know why. I used to have windows vista my ping used to be 50-70 and now it moved to 100-300 its a great change that made my playing experience suck... With all that commercial that u made about windows 7 being faster gaming experience, was all bs, its the first and only windows that make it suck! Windows xp, windows vista didn't have this problem. THE ONLY WAY I FOUND THAT IT WORK is to disable the sound drive, the ping would go back to the way it should be, but you will have to play without a sound...... I still don't see the relations it seems that the sound drive is some kind related to the internet somehow during online game play.
    Tuesday, August 31, 2010 9:20 PM
  • I have the same problem on my windows 7.  It seems the problem is somewhat related to the sound drive, I don't know why.  
    I used to have windows vista my ping used to be 50-70 and now it moved to 100-300 its a great change that made my playing experience suck... With all that commercial that u made about windows 7 being faster gaming experience, was all bs, its the first and only windows that make it suck! Windows xp, windows vista didn't have this problem.  They should say windows 7 with the worst online gaming experience.


    THE ONLY WAY I FOUND THAT IT WORK is to disable the sound drive, the ping would go back to the way it should be, but you will have to play without sound...  I still don't see the relations it seems that the sound drive is some kind related to the internet somehow during online game play.
    Tuesday, August 31, 2010 9:25 PM
  • Disable sound drive, and open the game and you will see that the ping is back to normal, but you will have to play with no sound. 

     

     

    It seems that windows 7 is the only windows ruined the online gaming,  I still don't why the sound drive is related with the ping... but that's how it is. Maybe spying on you lol jk.

     

    Updating your drivers doesn't work.

    Wednesday, September 1, 2010 8:11 PM
  • hey sorry, but i cant find  :

    then double click limit reservible bandwith

     

    i check the list on settings didn't see it help me out thanks !!

    Friday, February 18, 2011 12:12 AM