none
Multiples Item-Level Targeting for IE11 Preferences

    Question

  • LO world,

    strange behaviour regarding Multiples Item-Level targenting to set IE11 preferences.

    First ILT check VLAN range to enable Proxy if computer is in a specific VLAN (otherwise no proxy needed)

    Second ILT check if an custom attribute in user obect AD to set IE11 preferred language for sharepoint

    If first ILT condition is met, no trouble found , Proxy is set-up et language is set up

    If first ILT condition is not met --> second ILT is bypassed !?!

    To test, I have switched order of ILT :

    If custom attribute is present , prefered language is defined, then second ILT is challenged

    If custom attribute is not matching one of conditions, second ILT is not challenged ... et proxy is not define even if computer is in specified VLAN.

    It seems that when a ILT return a false, then others are not challenged ?!?

    DC 2012R2, OS : W7 enterprise fully patched & W10 enterprise fully patched (same behaviour)

    What am I missing ???

    thx

    Monday, April 03, 2017 2:37 PM

Answers

  • LO Martin, thx for your tests

    Instead importing settings in a new GPO & modify it to my needs, I created a new one from scratch ...

    All is working fine !

    Note for myself : When using preferences, always recreate it , do not import from another GPO

    Thx !

    Wednesday, April 12, 2017 7:34 AM

All replies

  • > If first ILT condition is not met --> second ILT is bypassed !?!
     
    How are they connected? By default it's BOOL "AND", you can change via context menu.
     
    Monday, April 03, 2017 4:20 PM
  • f.e. I define an IE preference , with proxy enabled & defined. I set an ILT on it & trigger is a specific VLAN

    then I set another IE preference in same GPO , wich define preferred language in IE.

    If first ILT is Thrue, proxy is defined then second ILT is processed. no trouble found

    If first ILT is false , preference is not applied ... & 2nd ILT is not processed !

    meanwhile I have done further tests : even if I do not define an ILT on second set of preferences, it's not applied neither if first ILT return a "false" ...

    Tuesday, April 04, 2017 8:59 AM
  • Hi,
    When you apply multiple targeting items to a preference item and select the logical operation (AND or OR) by which to combine each targeting item with the preceding one. If the combined value of all targeting items for a preference item is false, then the settings in the preference item are not applied to the user or computer. 
    Best regards, 
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, April 05, 2017 8:52 AM
    Moderator
  • > meanwhile I have done further tests : even if I do not define an ILT on second set of preferences, it's not applied neither if first ILT return a "false" ...
     
    Cannot repro... Created 2 folder items as following:
     
    <?xml version="1.0" encoding="UTF-8"?>
    <Folders clsid="{77CC39E7-3D16-4f8f-AF86-EC0BBEE2C861}">
    <Folder clsid="{07DA02F5-F9CD-4397-A550-4AE21B6B4BD3}" bypassErrors="1" removePolicy="1" uid="{7759F144-CB18-4D42-A777-1DA4DA2541EC}" changed="2017-04-05 13:14:30" image="1" status="Computername1" name="Computername1">
    <Properties hidden="0" archive="1" readOnly="0" deleteIgnoreErrors="0" deleteReadOnly="0" deleteFiles="0" deleteSubFolders="0" deleteFolder="0" path="%DesktopDir%\Computername1" action="R"/>
    <Filters>
    <FilterComputer name="G*A*" type="NETBIOS" not="0" bool="AND"/>
    </Filters>
    </Folder>
    <Folder clsid="{07DA02F5-F9CD-4397-A550-4AE21B6B4BD3}" bypassErrors="1" removePolicy="1" uid="{DFD974B0-4191-4FB4-9CB1-421DA88E47C9}" changed="2017-04-05 13:14:41" image="1" status="Computername2" name="Computername2">
    <Properties hidden="0" archive="1" readOnly="0" deleteIgnoreErrors="0" deleteReadOnly="0" deleteFiles="0" deleteSubFolders="0" deleteFolder="0" path="%DesktopDir%\Computername2" action="R"/>
    <Filters>
    <FilterComputer name="DC*" type="NETBIOS" not="0" bool="AND"/>
    </Filters>
    </Folder>
    </Folders>
     
    On a computer named "DC2", the second folder gets created while the first one doesn't.
     
    Wednesday, April 05, 2017 1:16 PM
  • LO Martin, thx for your tests

    Instead importing settings in a new GPO & modify it to my needs, I created a new one from scratch ...

    All is working fine !

    Note for myself : When using preferences, always recreate it , do not import from another GPO

    Thx !

    Wednesday, April 12, 2017 7:34 AM
  • Hi,
    Great share and update, could you please help to mark it as answers? It will be greatly helpful to others who have the same question.
    Best regards, 
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Thursday, April 13, 2017 2:12 AM
    Moderator