none
Problem with removing documents from collection RRS feed

  • Question

  • Anyone help me please. I use FAST ESP 5.3. I removed 74 documents from a collection with indexeradmin rdocs command, the command went fine, it reported for example that 74 docs removed and success. But searching for the removed documents gives the result that only 17 documents were removed, 54 still exist. What can I do?

    Thanks, 

      Imre

    Monday, November 18, 2013 2:42 PM

Answers

  • Imre,
    Seems like index and fixml are not in sync.
    I would recommend running resetindex i.e indexadmin -a resetindex
    This should reduce the number of searchable documents. Please ensure feeding is stopped during resetindex.

    Tuesday, November 19, 2013 3:20 PM

All replies

  • Sorry, a correction: 74 documents I mentioned incorrectly, the correct number is 71.
    Monday, November 18, 2013 2:44 PM
  • Am assuming that you just wanted to delete some documents and NOT all the documents from the collection?
    Are you able to get fixml for these documents and do indexerinfo doccount <collectionname> show correct number of documents?
    Please also let us know the current patch of searchengine on the system.

    Monday, November 18, 2013 6:22 PM
  • Yes I just wanted to delete some documents (with specific internal ids).

    Sorry, your fixml related question I don't understand, but I did indexerinfo doccount <collectionname> for the specific collection and I got 53523 documents. This is a strange number because the number of searchable documents reported is 213348 (and the same number for the indexed documents).

    Here are some system details:

       

    Product Version 5.3.sp5   
    Installed Hotfixes 5.3.SP2.searchengine.patch02
    5.3.SP4.Adminserver.patch10
    5.3.SP4.searchengine.patch04
    5.3.SP4.searchengine.patch09

     Build Number 5.3.5.1   
     Build Platform win32   

    Thanks,

     Imre

    Tuesday, November 19, 2013 1:13 PM
  • Imre,
    Seems like index and fixml are not in sync.
    I would recommend running resetindex i.e indexadmin -a resetindex
    This should reduce the number of searchable documents. Please ensure feeding is stopped during resetindex.

    Tuesday, November 19, 2013 3:20 PM
  • Can you check that the internal id(s) which you put in the file to remove are still available in search result page. You can use the "Advanced" option to see the internal id f the results.

    Just want to confirm that these  documents are the same internal id(s) which your removed or the results are having different internal id(s) with same "Title", "body" and "URL" to check the duplicates things.

    Thanks

    Ashish


    Ashish Gupta Click "Vote As Helpful"! if you think that post is helpful in responding your question click "Mark As Answer, if you think that this is your answer for your question.

    Wednesday, December 4, 2013 6:21 PM