locked
Screen Saver Grace Period RRS feed

  • Question

  • I've got Windows 7 RC on a second PC that I've been using for a few weeks now, and it is driving me nuts.  We policy out a screensaver lock at 10 minutes, and since it's a secondary computer, I often don't touch it for 10 minutes.  With XP, there is a registry setting that allows a "grace" period after the screensaver kicks in and before the password kicks on.  Normally it's 4 or 5 seconds I believe.  Windows 7 doesn't seem to have this.  I created the registry key that worked in XP, but it doesn't seem to be working in Windows 7.  Anyone else noticed this, know of a fix, or am I just crazy?  I've tried googeling this, but I haven't been able to find any details for Windows 7.
    Tuesday, May 26, 2009 8:59 PM

Answers

  • Seems to be working for me, although the default is already set to (5) seconds.

    1. Enabled screensaver at (1) minute with screensaver lock
    2. Screensaver appeared and waited an additional (5) seconds
    3. Moved mouse
    4. Back at desktop

    Tried again after (10) seconds and got locked out.

    Added ScreenSaverGracePeriod (DWORD [decimal: 60]) to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\ and tried again after (10) seconds; this time I was back at the desktop.

    Perhaps the policy also defines the above key for security measures, as listed here:

    http://technet.microsoft.com/en-us/library/dd349797(WS.10).aspx#BKMK_13

    Added by Forum Moderator:

    Warning: While this solution solves the issue or problem, serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. For more information about modifying the registry, see Microsoft support article 256986.

    • Marked as answer by axfelix Tuesday, May 26, 2009 10:27 PM
    • Edited by Ryan Capp Tuesday, May 26, 2009 10:32 PM Clarification
    • Edited by Ronnie VernonMVP Wednesday, May 27, 2009 6:49 PM Required Registry Warning
    Tuesday, May 26, 2009 10:06 PM

All replies

  • Yep - even if I manically move the mouse just 1 second after screensaver kicks in, and I get kicked to the welcome screen.
    The grace period used to exist on Vista too, and it was a very good feature. Please bring it back :)
    Regards, Kristaps.
    Tuesday, May 26, 2009 9:12 PM
  • Seems to be working for me, although the default is already set to (5) seconds.

    1. Enabled screensaver at (1) minute with screensaver lock
    2. Screensaver appeared and waited an additional (5) seconds
    3. Moved mouse
    4. Back at desktop

    Tried again after (10) seconds and got locked out.

    Added ScreenSaverGracePeriod (DWORD [decimal: 60]) to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\ and tried again after (10) seconds; this time I was back at the desktop.

    Perhaps the policy also defines the above key for security measures, as listed here:

    http://technet.microsoft.com/en-us/library/dd349797(WS.10).aspx#BKMK_13

    Added by Forum Moderator:

    Warning: While this solution solves the issue or problem, serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. For more information about modifying the registry, see Microsoft support article 256986.

    • Marked as answer by axfelix Tuesday, May 26, 2009 10:27 PM
    • Edited by Ryan Capp Tuesday, May 26, 2009 10:32 PM Clarification
    • Edited by Ronnie VernonMVP Wednesday, May 27, 2009 6:49 PM Required Registry Warning
    Tuesday, May 26, 2009 10:06 PM
  • Okay, I did a bit more looking at it.  It seems that it kind of is working, but not quite as expected.  I think the confusion came from two things.  First, my screen was set to turn off after 10 minutes as well as my screensaver.  They didn't play nice and the grace period doesn't work.  Also, if you have your screensaver set to "None", when the screensaver goes off, it will black out your screen, then after the 5 second grace period is up, your screen will go to the welcome screen.  Not quite what I was expecting.  If you use a regular screensaver and set your monitor to turn off at a different time, it will work as expected.

    P.S. That reg key had to be a string value for it to work for me.
    Wednesday, May 27, 2009 12:57 PM
  • Don't know why it's working as a string, as all documentation states use as a DWORD:

    Data typeRangeDefault value

    REG_DWORD

    0x0–0x20C49B (2,147,483) seconds (approximately 24 days)

    0x5



    http://technet.microsoft.com/en-us/library/cc785331.aspx

    Wednesday, May 27, 2009 5:42 PM
  • Don't know why it's working as a string, as all documentation states use as a DWORD:

    Data type Range Default value

    REG_DWORD

    0x0–0x20C49B (2,147,483) seconds (approximately 24 days)

    0x5



    http://technet.microsoft.com/en-us/library/cc785331.aspx

    In that article that you linked, there is a comment at the bottom saying "Seems to only work if it's a REG_SZ. Seems strange to me!"

    I found one article saying that the Microsoft documentation was wrong.  I also found several articles that said you may need to try both.
    http://www.pc1news.com/modify-the-screen-saver-grace-period-1191.html
    • Proposed as answer by Ryan Capp Thursday, May 28, 2009 7:01 PM
    Thursday, May 28, 2009 5:45 PM
  • I have tried DWORD, QWORD (64bit) and REG_SZ

    I've tried on a clean install non-domain, clean install domain login, and systems that have been in use for a year or more.

    Friday, April 13, 2012 6:43 PM
  • Microsoft released a hotfix that fixed it for me.

    http://support.microsoft.com/kb/2685088

    Monday, September 17, 2012 7:18 PM