none
Users cant able login into PWA after Migration project server 2013 RRS feed

  • Question

  • Hi

    I recently migrated from Project server 2010 to Project server 2013 but unfortunately no one can able to login into PWA 2013 site

    In 2010 environment have only classic mode authentication (which is default web application)

    what was the issue?

    Let me know if any information need from my side

    Regards

    Santosh



    Thursday, September 11, 2014 11:29 AM

Answers

  • Issue has been resolved after performing below steps

    Update  WRES_ACCOUNT to claims using the following database script from Microsoft

       UPDATE pub.MSP_RESOURCES SET WRES_ACCOUNT = WRES_CLAIMS_ACCOUNT

    Wednesday, September 17, 2014 1:57 PM

All replies

  • You have to migrate the users to clasic to claims, with this powershell command

    (Get-SPWebApplication <web application url>).migrateUsers($true)

    Take a look TechNet http://technet.microsoft.com/en-us/library/ee662104(v=office.15).aspx at step 4, and after you do that, Sync your AD with PS.


    Ray Chapa



    • Edited by Ray Chapa Thursday, September 11, 2014 1:47 PM
    Thursday, September 11, 2014 1:46 PM
  • Thanks Ray

    i have executed this mentioned step but no luck and also tried without this command as this optional one

    Any one experienced this issue





    Thursday, September 11, 2014 2:25 PM
  • Hi,

    Have you also started the Claims to Windows service? If that has been started and you still experience the issue I would re-run the migration steps and make sure the command Ray mentioned has been executed successfully during the migration.

    Other things to try:

     - you may want to play a little bit with changing the permissions mode from SharePoint to Project Server and see if that would help

    - re-provision the PWA

    Hope this helps

    Paul

    Thursday, September 11, 2014 2:45 PM
  • Hi,

    Just for test, try to change manually one user, retype login name from Server Settings, and try with this user to enter PWA, let me know if works...

    Ray


    Ray


    • Edited by Ray Chapa Thursday, September 11, 2014 3:15 PM
    Thursday, September 11, 2014 3:15 PM
  • Hi Paul / Ray

    Thanks a lot for reply

    As you said let me try below power shell command 

    Set-SPPRojectPermissionMode –Url http://MyPS-2013/PWA/ -AdministratorAccount mydomain\administrator -Mode ProjectServer

    1) Is there any impacts in future after switching to project server mode?

    2) If require can we switch back to sharepoint mode from project server mode?

    Its an important thing to be include in the technet article but its being missed out in

    the post migration task

    Regards

    Santosh 

    Thursday, September 11, 2014 4:31 PM
  • Hi Santosh,

    After switching to project server mode you will have to manage the permissions using project server functionality (PWA Settings). You can switch back to SharePoint mode, however, please note the implications this will have (e.g. the RBS cannot be managed via SharePoint permissions)

    Hope this helps

    Paul

    Thursday, September 11, 2014 7:41 PM
  • I ran below command as you suggested but no luck

    Set-SPPRojectPermissionMode –Url http://MyPS-2013/PWA/ -AdministratorAccount dir\santosh -Mode ProjectServer

    All Users are getting below error when try to login PWA 2013 site. Did i missed out anything

    Error Screenshot

    I have tried couple of times but getting same error. To resolve this issue restarted server , services and open the user in manage user and made some modifications

    Please Help me

    Regards

    Santosh

    Friday, September 12, 2014 2:56 PM
  • Hi Santosh,

    I would suggest then going again through the migration steps and make sure the command that Ray mentioned is executed successfully. The command should be executed before the actual upgrade.

    As per this article:

    http://technet.microsoft.com/en-us/library/ee662104(v=office.15).aspx

    If you are migrating Project Server 2010 users who were using Windows Classic authentication over to claims-based authentication when upgrading to Project Server 2013, you will need to run the following Windows PowerShell cmdlet.  If this is not done, your users will not be able to log on to Project Web App after upgrade.

    Hope this helps

    Paul

    Friday, September 12, 2014 5:16 PM

  • As i mentioned earlier, i have performed all the steps as per technet article

    But still problem persists

    Regards

    Santosh

    Friday, September 12, 2014 5:30 PM
  • Issue has been resolved after performing below steps

    Update  WRES_ACCOUNT to claims using the following database script from Microsoft

       UPDATE pub.MSP_RESOURCES SET WRES_ACCOUNT = WRES_CLAIMS_ACCOUNT

    Wednesday, September 17, 2014 1:57 PM