none
long login process when using GPO

Answers

  • hi,

    i found a DC that is really slow (even working on it from RDP) and have moved it to a faster hypervisor. maybe this could have caused the problem.

    i will be checking the problem laptops to see any difference.

    • Marked as answer by Reno Mardo Thursday, December 24, 2015 11:16 AM
    Tuesday, December 22, 2015 8:59 AM

All replies

  • i'm checking the event log and one test PC is spending a lot of time, to me it seems, processing GPO and i'm getting events 4016 and 5016 many times. the time it took between 4016 and 5016 is just milliseconds yet there are many of them.

    so basically after logging in, the PC spend at least 2 minutes before getting the Desktop. for laptop users, it's longer.

    Sunday, December 20, 2015 2:07 PM
  • How many machines are affected?
    Tuesday, December 22, 2015 12:57 AM
  • Hi,

    >> i'm getting events 4016 and 5016 many times

    Events 4016 and 5016 show the start and end of processing of groups of policies, including how long it took to apply each one in the end event. You could find out which group policy took long time based on the logs and the applied GPO.Please run gpresult /r command to find out which GPO is applied.

    Alternatively, you could enable “Verbose vs normal Status Messages” policy (on higher operating system, the setting is named “Display Highly Detailed Status Messages”.)and reboot the machine, we are able to see the detailed startup/login messages.  The policy setting is under:

    Computer Configuration/Administrative Templates/System/

    Besides, take a look at the article below for information about slow logon issues:

    http://blogs.technet.com/b/askds/archive/2009/09/23/so-you-have-a-slow-logon-part-1.aspx


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 22, 2015 8:46 AM
    Moderator
  • hi,

    i found a DC that is really slow (even working on it from RDP) and have moved it to a faster hypervisor. maybe this could have caused the problem.

    i will be checking the problem laptops to see any difference.

    • Marked as answer by Reno Mardo Thursday, December 24, 2015 11:16 AM
    Tuesday, December 22, 2015 8:59 AM
  • Have you tried disabling unused portions of the GPO? If you have a computer GPO, why not disable all of the user settings so the clients don't look through that portion of the GPO?
    Thursday, December 24, 2015 2:31 PM
  • Hi,

    Thank you for sharing the solution and update.

    Best regards,


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, December 25, 2015 1:36 AM
    Moderator