locked
Migrate All MOSS 2007 Databases from a SQL 2005 Server to another SQL 2008 Server - *Instruction Inside*, only one little Problem at the End. RRS feed

  • Question

  • Hello Everybody,

    Well, due a 'Problem' with our Win 2003 w. SQL 2005 Standard x86 EN Server, we had to change to a complete brand new Win 2008 w. SQL 2008 Standard x64 EN Server. It was also nessesary to transfer all SharePoint Stuff from One Server to the other one. God bless Microsoft they imagine this case and wrote a Technet Entry for exact this case:

    - Move all databases (Windows SharePoint Services 3.0)
    http://technet.microsoft.com/en-us/library/cc512723(office.12).aspx

    - How to transfer the logins and the passwords between instances of SQL Server 2005 and SQL Server 2008
    http://support.microsoft.com/kb/918992/en-us
     

    I did all exactly as i was told in those technet entries, and except the Point that the new SQL Server has usually other Dynamic TCP Port's which can lead to the Problem that your Connection will be activily denied, all went really good.


    Okay, but here's my "Problem". After i've done with all i've tried to start our main WebSite and got immediatly a Error:

    The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) (C:\Inetpub\wwwroot\wss\VirtualDirectories\intranet80\web.config line 122) 

    Line 122 of the webconfig:
    <add verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />


    I've commented this Line out and started all Services ect ect. and tried it again and until now all seems to work without any Kind of error within the 12 Hive Log's or Systemlog of the Server. BUT, why i've got the error at all and what do i have to do to fix it. Even if i dont really know what exactly the WebControl does, its better to have a complete working system instead of uncommenting all not working stuff ^^.

    I would be happy about any help.

    Oh, and i've instelld on our WebFrontEnd the new SQL Management Studio 2008 (parallel to the 2005 edition).

    Saturday, November 6, 2010 10:42 AM

Answers

All replies