locked
Users Login as Administrator? RRS feed

  • Question

  •  I have Sharepoint Services 3.0 setup on a single-server environment.  The OS is Windows Server 2008, and the database is running through SQL Express 2008.

    I have the site collection created and everything is all up and running, minus one thing.

    Whenever a standard user logs in, their account is automatically turned into the Administrator account.

    This occurs 100% of the time, if they're simply using AD credentials and not added to the Sharepoint site, or if their account itself is added to the Sharepoint Members (contributing) group.

    Anyone have any suggestions on how to fix this?

    Thanks.
    Monday, November 17, 2008 4:31 PM

Answers

  • Hi Jason

    Check to see if you have anonymous access enabled both in IIS and in the SharePoint Central Administration.  If Anonymous access has been enabled, then the users will be logging in as whatever account you have setup as the anonymous access account. 

    If this is the case you may find that users who were previously accessing the site, may not be able to until you setup some sharepoint accounts for them

    Hope this helps.

    Regards


     
    Richard Hogan, Development Manager, SDT Ltd, www.sdt.co.uk
    Monday, November 17, 2008 4:55 PM
  • Hi Richard,

    Anonymous access was turned off, but when I went into IIS to check, I stumbled across an Advanced Setting that had the physical path directory being accessed as the Administrator.  I changed this to the current user, and this resolved the issue.

    Thanks for pointing me in the right direction!
    Monday, November 17, 2008 5:06 PM

All replies

  • Hi Jason

    Check to see if you have anonymous access enabled both in IIS and in the SharePoint Central Administration.  If Anonymous access has been enabled, then the users will be logging in as whatever account you have setup as the anonymous access account. 

    If this is the case you may find that users who were previously accessing the site, may not be able to until you setup some sharepoint accounts for them

    Hope this helps.

    Regards


     
    Richard Hogan, Development Manager, SDT Ltd, www.sdt.co.uk
    Monday, November 17, 2008 4:55 PM
  • Hi Richard,

    Anonymous access was turned off, but when I went into IIS to check, I stumbled across an Advanced Setting that had the physical path directory being accessed as the Administrator.  I changed this to the current user, and this resolved the issue.

    Thanks for pointing me in the right direction!
    Monday, November 17, 2008 5:06 PM
  • No Problems

    I am glad it was of some help.

    regards

    Richard Hogan, Development Manager, SDT Ltd, www.sdt.co.uk
    Monday, November 17, 2008 5:26 PM