none
Access denied error for all projects in project center for all users RRS feed

  • Question

  • Due to other impacts, we recently had to change the URL of PWA.  Everything went smoothly, except one issue.  When trying to open Projects within PWA from the Project Center, all users receive an "Error: Access Denied" message.  I've confirmed that users are still set up with the correct permissions that should allow them to access the Projects through PWA.  Any help is appreciated.

    Thanks,

    Andy Klarkowski

    Friday, October 17, 2014 2:56 PM

All replies

  • To add, users can succesfully open the same projects through MS Project Pro.
    Friday, October 17, 2014 2:57 PM
  • Hi,

    Can they access other pages of PWA? Only the project center is unaccessible?

    Have you tried CTRL F5?


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, MCP |

    Friday, October 17, 2014 3:53 PM
    Moderator
  • Hi Guillaume,

    Yes, all other pages of PWA are accessible.  The Project Center is accessible itself, up until the point where a user tries to open a specific project within PWA.  Currently, I'm at a loss as to why this is occuring.

    I tried the CTRL F5 and that did not resolve the error.

    Thanks,

    Andy

    Friday, October 17, 2014 5:45 PM
  • Can you access the PDP section under the server settings and try to open the PDPs (choose the ones associated with the EPTs of the projects)? Is it successful?

    Then edit and save them without changing anything to see if it helps.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, MCP |

    Friday, October 17, 2014 5:49 PM
    Moderator
  • Have you tried bulk update of project/project sites?

    You have to make sure the before and after URLs are similar (match - mine have the short URL and the FQDN under the new url) under this settings

    Also check your queue manager - this has slowed things up for me in the past, where a certain job was still processing during the changing of the URL and it couldnt work properly ... open the queue management jobs and see if you have a list of pending jobs - cancel the job that is holding up everything ... 

    • Edited by kbwrecker Friday, October 17, 2014 6:08 PM
    Friday, October 17, 2014 6:06 PM
  • Hi Guillaume,

    I can access the PDP section.  However, I am now unable to open the PDPs in an edit mode.  Prior to the URL change, I was able to access this section.

    Andy

    Monday, October 20, 2014 5:39 PM
  • kbwrecker,

    I just completed the bulk update and ensured the URLs are similar.  Users are still unable to access the Project Details though.

    The queue is also clean at this point in time with no pending jobs.

    Thanks,

    Andy

    Monday, October 20, 2014 5:40 PM
  • Can you go to the PDP librairy under the server settings, then to the permissions settings of the librairy and ensure that it inheritates permissions from parent site?

    Hope this helps,


    Guillaume Rouyre, MBA, MVP, MCP |

    Monday, October 20, 2014 5:51 PM
    Moderator
  • I'm now able to update the permissions setting within the PDP libraries.  I should have been able to as I verified the Admin security group contained such permission, however, since I still was unable to, I manually updated my user global permissions to allow editing access to the PDPs.  

    However, it appears the parent site does not have the correct permissions either.  Users are able to access everything in PWA yet, except the Project Details Pages.  However, the AD Sync is not updating the parent site permissions even though the automatically syncronize PWA users with Project sites is checked.

    • Edited by Andy Klarkowski Monday, October 20, 2014 6:51 PM Added action taken to access edit PDPs
    Monday, October 20, 2014 6:17 PM
  • When you go to the queue settings and add "success" from the job completion states - do you see the project sites in the list of successes?

    not sure which action worked and got the permissions (just so users who see this post later know which action to perform)

    thanks

    Monday, October 20, 2014 6:29 PM
  • Yes, I do see "Project Site Create" within the successes.

    Thanks for the recommendation.  I just edited the reply to inclue the steps taken.

    Monday, October 20, 2014 6:53 PM
  • Hi Andy,

    I got the same issue during a migration with a new URL. This is due to an incorrect update of the PWAURL property in the SPWeb object that still contains the old URL and causes access denied errors on PDPs.

    You can change it using PS command.

    $web = Get-SPWeb http://<serverUrl>/<PWAInstanceName>

    $web.AllProperties["PWAURL"] = "http://<newserverUrl>/<PWAInstanceName>

    $web.Update()

    Regards,

    Clément Comte

    Monday, October 20, 2014 8:12 PM
  • Clément,

    Thanks for the reply.  We tried using the PS command you referrenced, however, it did not resolve the current issue we are having. 

    To add detail to the situation, we have found that resources added post URL change are successfully syncing to SharePoint permissions.  However, all resources prior to the URL change are not showing up within the SharePoint permissions.  For key users, we have manually added them in the interim, but I do not want this to become a manual process permanenetly.

    Thanks again,

    Andy

    Wednesday, October 29, 2014 6:19 PM
  • Hi Andy,

    After adding all resources manually in the group, are they able to access the required page/project detail page?

    If it is so, then may be the problem persist because of the sync process being stuck in between. For this check all the resources are available in resource center as well as in the active directory group. Deactivate or Delete the users in resource center who are not present in the active directory group and check.

    Thanks


    Thursday, October 30, 2014 11:55 AM
  • Hi

    1] Run the below commands and check if the PWA url mentioned in "PWAURL" section is correct ?
    $web=get-spweb http://projectserver2010pwaurl
    $web.Allproperties | format-table

    2] Open Project group, in Global Permissions check if the "Open Project" option is selected ?

    3] Check if the PDP page is checked out ?

    Wednesday, November 12, 2014 7:26 PM