locked
Sharepoint 2010, Accidently removed the default account from Farm Administrators RRS feed

  • Question

  • Besides the BUILTIN\Administrators, there is another default account (my own domain account). It was accidentally removed. Is there a way to add it back?

    Have been pulling my hair during the past days, please help!

    Thursday, August 9, 2012 9:04 PM

All replies

  • I'm assuming you cannot log into Central Administration in order to put your account back. In this case, can you add yourself to the local administrators group on the (Central Administration) server? Once there you'll be able to log into Central Administration again and add yourself (Central Administration -> Security -> Manage farm administrators group -> New)

    Jason Warren
    Infrastructure Specialist

    Thursday, August 9, 2012 9:13 PM
  • Hi,

    As BUILTIN\Administrators group still has access try adding your account into this group of the server running CA.

    Then login back to CA and add your account in the list of farm administartors.

    I hope this will help you out


    Thanks, Rahul Rashu

    Friday, August 10, 2012 2:57 AM
  • Hi Jason/Rahul,

    Thanks for the info.

    I do belong to the local admin group. I am still able to logon to CA but every time I tried to add myself back (as stated in your instruction), I got the error screen. In fact, I am not able to add anyone to the farm administrators group. same error

    many thanks

    Monday, August 13, 2012 12:33 PM
  • What does the error say? If it's the generic "Unknown error," then what is in the ULS logs?

    Jason Warren
    Infrastructure Specialist

    Monday, August 13, 2012 1:18 PM
  • The error says:

     Error

    An unexpected error has occurred.

    Troubleshoot issues with Microsoft SharePoint Foundation.

    Correction ID: 312fd......

    Date And Time:

    Nothing meaningful in the ULS log, just a bunch of entering/leaving activities

    Monday, August 13, 2012 1:52 PM
  • What about for the events with the correlation ID?

    Jason Warren
    Infrastructure Specialist

    Monday, August 13, 2012 2:05 PM
  • Thanks. got this ignored, here is the message:

    08/13/2012 10:14:31.62	w3wp.exe (0x28DC)	0x0CA4	SharePoint Foundation	Runtime	tkau	Unexpected	System.InvalidOperationException: Namespace prefix 'xsd' is not defined.    at System.Xml.Serialization.XmlSerializationReader.ToXmlQualifiedName(String value, Boolean decodeName)     at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderDictionaryEntryArray.Read1_Object(Boolean isNullable, Boolean checkType)     at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderDictionaryEntryArray.Read2_DictionaryEntry(Boolean checkType)     at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderDictionaryEntryArray.Read3_ArrayOfDictionaryEntry()	d4cb074c-2cfb-4822-9989-9dbd85bd14cf	

    Monday, August 13, 2012 2:16 PM
  • Thanks Jason for your help!

    I added myself back using firefox!

    it was an IE issue

    Monday, August 13, 2012 2:27 PM