locked
HV 2012 R2 and LIS for Debian RRS feed

  • Question

  • good day

    We have HV Server 2012 R2. A vm (generation 1) with guest os Debian 7 is running on it. Get following eventlog:

    **
    "Networking driver in <virtualmachine> loaded but has a different version from the server. Server version 5.0 Client version 3.2......"

    **

    Have found LIS 3.5 on the ms website but it seems it is only for RHEL and CentOS.

    Is there any LIS available for Debian or do we have to life with those warning events logged?

    Thanks in advance

    Andre

    • Moved by BrianEhMVP Tuesday, October 21, 2014 3:13 PM
    Tuesday, October 21, 2014 10:43 AM

Answers

  • The LIS is built-in to Debian 7. Microsoft does not provide a separate downloadable package with LIS for Debian.  So there's nothing to upgrade.  Note that if you do "lsmod | grep hv", you will see that the Hyper-V modules list their version number as "3.1".  This version is not comparable with the "3.5" in "LIS 3.5", and does not indicate that your LIS is out-of-date.

    See http://technet.microsoft.com/en-us/library/dn614985.aspx for full details on the Hyper-V features that are supported with Debian 7.   I will note that we (Microsoft) have not worked as closely with the Debian community as we have with some of the other distros, so the feature matrix for Debian is not as rich as with some other distros.  We hope to correct that in the future.

    Regarding the Hyper-V event log message, unfortunately this message is present regardless of which Linux distro or LIS version you are running.  See http://support.microsoft.com/kb/2956569/en-us where we have publicly documented that these messages should be ignored.   These messages will be fixed in the next major release of Hyper-V, including in the Windows Server Technical Preview that was recently released.


    Michael Kelley, Lead Program Manager, Open Source Technology Center

    • Marked as answer by andre_80 Wednesday, October 22, 2014 12:21 PM
    Tuesday, October 21, 2014 4:39 PM
    Moderator

All replies

  • What do you looking for isn't LIS itself it is more related to the not yet installed Hyper-V Tools (Key Value pairs (Cloud Tools)).
    As you already found out LIS 3.5 is for older RPM based distros. I'm not sure why an actual Suse for example has Lis 3.1 build in but it seems to be the latest on Suse/CentOS/REHEL7.

    Unfortunately I wasn't able to get it all running on Debian and it looks as there is a lack of support of LIS/KVP at the moment.

    Eventually a blog entry of mine is a bit more helpfully to you. But usually I'm sticking more on ubuntu and Suse at the moment.
    Please keep me posted. I'm highly interested in how the things running.
    There aren't so much Linux on Hyper-V guys around ... ;(

    If you have found a forum or another good source where more Linux guys running around with expertise on Hyper-V, let me know as well.

    Linux on Hyper-V – a summary 10.2014

    Tuesday, October 21, 2014 11:05 AM
  • Thanks for your answer. messages says

    "... To upgrade, connect to the virtual machine and select Insert Integration Services Setup Disk from the Action menu...."

    But this seems not to work with Linux VMs. Thats why i tought it should be the LIS which need to be installed...So if i get it right, at the moment there is no fix for that for Debian? (im not into Linux). Well it seems to work so far...

    maybe an official statement from ms would be nice.

    

    Tuesday, October 21, 2014 11:25 AM
  • The LIS is built-in to Debian 7. Microsoft does not provide a separate downloadable package with LIS for Debian.  So there's nothing to upgrade.  Note that if you do "lsmod | grep hv", you will see that the Hyper-V modules list their version number as "3.1".  This version is not comparable with the "3.5" in "LIS 3.5", and does not indicate that your LIS is out-of-date.

    See http://technet.microsoft.com/en-us/library/dn614985.aspx for full details on the Hyper-V features that are supported with Debian 7.   I will note that we (Microsoft) have not worked as closely with the Debian community as we have with some of the other distros, so the feature matrix for Debian is not as rich as with some other distros.  We hope to correct that in the future.

    Regarding the Hyper-V event log message, unfortunately this message is present regardless of which Linux distro or LIS version you are running.  See http://support.microsoft.com/kb/2956569/en-us where we have publicly documented that these messages should be ignored.   These messages will be fixed in the next major release of Hyper-V, including in the Windows Server Technical Preview that was recently released.


    Michael Kelley, Lead Program Manager, Open Source Technology Center

    • Marked as answer by andre_80 Wednesday, October 22, 2014 12:21 PM
    Tuesday, October 21, 2014 4:39 PM
    Moderator
  • Thanks Michael for your feedback and information you provided. Good to know!!

    have done some research but havent found the post with kb2956569 before.. anyway, now everything is clear

    • Edited by andre_80 Wednesday, October 22, 2014 12:24 PM
    Wednesday, October 22, 2014 12:22 PM
  • Hi Mihael

    Please can you assist

    I am having slight difficulty with Vyos (formerly Vyatta) and Hyper v 2012 R2

    I believe there is a vlan trunk and tagging issue

    Please advise how can I overcome these issues

    Helium Vyos 1.1.6  System Type X86  HyperV

    How do I check the Linux kernel in Vyos ?

    Monday, November 30, 2015 2:22 PM