locked
A Rather Unexplained and Slightly Confusing Fatal Error RRS feed

  • Question

  • Since about a year ago I started playing around with C languages, everything was golden and ran rather well. However when I wrote an app that I will link below that seemed to behave in a very strange fashion.

     

    https://drive.google.com/file/d/0B4fqFvNG5t5oazFMb2Q5UUR4OGM/view

     

    The code compiled correctly however on my main computer something strange happened. It was a run time error that I have not seen before and when I ran the program in a VM and on a different computer and even in Linux it did not appear. The program operated in every single system without fault. I even tried moving from the VS2012 Compiler to GNU however things got even worse. The program compiled under GNU and it never threw a run time error the one compiled with VS2012 did however throw an error. The program compiled either by GNU or by VS simply locked up and remained open, it could not be closed by task manage or anything else I know of. It consumed a grand total of about 102k of ram with slight variances each time it was executed. I did a bit of research as to why this issue is occurring and I even tried using a few command lines in CMD to try to fix it. Simply put I have been unable to pin point the issue and my research has been simply inconclusive, I am here today to ask has someone already had this kind of problem and how best would it be resolved.

    More information can be found in the Google drive link with the program and a snapshot of the error. The computer in question runs an i7-2700k,GTX 770, 8GB of ram and Windows 7 Ultimate Service Pack 1 build 7601. If any of you need more information I will try to get it.

    Also sorry for this being a Windows 7 Issue under a Windows 8 Forum. If that's an issue then please tear me apart below.

    Saturday, November 14, 2015 9:48 AM