none
System state backup on Server 2012 R2

    Question

  • Using the WSB utility, I get the following error "The process cannot access the file because it is being used by another process."

    I ran the utility through powershell and got the same error.  I checked the log files and get this error "Error in deletion of [C:\System Volume Information\001.dat] while pruning the target VHD: Error [0x80070020] The process cannot access the file because it is being used by another process."

    Looked at resource monitor and system constantly has access to the file.

    Any help would be appreciated.

    Thanks


    • Edited by PTRDB Tuesday, December 16, 2014 5:42 PM
    Monday, December 15, 2014 9:50 PM

Answers

  • Hi,

    Besed on my research, the files C:\System Volume Information\001.dat is attributed to Kaspersky anti-virus software which is not be able to backup. I suggest you except the file to run System State backup.

    Best Regards,

    Mandy 

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, December 25, 2014 9:51 AM
    Moderator

All replies

  • Hi,

    Do you install any Symantec software on your server? You could stop and disable all of Symantec Services to check the results. 

    The other troubleshooting step would be to download process monitor and see if you can figure out what process is causing the error.

    For more detailed information, please refer to the thread below:

    System State backup always inconsistend with error 0x80070020
    https://social.technet.microsoft.com/Forums/en-US/75f5dc94-68b0-43ee-9c71-03b2cb95cd73/system-state-backup-always-inconsistend-with-error-0x80070020

    Best Regards,

    Mandy

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 17, 2014 9:24 AM
    Moderator
  • Thanks for the reply.

    There are no Symantec products on this server.  The server does have Kaspersky EndPoint 10 though.  I have already disabled it and tried a new backup with no luck.

    I did run resource monitor and found that image "system" with PID 4 has had the file locked.  Other than that, I don't see anything else accessing that specific file.

    Thursday, December 18, 2014 7:43 PM
  • Hi,

    Besed on my research, the files C:\System Volume Information\001.dat is attributed to Kaspersky anti-virus software which is not be able to backup. I suggest you except the file to run System State backup.

    Best Regards,

    Mandy 

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, December 25, 2014 9:51 AM
    Moderator
  • Hi Mandy,

    I've the same problem: "error during system state backups with kasp endpoint security 10 installed, the backup start but after few second stops with error in deletion of .001 file into system volume information.

    I've try to exclude that file from kasp console... but maybe I must exclude it from VSS backup from the windows backup console?

    thanks in advance.

    luck

    Thursday, June 18, 2015 12:43 PM
  • Hi Mandy,

    I've tried above solutions..is not work for me too. Any others way to solve it?

    Regards,

    Nick



    Friday, August 28, 2015 6:25 AM
  • Would klmeta.dat, in the same directory, belong to the Kaspersky instalation as well? Having the same issue with that file.
    Friday, September 11, 2015 4:44 PM
  • We have same problem! But still cannot found solution...

    Microsoft Windows Server 2012 cannot use wbadmin to backup after installed Kaspersky Antivirus

    Friday, April 7, 2017 3:51 AM
  • File exclusion doesn't work at all on 2012 R2 ! I'm trying to exclute *klmeta.dat inside C:\System Volume Information\ in my scheduled backup policy, but each time my exclusion disappear ....

    Hope Microsoft already planned to resolve this issue on next kb...

    Monday, July 31, 2017 3:30 PM
  • File exclusion doesn't work at all on 2012 R2 ! I'm trying to exclute *klmeta.dat inside C:\System Volume Information\ in my scheduled backup policy, but each time my exclusion disappear ....

    Hope Microsoft already planned to resolve this issue on next kb...


    Hear hear! This issue still not resolved. One can delete all backups and re run it and it will then succeed.
    Friday, August 11, 2017 10:44 AM
  • klmeta and 001.dat and 002.dat all come from Kaspersky as I can see and they cause backup problems from time to time
    Friday, August 11, 2017 10:45 AM
  • It works once, like the firt time, but it still doesn't work for the next one ...
    • Edited by Supaxor Friday, August 18, 2017 7:22 AM
    Friday, August 18, 2017 7:17 AM
  • I have the same problem. When removing kaspersky the backup has returned to normal. I do not know what else to do. Has anyone discovered any?
    Saturday, March 10, 2018 3:56 PM
  • me too!

    all of a sudden - backups stopped working, i added an exclusion on the KLMETA file location .. it still failed on that file! I uninstalled Kaspersky and its fine - put Kaspersky back on .. FAILED BACKUPS again!

    Wednesday, March 14, 2018 2:17 PM
  • I had the same issue on Server 2012 R2 Essentials. I was running the workstation version of Endpoint Security 10. I switched to the server version and this resolved the issue for me. I am also running the Kaspersky administration server on this server. Uninstalling the Kaspersky Endpoint Security 10 Workstation version and installing Kaspersky Endpoint Security for Windows Server did not adversely affect the Administration server installation. There is no need to uninstall or replace the agent.
    Thursday, March 22, 2018 12:11 PM
  • Hi All

    it works as soon as you remove old backup from backup <g class="gr_ gr_108 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="108" id="108">dirve</g> and reschedule it. seems the only way it is.


    Sunday, June 24, 2018 7:15 AM