none
RDS Session Based Farm Broker Server is Broken!!!!!

    Question

  • SERVER 2012R2

    I have 3 servers. One is a broker and web access server. The other two are session hosts. 

    From the Broker server I added the session host in "All servers" then I ran the RDS role installation and I assigned the roles as previously indicated. 

    I created a collection. Added the hosts to this collection and I took care of the CAL servers. 

    I can still connect remotely to the session host. In the past the broker would prevent that from happening and I would would get thrown into a random session host to account for load balancing. 

    What am I doing wrong ? 


    • Edited by SilentCow Tuesday, March 21, 2017 1:38 AM
    Tuesday, March 21, 2017 1:37 AM

All replies

  • Hey,

    If you try to connect to another server in the farm while you connected to the first one, will it let you do it?
    As far as I experienced with all the RDS environment I deployed that was the case,The first time we try to connect it will work as the server has no "load balancing" to do.

    Saggie.


    • Edited by Saggie16 Tuesday, March 21, 2017 7:24 AM
    Tuesday, March 21, 2017 7:23 AM
  • Hi,

    To configure RDS on Windows Server 2012 R2:

    • create collection for RDSHs, and add RDSHs to the collection
    • create an A record in DNS with the record name:<collection name> record IP address:<RD Connection Broker's IP address>
    • if you want to connect RDSHs with mstsc.exe (it is recommended that connecting with Rd Web Access), you need add the registry key DefaultTsvUrl     REG_SZ     tsv://MS Terminal Services Plugin.1.<collection alias> under the path below on RD Connection Broker

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\ClusterSettings

    In addition, you could configure the load balancing in RDS deployment like below.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 21, 2017 8:53 AM
    Moderator
  • Thanks!

    To Saggie: it will let me connect at my desire. 

    To Jay: If I connect via IP or the name of the collection I get thrown into the broker and nobody gets thrown into its session hosts. 

    Tuesday, March 21, 2017 12:31 PM
  • Alright so I toggled my session hosts role and now it works. 

    Next question : 

    How can I make the rdbroker reachable through remote desktop without relying on the rdp page it produces ?

    Tuesday, March 21, 2017 5:59 PM
  • do you have GPO applied to those session host?
    If so, make sure that the "Use RD Connection Broker load balancing" settings under:
    Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\RD Connection Broker
    Is not disabled!

    if you dont have GPO or this setting is not configured, I can advise you do remove the servers from the collections and re-add them. I had this issue once on my company environment.

    hope it will help, if not, we will continue trying :)

    Saggie.

    Tuesday, March 21, 2017 6:16 PM
  • Hi,

    To Jay: If I connect via IP or the name of the collection I get thrown into the broker and nobody gets thrown into its session hosts. 

    >>>If you connect with IP address of RD connection broker by mstsc.exe, the user will connect to RD Connection Broker, it normal. If you connect with collection name (you have created the A record for RD connection broker and collection in DNS. And added the registry key in registry) by mstsc.exe, the RDP session will be redirected to RD Session Host by RD connection broker.

    How can I make the rdbroker reachable through remote desktop without relying on the rdp page it produces ?

    >>>Would you tell us the mean that “without replying on the RDP page”?

    Do you mean RD Web Access?

    Here is an article below about RDS for your reference.

    Remote Desktop Services Overview

    https://technet.microsoft.com/en-us/library/cc725560%28v=ws.11%29.aspx

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 22, 2017 5:23 AM
    Moderator