none
Cannot switch account without being logged out

    Question

  • Windows 10 x86 (but same behavior occurs on Windows 8.1).

    I am not able to switch user accounts. (Local account, administrator). Switching account _always_ causes the current one to be signed out, regardless of method used (ctrl+alt+del or windows+x or just clicking start and tapping the other user's username).

    Windows has been clean-installed and reinstalled twice, also installed from an iso once and gone through in-place upgrade once.

    DISM and SFC report no issues.

    No special configuration has been performed to enable or disable this kind of behavior.

    Monday, February 1, 2016 8:48 PM

All replies

  • This might help : 

    http://www.tenforums.com/tutorials/7394-switch-user-windows-10-a.html


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Proposed as answer by arnavsharma Monday, July 25, 2016 4:43 AM
    • Unproposed as answer by LittleVulpix Monday, July 25, 2016 7:20 AM
    Monday, February 1, 2016 9:26 PM
  • Are you using a remote connection to log on at all?
    • Proposed as answer by arnavsharma Monday, July 25, 2016 4:43 AM
    • Unproposed as answer by LittleVulpix Monday, July 25, 2016 7:18 AM
    Monday, February 1, 2016 10:10 PM
  • @arnavsharma - You could say I'm an advanced user. Regardless, I checked all of those and no result, or rather, it's I've had a microsoft support tech remote desktop my PC and he couldn't figure it out either.

    @-Mr Happy- Nope, just regular login into an account on the actual device (local account, password-protected, no picture login or pin used; but I tried account with no password and the behavior is the same). Not using remote as it's not possible on W10 Home edition.

    To repeat - the system is cleanly installed and even reinstalled a couple of times, using different methods, always also verifying the health etc; there is nothing wrong with it. The behavior however remains the same.

    Monday, February 1, 2016 10:40 PM
  • Hello,

    Well working out these differences is the tricky part. I have a Windows 10 Home 10586 I have just done fast user switching with, two local users switched from one to the other then back (via the start menu). Then the start menu show the other user now as Signed in. The system is a Hyper-V VM, 1 socket 2 cores, 2 GB memory so pretty basic. Clean 10586 aka TH2 install. 

    So are these both local accounts? Do you get any warnings about the current user being logged out?

    Monday, February 1, 2016 11:08 PM
  • They're both local.

    I get no warning if I just have some programs running etc. If I have some opened documents or things that need saving, windows will show that "these programs are preventing windows from logging off".

    Also when you switch it literally says "signing out" as it brings me to the login screen; which is very funny because when I open the windows shutdown dialogue (by clicking on desktop to focus it and then pressing ALT+F4) and pick "switch user", the little description underneath says "Switch user without closing apps".... which clearly isn't the case.)

    And yeah, I tried this on another computer and also in a virtual machine but they all behave normally like you'd expect. No issues. So what gives?

    Tuesday, February 2, 2016 1:01 AM
  • Well have you looked in Event Viewer at all to see any related looking events? Right click start open Event Viewer, I would say expand Windows and System see if anything is logged in there at user switch time.

    Also be worth checking from a clean boot I would say to rule out or in third party software. How to perform a clean boot in Windows explains the process.

    Tuesday, February 2, 2016 6:29 PM
  • I checked the events, and it shows events related to "user initiated logoff", when I was diagnosing it. It simply looks as though I clicked "log off" instead of "switch user". I don't understand why, because I really selected switch user in all possible ways (result is always the same)

    Also, I had microsoft support tech on that computer and he did a clean boot but obviously no difference either. After all, it was a cleanly installed system with literally 0 extra things on it. Just a fully updated system and drivers. Nothing less, nothing more.

    Tuesday, February 2, 2016 7:25 PM
  • Well pretty much got me stumped too this one. Just for record what version of Windows 10 build wise? and are other machines tested on from the same media, where did the media come from?
    Tuesday, February 2, 2016 9:37 PM
  • Installation media from here=> https://www.microsoft.com/en-au/software-download/windows10 .

    OS: W10 Home

    Version 1511

    Build is 10586.71, as I said all of the latest updates applied and everything.

    It is also fully activated (digital entitlement), though I doubt that would be an issue.

    I used teamviewer to record it (because teamviewer runs as a system service so it survives a logout), for the most part (it cuts out briefly and it doesn't show the signing out screen ... but it shows that I am doing things properly at least).


    Issue

    ( https://youtu.be/yzVeUwBxJ7Q )

    See for yourself.

    Tuesday, February 2, 2016 11:15 PM
  • Hi,

    I see what the issue is, and also I have tested on my machine, there is no such issue. The issue is weird.

    Please help to capture the process when you switch user account.

    I've traced logon/logoff using this method
    Start Process Monitor in Account A
    Switch User
    Logon to Account B
    Logoff Account B
    Logon to Account A
    Stop Process Monitor

    Other methods of capturing logoff are given one hour eleven minutes into this video  
    Windows Sysinternals Primer: Process Explorer, Process Monitor, and More | Tech·Ed North America 2010 | Channel 9 
    and in this article
    http://blogs.technet.com/b/markrussinovich/archive/2010/01/13/3305263.aspx


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, February 4, 2016 12:43 PM
    Owner
  • I captured the log as described.

    I had to start the process monitor as local service ( psexec –sd –i 0 c:\sysint\procmon.exe /backingfile C:\PMLOG.PML ) and then stopped it the same way. Obviously starting it normally didn't work because as I said, switching user signs me out.

    Captured events-> Start of process monitor in interactive local system session, USER SWITCH (from user Joe) to user "Vulpix", start of explorer on user Vulpix, USER SIGN-OFF from user "Vulpix", USER LOG-IN to user "Joe". Obviously, programs started on Joe initially were all closed.

    The trace is here: (zipped cause it was like 500MB in total). 1drv.ms/1nJh11k

    Thursday, February 4, 2016 3:27 PM
  • Tested again on build 10584.104, no change. Not that I expected any, just saying that I tested it and the behavior is still the same.

    @Kate Li - anything useful in the trace?

    Thursday, February 11, 2016 7:39 PM
  • I have this exact same problem on multiple windows 10 machines.

    I have windows 10 Pro on all of the machines. Worked perfectly fine before the upgrade on windows 7 Pro.

    as soon as you rdp into a machine all existing open applications are closed. Also when i exit the rdp session it says all applications will continue to run, but when you log back in locally they are closed.

    I have tried to gpedit the session timeouts to never with no effect. 


    Wednesday, February 24, 2016 5:01 PM
  • Yes this behavior pretty much breaks RDP. You can just try it by trying to switch a local user (not using RDP, but just as you would on the machine), it just signs you out when you try to switch. The two issues are related and basically the same.

    To try and see what the culprit could be (I ruled out RAM since it works fine on a VM with 900MB ram but not on my device with 1GB), lemme ask you this - are the devices you are experiencing this issues with portable? (Tablets/laptops) ?


    The RDP behavior logged as a ticket here.
    • Edited by LittleVulpix Wednesday, February 24, 2016 6:09 PM Added related link
    Wednesday, February 24, 2016 5:46 PM
  • No change in 10586.122. Are there really no news on this?
    Sunday, March 6, 2016 4:21 PM
  • No change in 10586.164.
    Friday, March 25, 2016 9:33 AM
  • Behavior unchanged in 10586.218 :( c'mon, is it really so hard to say a) this is because of X, it will never work or b) this is a bug, it will be fixed.. ?
    Tuesday, April 19, 2016 11:57 AM
  • No, I am not. I was also able to verify that this happens on all bay trail tablets I managed to test it with - 7 different models, some of which had 2 GB of memory.

    I am merely tapping my name and clicking the other user's name just like you normally would.

    Recording of the issue

    Please check the youtube video above.

    Monday, July 25, 2016 7:18 AM
  • Hello,

    No, this does not help at all. I'm an advanced user and I've tried literally everything I could to switch user. It's not that I don't know how to do a fast user switch. It's that whenever I do it - via any of the several possible ways - the currently logged-in user gets logged out forcibly.

    Recording of the issue

    Monday, July 25, 2016 7:20 AM
  • Behavior still the same in 10586.494 across multiple devices with bay trail platform - all of them tablets, some with 1GB and some with 2GB of RAM.
    Monday, July 25, 2016 7:22 AM
  • I can confirm this issue on Windows 10 Pro v1511 running on a desktop with a Core 2 Duo (E6550) with 1GB RAM. I upgraded this computer from Windows 8.1 Pro, which didn't exhibit this problem; I previously had Vista Business on it, which also didn't exhibit this problem.

    Initially I noticed that every time I reconnected to the computer, it would start a new session rather than connect to the one I had previously disconnected to. What clued me in to the fact it wasn't a 'log-off on disconnect' problem (apart from the fact that the RD host disconnect policies weren't having any effect) was the fact that even logging in locally and then connecting with RDC would log me out again (rather than transferring the session to RDC as in previous versions.) Logging in with RDC first and then logging in locally also has the effect of signing out the logged in user (rather than transferring the session to the local screen.) Eventually, I came across this thread, which spurred me to test simply switching users, which - sure enough - signs me out.

    While I can work around the issue, it's really inconvenient. I could imagine that 'switching users signs the current user out' is a matter of limiting resources used by the system, but even if it isn't a bug, it shouldn't affect logging in to the currently active session.


    • Edited by MarkKB Saturday, July 30, 2016 8:30 AM
    Saturday, July 30, 2016 8:27 AM
  • I too have this problem in my office. I have tested on many of our computers and the same problem exists. Its May of 2018 and this hasnt been resolved yet? Please help if you have a fix for this.
    Thursday, May 3, 2018 2:58 AM