locked
Error (12700) VMM cannot complete the Hyper-V operation on the OCGDE0HV01.OCGDE.CORP server because of the error: 'VM' failed to RRS feed

  • Question

  • Hi,

     

    I have a strange behavior:

     

    My physical host runns Hyper-V and SCVMM. The Lib shar is local on the machine and shared through a former Beta 3 installation of SCVMM.

     

    SCVMM runs under SQL 2008

     

    In the Lib share I have a folder called ISOs and hosts all my needed ISO files for mounting.

     

    I create a new VM an will mount the install iso to the VM and choose Exisitng image file. Ich brows to the iso and choose it. I activate Share image file instead of copying it.

    Wenn I apply, then I get following ERROR.

     

     

    Error (12700)

    VMM cannot complete the Hyper-V operation on the OCGDE0HV01.OCGDE.CORP server because of the error: 'VM' failed to add device 'Microsoft Virtual CD/DVD Disk'. (Virtual machine ID 6B4D7AAE-4FAE-483C-A95C-BC792CED6B70)

    'VM': The machine account 'Domain\SERVERNAME$' does not have read access to file share '\\ServerName.DOMAIN.CORP\MSSCVMMLibrary\ISOs\en_W2k3_x64.iso'. Please add this machine account to the file share security. Error: 'General access denied error' (0x80070005). (Virtual machine ID 6B4D7AAE-4FAE-483C-A95C-BC792CED6B70)

    (Unknown error (0x8001))

    Recommended Action

    Resolve the issue in Hyper-V and then try the operation again.

     

     

    It seems some have solved the problem by adding the machine account of the physical host to the share and NTFS-permissions of the library, but that doesn't work for me.

     

    Any Solutions from you guys?

     

    I apprichiate it, to get a fast solution, I need it for production!!!!! 

     

    Thanks

     

    Josef

    Thursday, November 6, 2008 4:26 PM

Answers

  • The solution is to grant 'Authenticated Users' read access on both the share and NTFS.

     

    /Michael

     

    Thursday, November 6, 2008 8:09 PM

All replies

  • The solution is to grant 'Authenticated Users' read access on both the share and NTFS.

     

    /Michael

     

    Thursday, November 6, 2008 8:09 PM
  • THX Michael, that was the right hint.

     

    I ask my self, why does not the setup this setting?

     

    Anyway I kow it now and will look at it.

     

    Cheers Josef

    Friday, November 7, 2008 11:18 AM
  • Great - I too don't understand why the setup doesn't fix this...

     

    /Michael
    Friday, November 7, 2008 11:23 AM
  • I am having the same issue but even when I set the privilege to Authenticated Users, it still fails. Any other recommendations?

    Friday, November 7, 2008 7:00 PM
  • If you are running the VMM on a different machine than the Hyper-V server, you will also have to delegate cifs on the Hyper-V object to the VMM server in Active Directory.

     

    /Michael

     

    Friday, November 7, 2008 8:14 PM
  • We are running our VMM on a virtual machine within the Hyper-V environment. We have also raised our AD to Windows Server 2003 to get the "Delegation tab".

     

    To ensure we understand the requirement, the Hyper-V server is called HV and the VMM manager runs on a server called VMM-MGR. We have modified both the HV delegation and provided cifs to VMM-MGR and did the reverse as well (delegating cifs to HV on the VMM-MGR object) but we still fail with the same error.

     

    Have we missed or misunderstood a step?

     

    Thanks again.

    Friday, November 7, 2008 8:44 PM
  • What you have done sounds rigth to me. I have solved the problem on three different Hyper-V installations by doing this. I am sorry, but I don't have any other hints...

     

    /Michael

     

    Monday, November 10, 2008 7:28 AM
  • We are trying to track down the event log entry to help diagnose where the failure is occuring. Looking at both the VMM-MGR event log, the VM host itself, and the Hyper-V host, none seem to list any failures. If we can find out where the event log is being recorded (other than within the VMM application itself), it may help us understand "who" is trying to log in and receiving insufficient rights.

     

    Thanks again for any help you can provide.

    Monday, November 10, 2008 4:38 PM
  •  

    Anyone got any official feedback from Microsoft on this? I'm utterly reluctant to give Authenticated Users access to my VHDs - there must be a better way to solve this.
    Monday, November 10, 2008 7:00 PM
  • I just received a response from Microsoft and they have indicated that it is a known problem with VMM. Instead, you have to use the Hyper-V manager in Windows Server (or Vista) instead. They are aware of the problem and are looking into enabling that scenario in the future but no commitments or dates yet. From what I can tell, this means the only way to associate an ISO image to a virtual client's CD/DVD drive is to copy it.

     

    Monday, November 10, 2008 8:32 PM
  • Same issue here,

     

    CIFS is delegated, Auth Users added to both NTFS and share... and NADA.

     

    Anyone have the problem when you try to build a VM and it won't let you choose your Hyper-V server as a destination because of the error:

     

    Virtualization platform on host XXXX does not support shared DVD ISO images.

     

    ??

     

    That error shows up in the "Select a host" dialog under Rating Explanation and then obviously fails if you attempt to put it there anyway with:

     

    Virtualization platform on host XXXX does not support shared DVD ISO images.

    Remove the shared ISO image from hardware profile or select a different host.

    ID: 11028

     

    <rant>

    Since when did RTM = Beta 3? It seems like everything MS is putting to RTM is not even close to finished and is riddled with problems. I would rather wait a month or two for something that worked well than have to deal with semi-functional software. I ran into this with Exchange 2007 and DPM 2007 too. I remember during the Exchange 2007 mess people at MS were saying, "we were under the gun to release it so we did, but it is missing stuff". Cripes, someone needs to fire the upper management if they can't understand that semi-functional software is useless and just bothers IT pros, futher tarnishing the opinion of the company with their partners/clients. When is Bill Gates coming back? 

    </rant>
    Monday, November 10, 2008 9:17 PM
  • I can confirm that it works by attaching the CD/DVD using Hyper-V manager. I had to grant the Hyper-V machine accounts read access to the MSSCVMMLibrary share, but that is a whole lot better than giving it to Authenticated Users.

     

    Tuesday, November 11, 2008 9:23 AM
  • Well through the Hyper-V Manager it works perfectly for me as well, however SCVMM will not permit it and says it's not supported.

    Tuesday, November 11, 2008 1:59 PM
  • Are you sure you're setting the proper rights at the share level? I missed this part and had to re-read Michales post in order to get it right.
    Friday, December 12, 2008 6:39 PM
  • Hi,

    I've encountered the same error.

    The solution was:
    1. set permissions to VM folder for Network Service to Modify (I suppose it's because VMSSC is installed)
    2.  set permmisions on virtual machine folder for VM account

    icacls folder /grant "NT VIRTUAL MACHINE\Virtual Machines":(CI)(IO)(GR,WD,AD)
    icacls folder /grant "NT VIRTUAL MACHINE\Virtual Machines":(R,WD,AD)
    (http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/299f6f4b-9933-4027-a92d-c76350eb2d00/ )

    This did the trick for me.

    I also recommend using auditing option for debuging. To do this in AD enviroment:
    1. create test group polisy, eg "test policy"
    2. set Audit object access - failure  (computer Configuration\Windows Settings\Security Settings\Local Policies/Audit Policies)
    3. assign this gpo to hyper-v server
    4. check security log on server for further hints

    Renata


    Renata J,
    Wednesday, February 18, 2009 3:26 PM
  • Hi.

    I have a different solution to this problem.

    We have our Hyper-V nodes connected to a SAN and I always create LUNs 1 gb larger than the actual size of the VHD I'm about to create (so that I can make the VHD, for instance, 50 Gb and not 49 Gb).

    I then always used fixed size disks instead of dynamic as I'm keen to remove any performance overhead I can. VMM always fails to connect an ISO-image to a VM created this way.

    VMM uses the LUN that I've assigned to this VM in order to store the ISO-image - at least in our clustered, SAN-connected setup. When I create a VHD that fills the LUN to 99% there's no room for a DVD image of Windows 2008.

    I've verified this by creating a 20 Gb dynamic disk VHD on a 21 Gb LUN and successfully assigned the same ISO that failed on a 20 Gb fixed disk VHD on a 21 Gb LUN.

    My colleague always creates his LUNs 50% larger than his VHDs and he never sees this error.

    Hope this helps someone - I grew an ulcer trying to solve this...
    Monday, March 23, 2009 7:50 AM
  • We are having the same issue here, and have yet to solve it.

    We have two hyperv servers - s4hyperv and s4hyperv2
    the SCVMM server is installed on s4hyperv2
    The library share is located on s4hyperv2

    When trying to attach the iso file & share it rather than copy it (why would you want to waste disk space by copying the iso everytime you need it??) i receive the same error others have reported, both with the target virtual machine on s4hyperv as well as on s4hyperv2


    I am able to successfully attach an existing ISO to a machine (*without it being copied) if i do it through the Hyper-V manager console on the hyper-v server that the vm resides on. However- this is just not an acceptable solution for me, as it creates additional steps that must be taken just to do this. When you have the SCVMM console installed on your workstation, its much easier to add the iso to the vm from there, rather than having to log into the hyperv server and do it there (i know its not much to do, but its still frustrating!)


    Here is the error that i receive.

    Error (12700)
    VMM cannot complete the Hyper-V operation on the s4hyperv.domain.com server because of the error: 'Server2003' failed to add device 'Microsoft Virtual CD/DVD Disk'. (Virtual machine ID 911A90E9-7C87-49D0-B0B4-6E43F4734C5A)
    
    'Server2003': The file '\\S4Hyperv2.domain.com\VMLibrary\OS ISOs\MSDN_Server2003_32bit_standard.iso' does not have the required security settings. Error: 'General access denied error' (0x80070005). To fix the security settings, remove the device associated with this file from the virtual machine and then add it again. (Virtual machine 911A90E9-7C87-49D0-B0B4-6E43F4734C5A) 
     (Unknown error (0x8001)) 
    
    Recommended Action
    Resolve the issue in Hyper-V and then try the operation again
    Friday, May 1, 2009 3:58 PM
  • One suggestion for those who think they are doing all the share/NTFS permissions and delegation but still have problems (as I did) - when setting up delegation, you can either chose "Use Kerberos only" (which appears to be the default), or "use any authentication protocol".  It appears that you MUST change from the default to "use any authentication protocol". 

    thanks

    Martin
    Tuesday, August 25, 2009 6:38 PM
  • Fine that is a solution but most of time these "ISO" file include keys and access cannot be allowed to just any one even if he/she is "authenticated user"

    I dont consider this as a solution

    kindly provide a proper solution which enabled restricted admin (Virtualization Admins) access  to vmm library and also solves ISO problem

    /Abdul Jaleel Malik
    Tuesday, January 5, 2010 6:28 AM
  • I have almost the same:

    SCVMM 2008 R2 (2.0.4273.0) with all patches, as well our 2 HyperV Nodes.

    I can migrate with the Failover Cluster Management Console, I can add a shared ISA when the VM is created, but...

    I can't create the VM if I had the Shared ISA in the initial config... and I can't do a "Migration" with SCVMM with an shared ISO bound to my VM... I get this error:

    "Virtualization platform on host HyperV2.hakama.ch does not support shared DVD ISO images.
    Remove the shared ISO image from hardware profile or select a different host.
    ID: 11028"

    I think it's a bug. I'll wait a bit for a fix, I hope MS has already seen it.

    And for the Access level that you need, you should note that you can follow the steps of microsoft only if you have a windows 2003 native domain (I don't think the forest level has an impact).

    Monday, July 19, 2010 3:32 PM
  • Create folder C:\ISO.  Share the folder with authenticated users.  Set NTFS permission.  Add the share to your library.  You are allowed more than the default.  Keep your VHDs and keys in a different share only accessible by restricted admins. 
    Friday, July 23, 2010 7:28 PM
  • Been suffering from a similar problem with a 2-node Hyper-V cluster and a separate VMM server.  I followed all the instructions, adding machine accounts to the share/NTFS etc. with no success.  Then, I came across this KB article.

    http://support.microsoft.com/kb/2285882

    Bob's your uncle.  Made the amendment suggested and can now happily attach shared ISO images to VMs.

    • Proposed as answer by BigDavey Wednesday, July 28, 2010 1:24 PM
    Wednesday, July 28, 2010 1:24 PM