locked
Update Media Content FAILS - "There is not enough space on the disk." RRS feed

  • Question

  • Microsoft Deployment Toolkit 2013 Update 2 (6.3.8330.1000)

    I have created a Media profile to use for offline deployments. I have set the variable "SkipWimSplit" in the Settings.xml to TRUE in order to extract the whole deployment ISO onto one partition of an external USB. The Media path is pointing to a shared folder I set up on my server, on a partition that has plenty of room to spare. I made sure to use a different folder than the one my actual Deployment Share is living on, as recommended.

    Some other things to note on the server are that it is running 2012 R2, data de-duplication is enabled and I used "Storage Spaces" to create logical disks/volumes.

    The very first time I ran the "Update Media Content" (right after I created it), it worked great. However, trying to run it subsequent times - after I update some drivers, for example - it always fails with this message:

    

    Tuesday, July 5, 2016 3:52 PM

All replies

  • How big is the disk or volume that the media is being written to?  What is the total size of the media that was written to it?
    Thursday, July 7, 2016 1:47 PM
  • Hello,

    I have created a logical volume on my 2012 server using "Storage Spaces" that is 2TB in size. The deployment .ISO that is created is about ~50GB in size. Interestingly, when I run the "Update Media Content" function w/ the "SkipWimSplit" variable set to TRUE, the process completes without any errors... So the failure has something to do w/ the trying to split the .WIM.

    Thursday, July 7, 2016 10:16 PM
  • Split wim is not about splitting the ISO image, it's about splitting the WIM file.

    Specifically, are you copying the media content to a USB flash disk? And if so did you format it with Fat32 or NTFS? How big is the content you are copying to the disk? Do you need to boot from any machine that has UEFI (Windows 8 and 10) with Secure Boot?

    If you formatted it using NTFS, you won't be able to boot using UEFI in Secure Boot mode.

    If you formatted it using Fat32, then the *largest* size the main partition can be is 32B, if your ISO image is really 50GB, then where is the extra 18GB going? additionally, Fat32 also has a limitation on the largest file size, Which can only be 2GB, where the splitwim feature is used.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Saturday, July 9, 2016 9:39 PM