locked
Problem with setting Voice Route Alternate Caller ID RRS feed

  • Question

  • Im trying to set AlternateCallerID on a Voice Route.. I want it to start with 0, and the help (http://technet.microsoft.com/en-us/library/gg412893.aspx) says "In other words, the value can begin with a plus sign (+) but doesn’t need to; must consist of any number of digits... ".

    Zero is a digit? Can't I have a zero in the beginning?

    Wednesday, July 6, 2011 12:26 PM

Answers

  • It must match the regular expression in that technet article:

    (\+)?[1-9]\d*(;ext=[1-9]\d*)?.

    0 is not an acceptable first digit.  How would there be an acceptable E.164 number beginning with 0 as a caller ID?


    Mark King | MVP: Lync Server | MCTS:UC Voice | MCITP x3 :Lync, Enterprise Messaging 2010, EA | MCSE: Messaging | blog.unplugthepbx.com
    • Marked as answer by Sean_Xiao Thursday, July 14, 2011 1:22 AM
    Wednesday, July 6, 2011 3:04 PM
  • The parameter AlternatedCallerId value can't begin with 0. The regular expression (\+)?[1-9]\d*(;ext=[1-9]\d*)? specify the value consist any number of digits [1-9].


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Sean_Xiao Thursday, July 14, 2011 1:22 AM
    Thursday, July 7, 2011 5:49 AM
  • You would have to do this with a gateway or session border controller.  Your SIP trunk provider must not be certified for Lync without a gateway if they require it to start with a 0.

    Mark


    Mark King | MVP: Lync Server | MCTS:UC Voice | MCITP x3 :Lync, Enterprise Messaging 2010, EA | MCSE: Messaging | blog.unplugthepbx.com
    • Marked as answer by Sean_Xiao Thursday, July 14, 2011 1:22 AM
    Friday, July 8, 2011 9:30 PM

All replies

  • It must match the regular expression in that technet article:

    (\+)?[1-9]\d*(;ext=[1-9]\d*)?.

    0 is not an acceptable first digit.  How would there be an acceptable E.164 number beginning with 0 as a caller ID?


    Mark King | MVP: Lync Server | MCTS:UC Voice | MCITP x3 :Lync, Enterprise Messaging 2010, EA | MCSE: Messaging | blog.unplugthepbx.com
    • Marked as answer by Sean_Xiao Thursday, July 14, 2011 1:22 AM
    Wednesday, July 6, 2011 3:04 PM
  • The parameter AlternatedCallerId value can't begin with 0. The regular expression (\+)?[1-9]\d*(;ext=[1-9]\d*)? specify the value consist any number of digits [1-9].


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Sean_Xiao Thursday, July 14, 2011 1:22 AM
    Thursday, July 7, 2011 5:49 AM
  • Ok, then the formulation is incorrect :)

    My SIP trunk provider doesn't accept E164 numbers, they want it to be 0<NDC><SN>@ip for national calls... Is there anyway to get that result?

    Thursday, July 7, 2011 9:40 AM
  • You would have to do this with a gateway or session border controller.  Your SIP trunk provider must not be certified for Lync without a gateway if they require it to start with a 0.

    Mark


    Mark King | MVP: Lync Server | MCTS:UC Voice | MCITP x3 :Lync, Enterprise Messaging 2010, EA | MCSE: Messaging | blog.unplugthepbx.com
    • Marked as answer by Sean_Xiao Thursday, July 14, 2011 1:22 AM
    Friday, July 8, 2011 9:30 PM
  • Hi Mark,

    Thats true, they are not certified. Now, they want to be ;)

    Thank you for your answers!

    Wednesday, July 13, 2011 1:01 PM