locked
On-Screen Keyboard (same bug in Vista and XP) RRS feed

  • Question

  • The built in both Vista and XP On-Screen Keyboard utility has common bugs, steps to reproduce :


    1. Start Menu/Orbit > Accessories > Accessibility > On-Screen Keyboard (system32 > osk.exe), which by default is extended and looks this way :






    2. Go to its menu called "Keyboard" (next to "File") and change from "Extended" to "Standard" :





     

    3. Close the on-screen keyboard now - it is important to close !





    4. Start the on-screen keyboard, you will get it "Standard" this way :
     





    5. Minimize it to tray : 







    6. Restore it from tray - you will get the keyboard BUGGY this way :

    :





    7. To restore the keyboard's letters, there are two choices :

    - to restart the keyboard utility (and have the bug again as soon as the keyboard is MINIMIZED/RESTORED)

    - to go to "Keyboard" options and change any option there - the letters will be restored now and the keyboard can be used no problem, UNTIL NEXT restart.












    Secondt on-screen keyboard bug :


    Very rarely, might be  due to an accidental key pressing (but I'm not sure at all), the on-screen keyboard window is rolled down to its border like this :





    Is there a hotkey to restore the window size ?  

    Tell me please. In this case I can only use a 3rd party extension for the on-screen keyboard called  On-Screen Keyboard Magic, which allows me to resize the window.


    Will there be a KB fix ?   Or  a power toy  ?









    Thank you,

    - Roman.



    Monday, May 5, 2008 4:06 PM

All replies

  • I also have this problem - although I didn't take the time to reproduce and document the issue as thoughly as Roman did here.

     

    Also occurs on:

    British Vista home premium

    Friday, November 21, 2008 2:45 AM
  •  Yes, sure but this is not the only bug in this funny Microsoft program. When I try to write something in another language (example: Persian) within Internet Explorer, the layout would not even get changed into the Persian layout. So it stays as English layout and there'd be no way of knowing what or where to click to write a word in Persian language (must be the same for other similar languages as well). It is really surprising me that Microsft doesn't care for these bugs and use the same garbage in Windows Vista and probably in Windows 7 as well.
    However I can use it for writing Persian words in Microsoft Office word, then copy and paste them in IE later. It feels that I am still working with Windows 95 anyway!
    Sunday, January 18, 2009 10:56 PM
  • I had this problem too. When you're having the blue screen, simply go to Keyboard and switch it back to Enhanced Keyboard. It's back to normal. Funny bug though.
    Monday, January 19, 2009 4:11 AM
  • Exactly, Frankoza, I too have many times noticed this other bug you described, and the bug occurs only with IE7 + On-Screen Keyboard.  Using a different browser can help.

    I don't know, can we guys hope to get fixes ?

    Tuesday, February 10, 2009 1:39 PM
  •  

    I have a number of Touch Screen Panel PCs, all running Windows XP Pro, which are going to be used as equipment controllers (they were never equipped with a keyboard or mouse).  Also considering they are connected to the internet, I do not want to circumvent the login process by using the automatic login feature.  I really need to get the On Screen Keyboard (osk.exe) to work during login and with a user account (FBS2).  To date I have not been able to get it to work for both.  This is what I have done: I make the following change through regedit to HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ WindowsNT\ Cu rrentVersion\ Winlogon, added osk.exe to the SYSTEM entry.  Then after a reboot, the OSK launches along with the login screen, and it works great, could add account name (FBS2) and password (qwe098QWE).  However, after I actually was logged in as FBS2 (admin) I can’t launch the osk.exe keyboard.  And, when I open the task manager, I can see the osk.exe program is running under the SYSTEM vice FBS2 account.  Now, it’s basically running in the background, how do I make it run in the foreground, so I can use it? And, I did seem to need to run it as SYSTEM to get it to launch at the login. I have manually stopped osk.exe, through the task managerand, launched it again, but then it was running under the FBS2 account and I will not be able to do this once the Panel PC are installed.  After playing around with the registry, based on the advice I received, I still can’t get it to work for the login and user account??  

    • Proposed as answer by THIANLIANGPING Friday, August 17, 2012 4:20 AM
    Tuesday, March 10, 2009 6:51 PM