locked
Installing on Windows Server 2016 - Windows Fabric Host Service won't start RRS feed

  • Question

  • I'm trying to install Skype for Business on Windows Server 2016.

    I've tried twice, reinstalling Windows in between but i still can't get it working.

    I'm doing the following:

    • Installing and updating Windows 
    • Installing IIS/.NET prerequisites
    • Install SfB RTM and assign certs (we already have an existing topology, so i've just created a new pool and published the topology)
    • Update SfB to the latest CU
    • Run Start-CSPool

    When attempted to run Start-CSPool the Front End service and Windows Fabric Host Service get stuck in the starting state.  Get-CsPoolFabricState also fails with error:

    Get-CsPoolFabricState : An error occurred while receiving the HTTP response tohttps://server.domain.com/LiveServer/UserPinManagement/FabricManagement/. This could be due to the service endpointbinding not using the HTTP protocol. This could also be due to an HTTP request context being aborted by the server(possibly due to the service shutting down). See server logs for more details.

    Looking the Fabric logs fabric setup is failing constantly and just seems to keep trying in a loop.  Error messages include

    53761 Method QueryDataCollectorSet failed with HRESULT: -2144337918
    23041 FabricSetup operation returned errorcode E_FAIL
    23041 FabricSetup process exited with result E_FAIL
    53760 EventTraceInstaller::Install failed with error E_FAIL, Rolling back

    If i change the Fabric service to run as NETWORK SERVICE it will start, but then i get a load more errors in the Fabric event log such as those below.  All our other 2012 servers running S4B run the Windows Fabric service as Local System anyway.

    ParseConfigSettings: ErrorCode=E_FAIL, FileName=C:\ProgramData\Windows Fabric\FabricHostSettings.xml
    TryParseHostNameAddress: cannot convert '<Port>' in address '<IPorFullyQualifiedDomainName>:<Port>' to tcp port

    Anyone know how to get Skype for Business running on Server 2016?  

    I've tried

    • installing SQL 2014 SP2 and the latest CU
    • uninstalling and reinstalling the Windows Fabric service / deleting the Fabric host settings in ProgramData
    • Disabling and enabling the firewall


    • Edited by DJL Wednesday, July 19, 2017 6:30 PM
    Wednesday, July 19, 2017 6:28 PM

All replies

  • Hi DJL,

    Please check if you have correct certificate for your SFB server, the following document is for your reference, it’s same to SFB server 2015
    https://blogs.technet.microsoft.com/uclobby/2013/09/16/renewing-lync-server-20102013-certificates/

    Try to run the following cmdlet to reset the Registrar and Windows fabric services for the pool.

    Reset-CsPoolRegistrarState -PoolFqdn "Pool01.Contoso.com" -ResetType FullReset, for details, please refer to https://technet.microsoft.com/en-gb/library/jj619172.aspx

    Make sure your SFB server has the latest update.


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 20, 2017 7:04 AM
  • Hi Alice,

    Thanks for your reply.  

    I'm running the latest SfB CU and i believe the certificate assigned is correct - I've requested a new certificate several times and been through the blog post you suggested.

    Running Reset-CsPoolRegistrarState results in the following error:

    Reset-CsPoolRegistrarState : Fabric version for computer server.domain.com is unknown. Reset operation is aborted.
    At line:1 char:1
    + Reset-CsPoolRegistrarState -PoolFqdn "server.domain.com" -ResetTyp ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Reset-CsPoolRegistrarState], ManagementException
        + FullyQualifiedErrorId : Error resetting fabric state. For details, see inner exception.,Microsoft.Rtc.Management
       .Hadr.ResetPoolFabricStateCmdlet


    Thursday, July 20, 2017 9:29 AM
  • Hi DJL,

    Thanks for your response.

    Normally, we could install SFB server 2015 on windows server 2016, for your issue, please check if there are any event IDs in SFB server application log.


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Alice-Wang Monday, July 31, 2017 9:53 AM
    • Unproposed as answer by DJL Monday, July 31, 2017 10:13 AM
    Tuesday, July 25, 2017 6:51 AM
  • Hi Alice,

    The issue appears to be with Windows Fabric Setup as per the original post.

    I've managed to install SfB Edge on Windows Server 2016, but cannot get SfB Front End working.

    • I've reinstalled Windows Server 2016 5 times
    • Windows Server 2016 is fully up to date
    • I'm installing the latest SfB CU
    • I've put the server in a separate OU with no group polices being applied
    • I've checked the certificates and they are all the same (apart from the server names) as our working SfB FE servers running on Windows Server 2012

    Event Log

    Event 50011, LS AppDomain Host Process.  Failed to start Fabric Pool Manager. Cause: The Server failed to start the Fabric Pool Manager.  This should not occur under normal operations conditions. Resolution: Ensure that all the Front-Ends configured for this Pool are up and running.

    Event 1000, Application Error. Faulting application name: FabricHost.exe, version 3.0.8549.9492. Exception code: 0xc0000602.


    Monday, July 31, 2017 10:25 AM
  • Monday, July 31, 2017 5:42 PM
  • Exact same Problem here - no matter what i try i can't get Fabric Pool Manager to work.

    Did you ever resolve this DJL?

    Tuesday, January 23, 2018 9:23 PM
  • Hi Oliver,

    My problem was due to 4Kn hard disks, which SfB 2015 doesn't currently support.  I've posted about it here: 

    https://social.technet.microsoft.com/Forums/en-US/1f3e47e7-2ff6-4834-a0c5-afac3632b649/skype-for-business-doesnt-support-4k-advanced-format-hard-disks?forum=sfbfr


    • Edited by DJL Wednesday, January 24, 2018 8:22 AM
    Wednesday, January 24, 2018 8:21 AM
  • Tuesday, March 6, 2018 8:42 AM